Autoshutdown; you got me stumped.

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Autoshutdown; you got me stumped.

      openmediavault-autoshutdown-1.0.8
      omv 2.2.13

      I am stuck with trying to figure out how to configure autoshutdown. I've the plug-in installed and enabled. Upon boot syslog shows

      Dec 18 12:44:54 omvt110 /etc/init.d/autoshutdown: autoshutdown starting ...
      Dec 18 12:44:54 omvt110 /etc/init.d/autoshutdown: autoshutdown started successful!

      No further entries after that. My autoshutdown.conf

      # This configuration file is auto-generated.
      # WARNING: Do not edit this file, your changes will be lost.
      ENABLE="true"
      CYCLES=6
      SLEEP=10
      RANGE=""
      SHUTDOWNCOMMAND="pm-suspend"
      CHECKCLOCKACTIVE="false"
      UPHOURS="15..20"
      NSOCKETNUMBERS=""
      ULDLCHECK="true"
      ULDLRATE=50
      LOADAVERAGECHECK="false"
      LOADAVERAGE=40
      HDDIOCHECK="true"
      HDDIO_RATE=401
      SYSLOG="true"
      VERBOSE="true"
      FAKE="true"

      Eventually I will specify Sockets; but for now I just would like to verify that the server suspends.

      Since I have Fake / Test Mode enabled, I would expect to see some entries in syslog that would show that the system is trying to suspend; but there are no entries.

      I am also not sure, if the service is actually running. Syslog says yes, but htop filter for 'autoshut' shows nothing. The GUI shows a Red Dot for AutoShutdown under Services.

      Don't know where to go from here. Any help would be very much appreciated.
    • try the default settings first. You can test the suspend method by seeing if your system supports it with pm-is-supported with the flags it supports
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      try the default settings first. You can test the suspend method by seeing if your system supports it with pm-is-supported with the flags it supports
      I've went back to square one. Uninstalled the autoshudown plugin; reinstalled the plugin; enabled Fake and Verbose mode. Did this around 11AM PST; now around 2PM PST nothing logged in syslog. The service still shows a red dot in the GUI.
      I would expect something to be logged: failed attempts; parameters not met, so no shutdown; etc.

      Jan 2 10:57:47 omvt110 /etc/init.d/autoshutdown: autoshutdown stopping failed!
      Jan 2 10:57:48 omvt110 /etc/init.d/autoshutdown: autoshutdown starting ...
      Jan 2 10:57:48 omvt110 /etc/init.d/autoshutdown: autoshutdown started successful!


      # This configuration file is auto-generated.
      # WARNING: Do not edit this file, your changes will be lost.
      ENABLE="true"
      CYCLES=6
      SLEEP=180
      RANGE="2..254"
      SHUTDOWNCOMMAND="shutdown -h now"
      CHECKCLOCKACTIVE="false"
      UPHOURS="6..20"
      NSOCKETNUMBERS="21,22,80,139,445,3689,6991,9091,49152"
      ULDLCHECK="true"
      ULDLRATE=50
      LOADAVERAGECHECK="false"
      LOADAVERAGE=40
      HDDIOCHECK="true"
      HDDIO_RATE=401
      SYSLOG="true"
      VERBOSE="true"
      FAKE="true"
    • Hi all,

      I did an update on the weekend from lastest 2.x to OMV 3.0 and it seems like pm-suspend command is not issued and autoshutdown.sh is stopped.
      When Im performing pm-suspend manually, it's working fine, even WOL from suspend is working.

      In the log file in line 108 where pm-suspend should be issued, it just stopping autoshutdown.sh:

      autoshutdown.log-1.txt

      autoshutdown.conf.txt




      Is there some background info how the plugin is working?
      OMV 3.0 with bpo Kernel running on:
      Board: ASRock Q1900-ITX
      RAM: 4GB DDR3-1066 Kingston ValueRAM
      Case: Coolermaster Elite 120 Advanced
      HDD: 1x 40GB 2.5" Samsung for System and 1x 3TB 3.5" Seagate ST3000DM001 + 1x3TB 3.5" Seagate SV35.5
    • z0rk wrote:

      Pretty disappointing.
      Sorry. I don't use it but still try to maintain it. I guess I need more than just general observations on what going wrong. Someone who knows bash script AND uses the plugin regularly needs to maintain it or at least help me.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi all,

      I managed to get it working again.
      I forgot that I edited my autoshutdown-restart file under /etc/pm/sleep.d/ and after upgrading from OMV 2.x to OMV 3 I had two files in that folder.

      Source Code

      1. autoshutdown-restart
      2. autoshutdown-restart.dpkg-xxxxx not sure about the ending :)

      After deleting the old one and renaming the .dpkg- one to autoshutdown-restart the plugin is working again. So there is no error with that.

      @ryecoaaron: I'm willing to help you if it comes to testing, but my scripting skills are not that good.

      @z0rk:

      Did you try to reboot with the plugin activated? I found out that if you activate the plugin the first time, you need to reboot your machine, since no log entries will be made to autoshutdown.log until the next reboot.
      and activating FAKE mode will not shutdown your machine, but I think you already knew that.

      Does your machine shutdown if you perform one of these commands?

      Source Code

      1. pm-suspend
      2. pm-hibernate
      I'm using autoshutdown for years and if Suspend-to-RAM or HIBERNATE is enabled in BIOS the script will work. If you have any questions I'm trying my best to help you.
      OMV 3.0 with bpo Kernel running on:
      Board: ASRock Q1900-ITX
      RAM: 4GB DDR3-1066 Kingston ValueRAM
      Case: Coolermaster Elite 120 Advanced
      HDD: 1x 40GB 2.5" Samsung for System and 1x 3TB 3.5" Seagate ST3000DM001 + 1x3TB 3.5" Seagate SV35.5