Openmediavault-ups 3.2.7 error

    • OMV 3.x
    • Resolved
    • Openmediavault-ups 3.2.7 error


      I use openmediavault 3.0.59 (installed on a custom debiann jessie installation) and I when I installed openmediavault-ups 3.2.7.

      When I enable the plugin, I got this error:

      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start nut-server 2>&1' with exit code '1': A dependency job for nut-server.service failed.

      I used this directives:
      driver = usbhid-ups
      port = usb

      I don't know what to do ...

      Thanks for your help.

      The post was edited 1 time, last by TheFuriousSnail ().

    • Hi there,
      I encountered this issue (I'm a noob) and I'd like to document how I solved this for anyone that stumbles upon this in the future. Here's what I did:

      I stopped the services I thought were relevant. I used the instructions from here:

      What I did was open the CLI (either through SSH or on device) and typed:
      ls /etc/init.d

      Then I looked for services that seemed relevant, In this case I was looking for anything with NUT(network UPS Tools) or UPSD.
      I found two services called nut-server and nut-client.

      I then typed:
      sudo systemctl stop nut-client
      sudo systemctl stop nut-server

      I then could enter the web interface and enter my information and click apply without an error message. After that, I restarted the PC and everything worked.
      MY understanding is it is necessary for you to have driver, port, and description fields filled in, everything else isn't necessary.

      What I tried that didn't work/My questions:
      I tried following this guide
      and trying upsd -c stop but the system kept telling me think) was not found.
      I interpreted that to mean that the system is attempting to shutdown via using the configuration file but that file didn't exist. Can someone help me understand?

      Best of luck to everyone and hoped that helped
    • Spidertech500 wrote:

      I encountered this issue
      Which issue do you encounter?

      Spidertech500 wrote:

      I then could enter the web interface and enter my information and click apply without an error message.
      If this is your error (error message when clicking on apply) then this is different from the thread starter´s issue ("A dependency job for nut-server.service failed.").

      If you get an error while clicking on "apply" then please ensure that your UPS is powered on and the (USB-) data interface is physically connected to you NAS.
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • Users Online 1

      1 Guest

    • Tags