VirtualBox plugin error

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • VirtualBox plugin error

      Hello guys,

      Today I've installed VirtualBox plugin from OMV-extras and here is result:

      Can anyone help here?
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!
    • It must not have installed properly. I am guessing you don't have the headers installed. What is the output of:

      dpkg -l | grep -E "openm|linux"
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Here is output:

      ii console-setup-linux 1.123 all Linux specific part of console-setup
      ii doc-linux-pl 2002.06.14-2 all Linux docs in Polish: HOWTO - ascii version
      ii doc-linux-pl-html 2002.06.14-2 all Linux docs in Polish: HOWTO - html version
      ii libselinux1:amd64 2.3-2 amd64 SELinux runtime shared libraries
      ii libv4l-0:amd64 1.6.0-2 amd64 Collection of video4linux support libraries
      ii libv4lconvert0:amd64 1.6.0-2 amd64 Video4linux frame format conversion library
      ii linux-base 4.3~bpo8+1 all Linux image base package
      ii linux-compiler-gcc-4.8-x86 3.16.36-1+deb8u2 amd64 Compiler for Linux on x86 (meta-package)
      ii linux-compiler-gcc-4.9-x86 4.8.11-1~bpo8+1 amd64 Compiler for Linux on x86 (meta-package)
      ii linux-headers-3.16.0-4-amd64 3.16.36-1+deb8u2 amd64 Header files for Linux 3.16.0-4-amd64
      ii linux-headers-3.16.0-4-common 3.16.36-1+deb8u2 amd64 Common header files for Linux 3.16.0-4
      ii linux-headers-4.8.0-0.bpo.2-amd64 4.8.11-1~bpo8+1 amd64 Header files for Linux 4.8.0-0.bpo.2-amd64
      ii linux-headers-4.8.0-0.bpo.2-common 4.8.11-1~bpo8+1 amd64 Common header files for Linux 4.8.0-0.bpo.2
      ii linux-headers-amd64 4.8+77~bpo8+1 amd64 Header files for Linux amd64 configuration (meta-package)
      ii linux-image-3.16.0-4-amd64 3.16.36-1+deb8u2 amd64 Linux 3.16 for 64-bit PCs
      ii linux-image-4.8.0-0.bpo.2-amd64 4.8.11-1~bpo8+1 amd64 Linux 4.8 for 64-bit PCs (signed)
      ii linux-image-amd64 4.8+77~bpo8+1 amd64 Linux for 64-bit PCs (meta-package)
      ii linux-kbuild-3.16 3.16.7-ckt20-1 amd64 Kbuild infrastructure for Linux 3.16
      ii linux-kbuild-4.8 4.8.11-1~bpo8+1 amd64 Kbuild infrastructure for Linux 4.8
      ii linux-libc-dev:amd64 3.16.36-1+deb8u2 amd64 Linux support headers for userspace development
      ii openmediavault 3.0.59 all Open network attached storage solution
      ii openmediavault-apttool 3.3 all apt tool plugin for OpenMediaVault.
      ii openmediavault-backup 3.3.5 all backup plugin for OpenMediaVault.
      ii openmediavault-deluge 3.2 all OpenMediaVault Deluged plugin
      ii openmediavault-fail2ban 1.3.1 all OpenMediaVault Fail2ban plugin
      ii openmediavault-keyring 1.0 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-letsencrypt 3.1 all Generate free and valid SSL certificates for OMV
      ii openmediavault-locate 3.3 all locate plugin for OpenMediaVault.
      ii openmediavault-lvm2 3.1.3 all OpenMediaVault Logical Volume Manager (LVM2) plugin
      ii openmediavault-mysql 3.0.4 all MySQL plugin for OpenMediaVault.
      ii openmediavault-nginx 3.0.9 all Nginx plugin for OpenMediaVault.
      ii openmediavault-omvextrasorg 3.4.14 all OMV-Extras.org Package Repositories for OpenMediaVault
      ii openmediavault-plexmediaserver 3.7 all OpenMediaVault Plex Media Server plugin
      ii openmediavault-sensors 3.0 all Provides a cpu temperature monitor
      ii openmediavault-shellinabox 3.4 all Web-based SSH client.
      ii openmediavault-sonarr 3.2 all OpenMediaVault Sonarr plugin
      iU openmediavault-virtualbox 3.0.6 all VirtualBox plugin for OpenMediaVault.
      ii util-linux 2.25.2-6 amd64 Miscellaneous system utilities
      ii util-linux-locales 2.25.2-6 all Locales files for util-linux
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!
    • Uninstall it 1st or just run apt -f when it is installed?

      @@EDIT

      and also I had installed 4.3 manually previously. Should I first purge whole package and delete user/group/init scripts?
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!
    • kawu2 wrote:

      and also I had installed 4.3 manually previously. Should I first purge whole package and delete user/group/init scripts?
      Yes. I would purge everything virtualbox. The 4.3 package can cause problems with the 5.0 package.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Yeah, you were right, purging previous VB solved installation problem.
      But now new one showed up:

      Can you give me a hand with this also?

      And when trying to go to users or groups in WebUI this comes:


      Also lost whole access to WebUI after refresh. It was set on port 802...
      Now I really need help :D

      @@EDIT

      I purged whole VB installation but still no WebUI access
      It says 502 bad gateway
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!

      The post was edited 2 times, last by kawu2 ().

    • omv-firstaid should fix the web interface. Then I would purge everything again and make sure to remove /usr/share/phpvirtualbox/config.php
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • There are no files in /usr/share/ of phpvirtualbox.
      omv-firstaid did not repaired WebUI access, still 502 bad gateway :(
      I just used second option of aid.

      Rest of my nginx sites are accessible, only UI died.

      @@EDIT
      Maybe this will be some hit but I found out there is no .sock of php5-fpm-openmediavault-webgui in /var/run

      I tried to omv-mkconf php5fpm and restart service but:

      root@OMV 08:46:39 ~ → systemctl status php5-fpm.service
      ● php5-fpm.service - The PHP FastCGI Process Manager
      Loaded: loaded (/lib/systemd/system/php5-fpm.service; enabled)
      Active: failed (Result: exit-code) since czw 2017-01-05 08:46:48 CET; 863ms ago
      Process: 3645 ExecStart=/usr/sbin/php5-fpm --nodaemonize --fpm-config /etc/php5/fpm/php-fpm.conf (code=exited, status=78)
      Process: 3640 ExecStartPre=/usr/lib/php5/php5-fpm-checkconf (code=exited, status=0/SUCCESS)
      Main PID: 3645 (code=exited, status=78)

      sty 05 08:46:48 OMV php5-fpm[3645]: [05-Jan-2017 08:46:48] ERROR: [pool 2328a6af-c83b-4292-8247-b5fd0f1d22e1] cannot get uid for user 'vbuser'
      sty 05 08:46:48 OMV php5-fpm[3645]: [05-Jan-2017 08:46:48] ERROR: FPM initialization failed
      sty 05 08:46:48 OMV systemd[1]: php5-fpm.service: main process exited, code=exited, status=78/n/a
      sty 05 08:46:48 OMV systemd[1]: Failed to start The PHP FastCGI Process Manager.
      sty 05 08:46:48 OMV systemd[1]: Unit php5-fpm.service entered failed state.

      @@EDIT
      Removing 2328a6af-c83b-4292-8247-b5fd0f1d22e1.conf from /etc/php5/fpm/pool.d solved my problem! Now UI is up and ready :D
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!

      The post was edited 4 times, last by kawu2 ().

    • I do not edit previous post on purpose.

      After repairing UI I tried to install VB one more time with same effect.
      I'm wondering if I should add user and group vbuser manually to get rid of this error?

      It would be great to have VBOX working on my OMV3 so I still look for help here
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!

      The post was edited 1 time, last by kawu2 ().

    • kawu2 wrote:

      I'm wondering if I should add user and group vbuser manually to get rid of this error?
      I don't think so. If you do, you need to create a password for that user and add it to the /etc/default/openmediavault-virtualbox file.


      kawu2 wrote:

      It would be great to have VBOX working on my OMV3 so I still look for help here
      I can't figure out why it isn't working. It works fine every time I install it. There must be something leftover from your 4.3 install.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I'm not Linux expert so I don't know what and where should I look for.
      @@EDIT
      I was using this script to install 4.3 - mby it helps
      gist.github.com/bplower/b7e193fc3861e964c367

      I've installed 5.0.30 + phpVirtualBox 5.0-5 manually and it's working (but php have some problems)
      Problem is that vboxwebsrv do not start automatically after reboot and also when I press Settings of VM it hangs on loading...

      Ehhhh, mby in weekend I'll try to fully reinstall OMV (gosh, not next time :((()

      I'll ask it here but I know that should be asked in different section.
      Do you guys can/want/it is possible to create KODI plugin?
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!
    • kawu2 wrote:

      I was using this script to install 4.3 - mby it helps
      Probably but all of this manually installed stuff is just making thing harder to figure out what is wrong. I'll have to look at the script this weekend to see what it did. First glance is that it installs apache.... Not good.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Yes, it installed apache but I moved files to nginx and run thru it, was working perfectly until kernell change :P
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!
    • kawu2 wrote:

      Yes, it installed apache but I moved files to nginx and run thru it, was working perfectly until kernell change
      When you change the kernel, you have to recompile the virtualbox module. And it may have been working perfectly but that doesn't mean I know how it configured to help you.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Yeah, of course I know that.
      Wasn't aware of reconfigure module and here problem started :/
      I will wait for your free time and your kind help with plugin install :)

      @@EDIT
      So good news here!
      I purged whole VB install, removed all services from startup, removed all startup scripts, rebooted OMV.
      Installed VB from plugin and no bad gateway error! :D
      But here is new error:

      Mby this one will be solved faster :)

      And here is output from phpvirtualbox:


      OMV wrote:

      Exception Object
      (
      [message:protected] => Error logging in to vboxwebsrv.
      [string:Exception:private] =>
      [code:protected] => 64
      [file:protected] => /usr/share/phpvirtualbox/endpoints/lib/vboxconnector.php
      [line:protected] => 220
      [trace:Exception:private] => Array
      (
      [0] => Array
      (
      [file] => /usr/share/phpvirtualbox/endpoints/lib/vboxconnector.php
      [line] => 3147
      [function] => connect
      [class] => vboxconnector
      [type] => ->
      [args] => Array
      (
      )

      )

      [1] => Array
      (
      [file] => /usr/share/phpvirtualbox/endpoints/lib/vboxconnector.php
      [line] => 951
      [function] => remote_vboxGetGuestOSTypes
      [class] => vboxconnector
      [type] => ->
      [args] => Array
      (
      [0] =>
      )

      )

      [2] => Array
      (
      [file] => /usr/share/phpvirtualbox/endpoints/api.php
      [line] => 316
      [function] => __call
      [class] => vboxconnector
      [type] => ->
      [args] => Array
      (
      [0] => vboxGetGuestOSTypes
      [1] => Array
      (
      [0] =>
      [1] => Array
      (
      [0] => Array
      (
      [data] => Array
      (
      [responseData] => Array
      (
      )

      )

      [errors] => Array
      (
      )

      [persist] => Array
      (
      )

      [messages] => Array
      (
      )

      )

      )

      )

      )

      )

      [3] => Array
      (
      [file] => /usr/share/phpvirtualbox/endpoints/api.php
      [line] => 316
      [function] => vboxGetGuestOSTypes
      [class] => vboxconnector
      [type] => ->
      [args] => Array
      (
      [0] =>
      [1] => Array
      (
      [0] => Array
      (
      [data] => Array
      (
      [responseData] => Array
      (
      )

      )

      [errors] => Array
      (
      )

      [persist] => Array
      (
      )

      [messages] => Array
      (
      )

      )

      )

      )

      )

      )

      [previous:Exception:private] =>
      )


      Location:127.0.0.1:18083/
      And next one when reinstalling plugin, it was posted in installation log of plugin:

      OMV wrote:

      WARNING: The character device /dev/vboxdrv does not exist.
      Please install the virtualbox-dkms package and the appropriate
      headers, most likely linux-headers-amd64.

      You will not be able to start VMs until this problem is fixed.
      @@EDIT
      Problem solved by your previous post :)

      ryecoaaron wrote:

      If you do, you need to create a password for that user and add it to the /etc/default/openmediavault-virtualbox file.
      So I followed this because I didn't remove user/group :)

      Now VB is working perfectly!

      Thank you for support ryecoaaron!
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!

      The post was edited 5 times, last by kawu2 ().

    • One last thing left for me.
      Why console is greyed out? Is it working for some1 or its just unavailable?
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!
    • kawu2 wrote:

      Why console is greyed out? Is it working for some1 or its just unavailable?
      The console? Can you post a screenshot?
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I've made console icon active, but I can not see anything
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!
    • Has that ever worked on virtualbox 5.0? Maybe something is disabled with the virtualbox package by default?
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!