Announce OMV with OS X Model Identifier/Hostname?

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Announce OMV with OS X Model Identifier/Hostname?

      Hey guys,

      I just got started with OMV, running 3.0.59 on a Raspberry Pi 3 B. So far I’m super happy with it, especially all the OS X related options and services right out of the box are great for me and my little Mac ecosystem. I’m almost ready to throw out my old Mac Mini server and let OMV handle everything…

      That being said, one literally tiny thing that does bother me is the fact that the Pi does announce itself as any old Windows machine in Netatalk and therefore creates a weird Cinema Display icon (of all things) in all Finder sidebars. And it’s hostname is lowercase and can’t have spaces. The case for my built is an old Power Mac G5 case and I would love for it to announce itself with the corresponding icon and a nice and clean hostname. :D While I know this isn’t really a OMV but rather a Linux issue I thought there might be an OMV solution to it.

      I looked into trying this really old tip to configure avahi to add a fake model identifier, but I already failed at finding afpd.service if it even is still relevant today. Not sure if I could have changed the hostname this way though, which I would really like to do as well.

      So my question is, is there any way to do this with maybe an OMV plugin or service? Or could you guys point me in a direction for which file to edit?

      Thanks a ton in advance,
      V
    • Vandal wrote:

      So my question is, is there any way to do this with maybe an OMV plugin or service? Or could you guys point me in a direction for which file to edit?
      There must be a way, the problem is now netatalk3 talks directly to avahi to configure the announce, so the old avahi configuration was unnecessary. You'll have to ask the netatalk mailing list or read documentation on how to disable the netatalk-avahi conversation or rebuild netatalk binary without avahi support.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Thanks a lot for your help, really appreciate it.

      I added "zeroconf = no" to the extra options and then created the following afpd.service in /etc/avahi/services/

      XML Source Code: afpd.service

      1. <?xml version="1.0" standalone='no'?><!--*-nxml-*-->
      2. <!DOCTYPE service-group SYSTEM "avahi-service.dtd">
      3. <service-group>
      4. <name replace-wildcards="yes">%h</name>
      5. <service>
      6. <type>_afpovertcp._tcp</type>
      7. <port>548</port>
      8. </service>
      9. <service>
      10. <type>_device-info._tcp</type>
      11. <port>0</port>
      12. <txt-record>model=MacPro</txt-record>
      13. </service>
      14. </service-group>
      Display All
      then restarted avahi with

      $ sudo /etc/init.d/avahi-daemon restart

      Sadly the share doesn't show back up at all, even though avahi-daemon is running

      $ service avahi-daemon status
      ● avahi-daemon.service - Avahi mDNS/DNS-SD Stack
      Loaded: loaded (/lib/systemd/system/avahi-daemon.service; enabled)
      Active: active (running)

      If I revert to no "zeroconf = no" in the extra options the share does come back.

      Did I mess up my afpd.service?

      The post was edited 1 time, last by Vandal: formatting ().

    • You're right, it looks like I did indeed mess up my afpd.service. In vim somehow the first line didn't get pasted, edited it again with nano and it works! I had to flush my icon cache, but now the Mac Pro icon pops up on all machines in the network, amazing! Thanks a ton!

      I also thought I had gotten a little further with changing the server name, namely by trying to edit /etc/avahi/avahi-daemon.conf and /etc/netatalk/afp.confg itself, but no luck there. Neither changing

      [server]
      host-name = My Server Name

      in avahi-daemon.conf (as I found here) nor adding

      [Global]
      hostname = My Server Name

      to afp.confg (as I found here) changed anything.

      In OS X you can set hostname, computer name, and bonjour name separately with scutil, there is nothing similar in Linux, is there?

      The post was edited 2 times, last by Vandal ().