[openmediavault-sabnzbd] Errors were encountered while processing

    • OMV 3.x
    • [openmediavault-sabnzbd] Errors were encountered while processing

      During installation of the SABNzbd plugin from the OMV-Extras Testing, I get the errors in the following posts. (See my next posts for the error as they were to long for on post.)

      I have tried both WebGUI and CLI install process. I cannot find anything recent on this issue on Google so if anyone can give me some help that would be appreciated. Is there a log file for more info?

      The post was edited 1 time, last by thermodust ().

    • Command Line Output of Error:

      Shell-Script

      1. root@debian:~# apt-get install openmediavault-sabnzbd
      2. Reading package lists... Done
      3. Building dependency tree
      4. Reading state information... Done
      5. The following NEW packages will be installed:
      6. openmediavault-sabnzbd
      7. 0 upgraded, 1 newly installed, 0 to remove and 0 not upgraded.
      8. Need to get 0 B/18.4 kB of archives.
      9. After this operation, 61.4 kB of additional disk space will be used.
      10. Selecting previously unselected package openmediavault-sabnzbd.
      11. (Reading database ... 50297 files and directories currently installed.)
      12. Preparing to unpack .../openmediavault-sabnzbd_3.2.2_all.deb ...
      13. Unpacking openmediavault-sabnzbd (3.2.2) ...
      14. Processing triggers for openmediavault (3.0.59) ...
      15. Restarting engine daemon ...
      16. Processing triggers for systemd (215-17+deb8u5) ...
      17. Setting up openmediavault-sabnzbd (3.2.2) ...
      18. Synchronizing state for sabnzbd.service with sysvinit using update-rc.d...
      19. Executing /usr/sbin/update-rc.d sabnzbd defaults
      20. insserv: warning: current start runlevel(s) (empty) of script `sabnzbd' overrides LSB defaults (2 3 4 5).
      21. insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `sabnzbd' overrides LSB defaults (0 1 6).
      22. Executing /usr/sbin/update-rc.d sabnzbd disable
      23. insserv: warning: current start runlevel(s) (empty) of script `sabnzbd' overrides LSB defaults (2 3 4 5).
      24. insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `sabnzbd' overrides LSB defaults (0 1 6).
      25. Adding sabnzbd user...
      26. dpkg: error processing package openmediavault-sabnzbd (--configure):
      27. subprocess installed post-installation script returned error exit status 4
      28. Processing triggers for openmediavault (3.0.59) ...
      29. Restarting engine daemon ...
      30. Errors were encountered while processing:
      31. openmediavault-sabnzbd
      32. E: Sub-process /usr/bin/dpkg returned an error code (1)
      33. root@debian:~#
      Display All
    • WebUI Output of Error:

      Shell-Script

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. The following extra packages will be installed:
      5. curl git git-man libcurl3 liberror-perl par2 python-cffi-backend
      6. python-cheetah python-configobj python-cryptography python-enum34
      7. python-feedparser python-idna python-ipaddress python-openssl python-pyasn1
      8. python-setuptools python-yenc unrar-free unzip
      9. Suggested packages:
      10. git-daemon-run git-daemon-sysvinit git-doc git-el git-email git-gui gitk
      11. gitweb git-arch git-cvs git-mediawiki git-svn python-markdown
      12. python-memcache python-configobj-doc python-cryptography-doc
      13. python-cryptography-vectors python-enum34-doc python-openssl-doc
      14. python-openssl-dbg doc-base python-setuptools-doc pike7.8 pike7.6 pike zip
      15. Recommended packages:
      16. python-libxml2 python-utidylib unar
      17. The following NEW packages will be installed:
      18. curl git git-man libcurl3 liberror-perl openmediavault-sabnzbd par2
      19. python-cffi-backend python-cheetah python-configobj python-cryptography
      20. python-enum34 python-feedparser python-idna python-ipaddress python-openssl
      21. python-pyasn1 python-setuptools python-yenc unrar-free unzip
      22. 0 upgraded, 21 newly installed, 0 to remove and 0 not upgraded.
      23. Need to get 6284 kB of archives.
      24. After this operation, 29.9 MB of additional disk space will be used.
      25. Get:1 http://ftp.us.debian.org/debian/ jessie/main liberror-perl all 0.17-1.1 [22.4 kB]
      26. Get:2 http://ftp.us.debian.org/debian/ jessie/main git-man all 1:2.1.4-2.1+deb8u2 [1267 kB]
      27. Get:3 http://security.debian.org/ jessie/updates/main libcurl3 amd64 7.38.0-4+deb8u5 [259 kB]
      28. Get:4 http://ftp.us.debian.org/debian/ jessie/main git amd64 1:2.1.4-2.1+deb8u2 [3262 kB]
      29. Get:5 https://dl.bintray.com/openmediavault-plugin-developers/erasmus-testing/ jessie/main openmediavault-sabnzbd all 3.2.2 [18.4 kB]
      30. Get:6 http://httpredir.debian.org/debian/ jessie-backports/main python-cffi-backend amd64 1.4.2-2~bpo8+1 [63.6 kB]
      31. Get:7 http://security.debian.org/ jessie/updates/main curl amd64 7.38.0-4+deb8u5 [200 kB]
      32. Get:8 http://ftp.us.debian.org/debian/ jessie/main python-cheetah amd64 2.4.4-3 [204 kB]
      33. Get:9 http://ftp.us.debian.org/debian/ jessie/main python-configobj all 5.0.6-1 [35.3 kB]
      34. Get:10 http://ftp.us.debian.org/debian/ jessie/main python-feedparser all 5.1.3-3 [61.9 kB]
      35. Get:11 http://httpredir.debian.org/debian/ jessie-backports/main python-idna all 2.0-3~bpo8+1 [35.2 kB]
      36. Get:12 http://httpredir.debian.org/debian/ jessie-backports/main python-ipaddress all 1.0.16-1~bpo8+1 [18.1 kB]
      37. Get:13 http://ftp.us.debian.org/debian/ jessie/main par2 amd64 0.6.11-1 [94.3 kB]
      38. Get:14 http://ftp.us.debian.org/debian/ jessie/main python-enum34 all 1.0.3-1 [26.8 kB]
      39. Get:15 http://ftp.us.debian.org/debian/ jessie/main python-yenc amd64 0.4.0-1 [22.8 kB]
      40. Get:16 http://ftp.us.debian.org/debian/ jessie/main unzip amd64 6.0-16+deb8u2 [162 kB]
      41. Get:17 http://ftp.us.debian.org/debian/ jessie/main unrar-free amd64 1:0.0.1+cvs20140707-1 [24.1 kB]
      42. Get:18 http://httpredir.debian.org/debian/ jessie-backports/main python-pyasn1 all 0.1.9-1~bpo8+1 [51.9 kB]
      43. Get:19 http://httpredir.debian.org/debian/ jessie-backports/main python-setuptools all 20.10.1-1.1~bpo8+1 [203 kB]
      44. Get:20 http://httpredir.debian.org/debian/ jessie-backports/main python-cryptography amd64 1.3.4-1~bpo8+2 [207 kB]
      45. Get:21 http://httpredir.debian.org/debian/ jessie-backports/main python-openssl all 16.0.0-1~bpo8+1 [43.2 kB]
      46. Fetched 6284 kB in 1s (3873 kB/s)
      47. Selecting previously unselected package libcurl3:amd64.
      48. (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 47052 files and directories currently installed.)
      49. Preparing to unpack .../libcurl3_7.38.0-4+deb8u5_amd64.deb ...
      50. Unpacking libcurl3:amd64 (7.38.0-4+deb8u5) ...
      51. Selecting previously unselected package curl.
      52. Preparing to unpack .../curl_7.38.0-4+deb8u5_amd64.deb ...
      53. Unpacking curl (7.38.0-4+deb8u5) ...
      54. Selecting previously unselected package liberror-perl.
      55. Preparing to unpack .../liberror-perl_0.17-1.1_all.deb ...
      56. Unpacking liberror-perl (0.17-1.1) ...
      57. Selecting previously unselected package git-man.
      58. Preparing to unpack .../git-man_1%3a2.1.4-2.1+deb8u2_all.deb ...
      59. Unpacking git-man (1:2.1.4-2.1+deb8u2) ...
      60. Selecting previously unselected package git.
      61. Preparing to unpack .../git_1%3a2.1.4-2.1+deb8u2_amd64.deb ...
      62. Unpacking git (1:2.1.4-2.1+deb8u2) ...
      63. Selecting previously unselected package python-cheetah.
      64. Preparing to unpack .../python-cheetah_2.4.4-3_amd64.deb ...
      65. Unpacking python-cheetah (2.4.4-3) ...
      66. Selecting previously unselected package python-configobj.
      67. Preparing to unpack .../python-configobj_5.0.6-1_all.deb ...
      68. Unpacking python-configobj (5.0.6-1) ...
      69. Selecting previously unselected package python-feedparser.
      70. Preparing to unpack .../python-feedparser_5.1.3-3_all.deb ...
      71. Unpacking python-feedparser (5.1.3-3) ...
      72. Selecting previously unselected package par2.
      73. Preparing to unpack .../par2_0.6.11-1_amd64.deb ...
      74. Unpacking par2 (0.6.11-1) ...
      75. Selecting previously unselected package python-cffi-backend.
      76. Preparing to unpack .../python-cffi-backend_1.4.2-2~bpo8+1_amd64.deb ...
      77. Unpacking python-cffi-backend (1.4.2-2~bpo8+1) ...
      78. Selecting previously unselected package python-enum34.
      79. Preparing to unpack .../python-enum34_1.0.3-1_all.deb ...
      80. Unpacking python-enum34 (1.0.3-1) ...
      81. Selecting previously unselected package python-idna.
      82. Preparing to unpack .../python-idna_2.0-3~bpo8+1_all.deb ...
      83. Unpacking python-idna (2.0-3~bpo8+1) ...
      84. Selecting previously unselected package python-ipaddress.
      85. Preparing to unpack .../python-ipaddress_1.0.16-1~bpo8+1_all.deb ...
      86. Unpacking python-ipaddress (1.0.16-1~bpo8+1) ...
      87. Selecting previously unselected package python-pyasn1.
      88. Preparing to unpack .../python-pyasn1_0.1.9-1~bpo8+1_all.deb ...
      89. Unpacking python-pyasn1 (0.1.9-1~bpo8+1) ...
      90. Selecting previously unselected package python-setuptools.
      91. Preparing to unpack .../python-setuptools_20.10.1-1.1~bpo8+1_all.deb ...
      92. Unpacking python-setuptools (20.10.1-1.1~bpo8+1) ...
      93. Selecting previously unselected package python-cryptography.
      94. Preparing to unpack .../python-cryptography_1.3.4-1~bpo8+2_amd64.deb ...
      95. Unpacking python-cryptography (1.3.4-1~bpo8+2) ...
      96. Selecting previously unselected package python-openssl.
      97. Preparing to unpack .../python-openssl_16.0.0-1~bpo8+1_all.deb ...
      98. Unpacking python-openssl (16.0.0-1~bpo8+1) ...
      99. Selecting previously unselected package python-yenc.
      100. Preparing to unpack .../python-yenc_0.4.0-1_amd64.deb ...
      101. Unpacking python-yenc (0.4.0-1) ...
      102. Selecting previously unselected package unzip.
      103. Preparing to unpack .../unzip_6.0-16+deb8u2_amd64.deb ...
      104. Unpacking unzip (6.0-16+deb8u2) ...
      105. Selecting previously unselected package unrar-free.
      106. Preparing to unpack .../unrar-free_1%3a0.0.1+cvs20140707-1_amd64.deb ...
      107. Unpacking unrar-free (1:0.0.1+cvs20140707-1) ...
      108. Selecting previously unselected package openmediavault-sabnzbd.
      109. Preparing to unpack .../openmediavault-sabnzbd_3.2.2_all.deb ...
      110. Unpacking openmediavault-sabnzbd (3.2.2) ...
      111. Processing triggers for man-db (2.7.0.2-5) ...
      112. Processing triggers for mime-support (3.58) ...
      113. Processing triggers for openmediavault (3.0.59) ...
      114. Restarting engine daemon ...
      115. Processing triggers for systemd (215-17+deb8u5) ...
      116. Setting up libcurl3:amd64 (7.38.0-4+deb8u5) ...
      117. Setting up curl (7.38.0-4+deb8u5) ...
      118. Setting up liberror-perl (0.17-1.1) ...
      119. Setting up git-man (1:2.1.4-2.1+deb8u2) ...
      120. Setting up git (1:2.1.4-2.1+deb8u2) ...
      121. Setting up python-cheetah (2.4.4-3) ...
      122. Setting up python-configobj (5.0.6-1) ...
      123. Setting up python-feedparser (5.1.3-3) ...
      124. Setting up par2 (0.6.11-1) ...
      125. Setting up python-cffi-backend (1.4.2-2~bpo8+1) ...
      126. Setting up python-enum34 (1.0.3-1) ...
      127. Setting up python-idna (2.0-3~bpo8+1) ...
      128. Setting up python-ipaddress (1.0.16-1~bpo8+1) ...
      129. Setting up python-pyasn1 (0.1.9-1~bpo8+1) ...
      130. Setting up python-setuptools (20.10.1-1.1~bpo8+1) ...
      131. Setting up python-cryptography (1.3.4-1~bpo8+2) ...
      132. Setting up python-openssl (16.0.0-1~bpo8+1) ...
      133. Setting up python-yenc (0.4.0-1) ...
      134. Setting up unzip (6.0-16+deb8u2) ...
      135. Setting up unrar-free (1:0.0.1+cvs20140707-1) ...
      136. update-alternatives: using /usr/bin/unrar-free to provide /usr/bin/unrar (unrar) in auto mode
      137. Setting up openmediavault-sabnzbd (3.2.2) ...
      138. Failed to stop sabnzbd.service: Unit sabnzbd.service not loaded.
      139. Synchronizing state for sabnzbd.service with sysvinit using update-rc.d...
      140. Executing /usr/sbin/update-rc.d sabnzbd defaults
      141. Executing /usr/sbin/update-rc.d sabnzbd disable
      142. insserv: warning: current start runlevel(s) (empty) of script `sabnzbd' overrides LSB defaults (2 3 4 5).
      143. insserv: warning: current stop runlevel(s) (0 1 2 3 4 5 6) of script `sabnzbd' overrides LSB defaults (0 1 6).
      144. Adding sabnzbd user...
      145. dpkg: error processing package openmediavault-sabnzbd (--configure):
      146. subprocess installed post-installation script returned error exit status 4
      147. Processing triggers for libc-bin (2.19-18+deb8u6) ...
      148. Processing triggers for openmediavault (3.0.59) ...
      149. Restarting engine daemon ...
      150. Processing triggers for systemd (215-17+deb8u5) ...
      151. Errors were encountered while processing:
      152. openmediavault-sabnzbd
      153. >>> *************** Error ***************
      154. <<< *************************************
      155. >>> *************** Error ***************
      Display All
    • May have found issue in an old thread. Yeah Google.

      reverendspam wrote:

      I could not get any of the solutions above to work. A post I found here worked for me and I updated sab to version 1.1.0

      1) install the sab plugin as normal through gui

      2) ssh into OMV and open the file /var/lib/dpkg/info/openmediavault-sabnzbd.postinst

      Source Code

      1. nano /var/lib/dpkg/info/openmediavault-sabnzbd.postinst
      change the line that looks similar to

      Source Code

      1. STABLE=`wget -q http://sabnzbd.org/download/ -O - | \grep sourceforge\.net | grep Linux | \sed 's/.*href=\"\(.*\)\".*/\1/' | sed 's/.*-\(.*\)-.*/\1/'`
      to

      Source Code

      1. STABLE="1.1.0"
      ctrl o to write/save the file



      then ctrl x to exit

      finally force install


      Source Code

      1. apt-get install -f
      Only difference is I changed it to say STABLE="1.2.0". After this it installed and worked. Only notable thing is that the WebGUI states there is an update available but I assume not as that is the latest.
    • They keep doing this with every release, every new release breaks the curl command.

      I have changed it and added checks to use other curl commands if it looks like an invalid response.
      The OMV 3 version should be available in the next hour (or so)

      What I am watching/watched on my Popcorn Hour media player
      omv 2.1.1 stoneburner | 64 bit | omvextrasorg 1.29
      MySQL (Percona) | Newznab | Sonarr | CP | HP | NZBget | YAMJ | CUPS