RTNETLINK answers: File exists |Failed to bring up lo

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • RTNETLINK answers: File exists |Failed to bring up lo

      Hey guys,

      after a lot of googleing and changing the interfaces file my beloved OMV is still hanging @ boot with this message on the very bottom of the screen.
      What did I do to get this error?
      • I have had a configured IPv4 eth0 with a static IP address and gateway.
      • I installed nginx and owncloud - no problems here.
      • I wanted to access my owncloud from the internet, therefor I require a IPv6 address due to my provider and the open port.
      • I enabled IPv6 and set it to dhcp in the GUI (--> think this is were the error sits static IPv4 vs. dhcp IPv6) --> saved it ... now I'm hanging @ boot.
      What I tried so far:
      • got myself a debian live USB stick
      • mounted my omv-hdd
      • edited /etc/host (added the loopback - was missing - is it required?)
      • edited /etc/network/interfaces to only hold "auto lo" and "iface ... inet loopback"
      What else could I do to bring-up loopback again? It really is frustrating :(

    • Hello OMVs!

      I managed to fix my OMV installation. It took a while to figure it out...
      I ran into the avahi service configuring the local network behavior.for somewhat reason it was us full to delete the entry for using IPv6 within the configuration file for this service.

      A reboot then resulted in a filled /etc/networks/interfaces file - I then again deleted all entries about IPv6 and voila...omv was at least booting so I could login in the consoles.
      I then tried to call omv-firstaid, which was working but setting up the network interface failed due to a not startet monit-service. Had to fix some stuff there, then could setup the interface with first aid consol.

      Took me around 4h to figure this stuff out. A pain as some might guess.

      Maybe someone could explain in more detail what might have caused this error.

      Cheeres and happy weekend!
    • I too had this problem. It occured after I inadvertently set OMV to use iPv6 when I was using OMV-Firstaid to troubleshoot connection problems I was having. Finding your post totally saved me from a re-install.

      I manged to start the computer with a live Linux distro, found the /etc/networks/interface on my OMV master drive and commented out any lines that referred to iPv6. Saved the file, re-booted with out the stick and it worked. Apparently, OMV has some issues with iPv6.