IscsI - Add device Gateway Timeout

    • OMV 2.x
    • IscsI - Add device Gateway Timeout

      Hi all,

      I searched and searched, but was surprised I couldn't find any information on what issue I'm facing.

      At any given time I have 24 or more LVM volumes on my OMV rig. Most of these need to be attached to iSCSI LUNs. After a fresh install of OMV (currently 2.2.13) the system recognizes my old LVM volumes and when I go to reconstitute my iSCSI luns: iSCSI>Targets>Add>Lun>Add>Device. The system appears to be polling available volumes for qualified options, but after about 20 seconds it returns:

      Gateway Timeout.

      In what I could search out on timeouts, I tried adding OMV_HTTPREQUEST_TIMEOUT=180000 to /etc/default/openmediavault and /etc/nginx/sites-available/openmediavault-webgui to fastcgi_read_timeout 120s, to no change

      Is there another place I can increase that Timeout?

      Because I'm happy to wait. My only other recourse is to dump a bunch of volumes, make a slew of dummy targets, and then hack configs from the commandline to add devices, which isn't hard, but a titch less convenient.

      Not sure if it matters, but the LVM volumes lay atop physical members that are Raid6/5.

      --------------
      Setup:
      AMD A10-7800
      32gig ram
      22 internal drives in raid6/5 mixes
    • After adding the default, try omv-mkconf nginx then service nginx restart
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Ran:
      omv-mkconf nginx
      service nginx restart


      Attempted to add device to iSCSI lun: Gateway timeout

      Details in the timeout dialog in firefox yielded:

      <html>
      <head><title>504 Gateway Time-out</title></head>
      <body bgcolor="white">
      <center><h1>504 Gateway Time-out</h1></center>
      <hr><center>nginx</center>
      </body>
      </html>

      In Edge:

      <html>
      <head><title>504 Gateway Time-out</title></head>
      <body bgcolor="white">
      <center><h1>504 Gateway Time-out</h1></center>
      <hr><center>nginx</center>
      </body>
      </html>
      <!-- a padding to disable MSIE and Chrome friendly error page -->
      <!-- a padding to disable MSIE and Chrome friendly error page -->
      <!-- a padding to disable MSIE and Chrome friendly error page -->
      <!-- a padding to disable MSIE and Chrome friendly error page -->
      <!-- a padding to disable MSIE and Chrome friendly error page -->
      <!-- a padding to disable MSIE and Chrome friendly error page -->

      and
    • Sorry, it is php timeout.

      omv-mkconf nginx
      omv-mkconf php5fpm
      service php5-fpm restart
      service nginx restart

      Maybe clear your browser cache
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Executed recommended omv-mkconf commands and restarted applicable services.

      No change.

      Emptied cache in all browsers.

      No change.

      Just to confirm, it is expected that
      OMV_HTTPREQUEST_TIMEOUT=180000

      is added as a line at, say, the end of the /etc/default/openmediavault. Or does it have to appear earlier in the configuration file?

      and are there any other timeout values in /etc/nginx/sites-enabled/openmediavault-webgui other than
      fastcgi_read_timeout 60s

      Which I noted just now, when I try to change that value from 60 to something like 180...it reverts back to 60 after I re-run the omv-mkconf commands and restart the services.

      If that is the key, then how do I force that timeout higher?
    • omv-mkconf rewrites config files. So, you don't want to manually change them. Maybe the 180000 is too large?
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Chaged 180000 to 120000

      Executed omv-mkconf for nginx and php5fpm and restarted each respectively.

      Cleared Cache

      This time in the firefox browser just before it displayed the Gateway timeout it showed that "An Error has Occurred", sadly with no further details.

      Is there perhaps any way to Pre-cache the devices so that it doesn't have to do a live poll every time one attempts to add a device? There are other places in the interface where one may add devices that would be affected by this timeout (such as raid creation).
    • Deleted volumes one at a time, performing checks between each.

      When the number dropped to 19, they finally listed in the "Add Device" dialog that had previously been timing out.

      To test a hypothesis, I setup a clean VM and created a number of small volumes. The dialog continued to work past 30 volumes, so it isn't specifically limited by the number of volumes. Perhaps the size, as the most of my volumes are 30gig or more?
    • So at this point I'm forced to go the workaround.

      I've made a bunch of place holder Targets, and reconstituted the LVM volumes. As expected, within the interface I can no longer assign volumes to targets due to the gateway timeout.

      I'm now trying to manually add volumes directly to the <luns> section of respective targets in the /etc/openmediavault/config.xml file.

      This is not especially difficult, except that I don't know how to find appropriate UUIDs

      arbitrary UUIDs evoke errors from the GUI.

      Is there any way to generate appropriate UUIDs from the command line so that they can be incorporated into the config.xml and maintain a valid setup?


      example added lun with arbitrary uuid:
      <lun>
      <type>blockio</type>
      <devicefile>/dev/mapper/iscsi-chronos</devicefile>
      <scsiid></scsiid>
      <scsisn></scsisn>
      <iomode>wt</iomode>
      <id>1</id>
      <uuid>66cfa5db-64fa-488e-9eaa-e452dc9b87cc</uuid>
      </lun>