Problem with Plex server installation on OMV 2

    • OMV 2.x
    • Problem with Plex server installation on OMV 2

      Hi gang, I had to reinstall my OpenMediaVault version 2 since my hard drive stopped working.

      I've been trying for a couple of days to get Plex to work but when I try to see my movies from my 2 TB drive, the Plex can't see the Plex server on it's webpage, I get a message, "Looking for servers...". Even when I go to the Plex setup page, I can't even see the server setting selection.

      What did I do wrong or what did I forget to do?

      If you need more info, just let me know.

      Thanks for your in advance.
    • You need to fix the permissions. The plex user id on your new installation is probably not the same as the plex user id on your old installation.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • mbourd25 wrote:

      Would you know the command to reset all the permissions?
      Look at the database folder field in the plex plugin.
      chown -R plex:nogroup REPLACE_THIS_WITH_FOLDER_FROM_ABOVE
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Hi ryecoaaron, I ran your command on the plexmediaserver directory and the Data1 directory on my 2 TB drive, where my media is, and it still cannot find the Plex server.

      How come I'm having such a problem just trying to re-install the Plex server on a drive that was already setup?

      Thanks for your help.
    • mbourd25 wrote:

      How come I'm having such a problem just trying to re-install the Plex server on a drive that was already setup?
      No idea. I don't use plex. I tried a long time ago and didn't like it.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • mbourd25 wrote:

      which one do you use?
      samba :) Never have a problem with it. All of my TVs have a FireTV with Kodi on them. Kodi works very nicely with samba.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Thanks tinh_x7, that's my next step to re-install it again and then reformat my 2 TB data drive also and hope my backup has everything. I wanted to try installing it another way. Install Lubuntu and Virtualbox and then run it under Virtualbox. That way, I can do a backup of the whole OMV os in a virtualbox. Then it would be easier to recover if it happens again.

      What do you think? Would that work? Any comments?

      I tried Emby and I found it less friendly to use then Plex.

      Hi ryecoaaron, I tried that but I just didn't like the fact that when I went from my living room to my bedroom, Kodi didn't know where to resume the movie. With Plex, it resumes right away. I also, I mostly use my chromecast. The one thing I wished chromecast would have is, be able to pause play from a TV, turn on another TV, and from the pause screen, be able to say resume play on the other TV. That would be cool.
    • mbourd25 wrote:

      I tried that but I just didn't like the fact that when I went from my living room to my bedroom, Kodi didn't know where to resume the movie. With Plex, it resumes right away. I also, I mostly use my chromecast. The one thing I wished chromecast would have is, be able to pause play from a TV, turn on another TV, and from the pause screen, be able to say resume play on the other TV. That would be cool.
      I haven't done it but I think you can do that if kodi uses a central mysql database. I just use skip buttons to get close (doesn't take long with 10min skip) but I don't move TVs often.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Hi tinh_x7, I tried installing Emby instead of Plex, but I couldn't test it, it's asking me to install the latest update but it cannot find it.

      For Roku, I had purchased Roku 3 and the first it asked me was my credit card number to create an account. I returned the next day and got a 2nd version chromecast.

      Anyway, I tried reinstalling yesterday the OMV 2 on my server and got the same problem, not able to view the Plex server. I'll just reinstall tonight and hope for the best that my backup drive contains everything that I had before OMV started to get a kernel panic.
    • Users Online 1

      1 Guest

    • Tags