I cant add RAID 5 array to iscsi lun after crash and fresh install

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • I cant add RAID 5 array to iscsi lun after crash and fresh install

      Hello,


      i had a harddrive crash and needed to reinstall OMV. After the fresh install i can see the RAID 5 array in the webUI but also there are two arrays more:

      md127 9TB state: clean, degraded (at the moment its degreded cause o drive failed)
      md127p1 128MB state: false
      md127p2 9TB state: false




      Raid Detail


      root@openmediavault:~# cat /proc/mdstat
      Personalities : [raid6] [raid5] [raid4]
      md127 : active (auto-read-only) raid5 sda[0] sdc[2] sdb[1]
      8790405120 blocks super 1.2 level 5, 512k chunk, algorithm 2 [4/3] [UUU_]


      unused devices: <none>


      root@openmediavault:~# blkid
      /dev/sda: UUID="52eade96-c466-059d-841f-dc33e546af08" UUID_SUB="0e185fa8-2bbd-1c5d-6872-395c423969e4" LABEL="NAS4:RAID5" TYPE="linux_raid_member"
      /dev/sdb: UUID="52eade96-c466-059d-841f-dc33e546af08" UUID_SUB="e57ca77a-b987-b532-0ebb-3c4c2e556bde" LABEL="NAS4:RAID5" TYPE="linux_raid_member"
      /dev/sdc: UUID="52eade96-c466-059d-841f-dc33e546af08" UUID_SUB="66a0dee9-1c72-e610-161c-63f200f2e476" LABEL="NAS4:RAID5" TYPE="linux_raid_member"
      /dev/md127p2: LABEL="NAS4" UUID="502ADECF2ADEB168" TYPE="ntfs"
      /dev/sdd1: UUID="9928083b-ea04-4794-855c-758c94e4de8a" TYPE="ext4"
      /dev/sdd5: UUID="b775b360-f2f9-4f5c-a518-b42e07239a4f" TYPE="swap"


      root@openmediavault:~# fdisk -l | grep "Disk "
      Disk /dev/sda doesn't contain a valid partition table
      Disk /dev/sdb doesn't contain a valid partition table
      Disk /dev/sdc doesn't contain a valid partition table


      WARNING: GPT (GUID Partition Table) detected on '/dev/md127'! The util fdisk doesn't support GPT. Use GNU Parted.


      Disk /dev/sda: 3000.6 GB, 3000592982016 bytes
      Disk identifier: 0x00000000
      Disk /dev/sdb: 3000.6 GB, 3000592982016 bytes
      Disk identifier: 0x00000000
      Disk /dev/sdc: 3000.6 GB, 3000592982016 bytes
      Disk identifier: 0x00000000
      Disk /dev/sdd: 32.0 GB, 32017046528 bytes
      Disk identifier: 0x0007a3bc
      Disk /dev/md127: 9001.4 GB, 9001374842880 bytes
      Disk identifier: 0x00000000


      root@openmediavault:~# cat /etc/mdadm/mdadm.conf
      # mdadm.conf
      #
      # Please refer to mdadm.conf(5) for information about this file.
      #


      # by default (built-in), scan all partitions (/proc/partitions) and all
      # containers for MD superblocks. alternatively, specify devices to scan, using
      # wildcards if desired.
      #DEVICE partitions containers


      # auto-create devices with Debian standard permissions
      CREATE owner=root group=disk mode=0660 auto=yes


      # automatically tag new arrays as belonging to the local system
      HOMEHOST <system>


      # instruct the monitoring daemon where to send mail alerts
      MAILADDR root


      # definitions of existing MD arrays


      # This file was auto-generated on Mon, 29 Jun 2015 06:41:20 +0000
      # by mkconf 3.2.5-5


      root@openmediavault:~# mdadm --detail --scan --verbose
      ARRAY /dev/md/RAID5 level=raid5 num-devices=4 metadata=1.2 name=NAS4:RAID5 UUID=52eade96:c466059d:841fdc33:e546af08
      devices=/dev/sda,/dev/sdb,/dev/sdc



      If i try to add the md127 raid to an iscsi lun it doesent show up. Only the 128mb raid shows up and can be selected.
      I appreciate if someone helps me to fix this problem.



      regards
      alex