Plex Database folder not updated in the config

    • OMV 3.x (stable)
    • Hi,

      I'm having exactly the same issue only noticed when my system drive started filling up. Tried everything in this thread to no avail e.g. uninstall and clear all files and user permissions etc and reinstall. My current system has been upgraded from OMV 2.x to OMV 3.x currently on 3.0.86 so just wondering is there is a hangover from the upgrade. Plex is working fine just can't seem to get it to use the Database Folder that is specified in the Web Gui therefore still writing to the /var/lib directory. Tried specifying the directory when creating my libraries through the Plex Web Guide but that doesn't work either.

      I don't have /etc/systemd/plexmediaserver.service.d or /etc/systemd/system/plexmediaserver.service.d directories.

      Running Plex Media Server plugin 3.8.1

      Any help would be gladly received.


    • Hi All,

      My issue has been resolved thanks to jhobe6678, told a slight lie as I can't have tried anything. Removing the plexmediaserver folder from my raid volume e.g. the directory I actually wanted as and disabling and enabling which I assumed has forced the recreation of the folder seems to have done the trick. Possibly permissions but I'm not that much of a linux whizz to find out any more unfortunately so take that with a pic of salt.

      Anyway all sorted, and thanks for your help with this thread.

    • This is an interesting post. I will take a close look at my set-up once I an at home in front of it.

      My / had been filling suddenly. 25GB available then suddenly 99.8% filled. I came across a feature in Plex's server setting called 'Scheduled Tasks.' In it is an option to Backup database every three days. Well the default Backup directory is in /lib/

      I like the feature so I pointed it to a different volume. This seemed to do the trick for me, but that was four days ago. I wonder if the changes stuck.
      BTW: I created exclusions in SnapRaid for both databases taking a load off of SnapRaid.
    • Have you looked at the actual size of the folder holding the Scheduled (every three days) database backups? Mine total only 1GB and these are not backups of the actual full Plex Media Server Database, which in my case is well over 200GB.

      Another thing to keep in mind: If you make any changes in the OMV Plex Media Server plugin and save and apply those changes, OMV will apply a chown to every file and folder in the full database. This does not happen instantly and can take quite a while to complete for a large database.

      Although I have never had to do it, relocating the full database (not the Scheduled every three day backup) to another location can also take quite a bit of time.

      Are you sure you have waited long enough for these operations to complete?
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • I had the same issue and I couldn't get Plex to use the shared folder so it used /var/lib/ instead.
      I found this post for what old files is needed to restore the Watched status:…om-One-Install-to-Another
      I didn't use the database commands, just cp -dRa. Not sure about the options but it worked.
      After that I restarted Plex in the UI and went back to Plex Web Client to refresh the Metadata for Movies and all of the sudden it was using the shared folder and /var/lib/plexmediaserver folder is empty.

      Back to normal :)