Not able to connect to Plex server

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Not able to connect to Plex server

      Hi gang, I had to re-install OMV due to my hard drive dying. But for about a week, I've been trying to get Plex to work but I can never connect to it. When I go to the Plex home page, it keeps showing me "looking for server"

      I followed all the instructions to properly install the folders that contain my media but still can't connect to the server.

      Any help would be greatly appreciated. Let me know if more information is required.

      Thanks in advance.
    • Just to update, since I tried to uninstall/reinstall Plex plugin, now Plex doesn't want to install, here is the message I keep getting.

      Error #0:exception 'OMV\Config\DatabaseException' with message 'Failed to execute XPath query '//services/plexmediaserver'.' in /usr/share/php/openmediavault/config/database.inc:78Stack trace:#0 /usr/share/openmediavault/engined/module/plexmediaserver.inc(58): OMV\Config\Database->get('conf.service.pl...')#1 /usr/share/openmediavault/engined/rpc/services.inc(56): OMVModulePlexMediaServer->getStatus()#2 [internal function]: OMVRpcServiceServices->getStatus(Array, Array)#3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#4 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('getStatus', Array, Array)#5 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('Services', 'getStatus', Array, Array, 1)#6 {main}
      OKHide details
    • OK, I also deleted the entire /media/<UUID>/plexmediaserver before reinstall the plex plugin.

      Still got en error after installation (see log file):

      Display Spoiler

      Log started: 2017-03-20 21:03:21
      Selecting previously unselected package avahi-utils.
      (Reading database ...
      (Reading database ... 5%
      (Reading database ... 10%
      (Reading database ... 15%
      (Reading database ... 20%
      (Reading database ... 25%
      (Reading database ... 30%
      (Reading database ... 35%
      (Reading database ... 40%
      (Reading database ... 45%
      (Reading database ... 50%
      (Reading database ... 55%
      (Reading database ... 60%
      (Reading database ... 65%
      (Reading database ... 70%
      (Reading database ... 75%
      (Reading database ... 80%
      (Reading database ... 85%
      (Reading database ... 90%
      (Reading database ... 95%
      (Reading database ... 100%
      (Reading database ... 38954 files and directories currently installed.)
      Preparing to unpack .../avahi-utils_0.6.31-5_amd64.deb ...
      Unpacking avahi-utils (0.6.31-5) ...
      Selecting previously unselected package liberror-perl.
      Preparing to unpack .../liberror-perl_0.17-1.1_all.deb ...
      Unpacking liberror-perl (0.17-1.1) ...
      Selecting previously unselected package git-man.
      Preparing to unpack .../git-man_1%3a2.1.4-2.1+deb8u2_all.deb ...
      Unpacking git-man (1:2.1.4-2.1+deb8u2) ...
      Selecting previously unselected package git.
      Preparing to unpack .../git_1%3a2.1.4-2.1+deb8u2_amd64.deb ...
      Unpacking git (1:2.1.4-2.1+deb8u2) ...
      Selecting previously unselected package git-core.
      Preparing to unpack .../git-core_1%3a2.1.4-2.1+deb8u2_all.deb ...
      Unpacking git-core (1:2.1.4-2.1+deb8u2) ...
      Selecting previously unselected package plexmediaserver.
      Preparing to unpack .../plexmediaserver_1.4.4.3495-edef59192_amd64.deb ...
      Unpacking plexmediaserver (1.4.4.3495-edef59192) ...
      Selecting previously unselected package openmediavault-plexmediaserver.
      Preparing to unpack .../openmediavault-plexmediaserver_3.8.1_all.deb ...
      Unpacking openmediavault-plexmediaserver (3.8.1) ...
      Processing triggers for man-db (2.7.0.2-5) ...
      Processing triggers for systemd (215-17+deb8u6) ...
      Processing triggers for mime-support (3.58) ...
      Processing triggers for openmediavault (3.0.67) ...
      Restarting engine daemon ...
      Setting up avahi-utils (0.6.31-5) ...
      Setting up liberror-perl (0.17-1.1) ...
      Setting up git-man (1:2.1.4-2.1+deb8u2) ...
      Setting up git (1:2.1.4-2.1+deb8u2) ...
      Setting up git-core (1:2.1.4-2.1+deb8u2) ...
      Setting up plexmediaserver (1.4.4.3495-edef59192) ...
      OK
      Created symlink from /etc/systemd/system/multi-user.target.wants/plexmediaserver.service to /lib/systemd/system/plexmediaserver.service.
      Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      dpkg: error processing package plexmediaserver (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of openmediavault-plexmediaserver:
      openmediavault-plexmediaserver depends on plexmediaserver | plexmediaserver-installer; however:
      Package plexmediaserver is not configured yet.
      Package plexmediaserver-installer is not installed.

      dpkg: error processing package openmediavault-plexmediaserver (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      plexmediaserver
      openmediavault-plexmediaserver


      Any idea?
    • OK, I also deleted the entire /media/<UUID>/plexmediaserver before reinstall the plex plugin.

      Still got en error after installation (see log file):

      Display Spoiler

      Log started: 2017-03-20 21:03:21
      Selecting previously unselected package avahi-utils.
      (Reading database ...
      (Reading database ... 5%
      (Reading database ... 10%
      (Reading database ... 15%
      (Reading database ... 20%
      (Reading database ... 25%
      (Reading database ... 30%
      (Reading database ... 35%
      (Reading database ... 40%
      (Reading database ... 45%
      (Reading database ... 50%
      (Reading database ... 55%
      (Reading database ... 60%
      (Reading database ... 65%
      (Reading database ... 70%
      (Reading database ... 75%
      (Reading database ... 80%
      (Reading database ... 85%
      (Reading database ... 90%
      (Reading database ... 95%
      (Reading database ... 100%
      (Reading database ... 38954 files and directories currently installed.)
      Preparing to unpack .../avahi-utils_0.6.31-5_amd64.deb ...
      Unpacking avahi-utils (0.6.31-5) ...
      Selecting previously unselected package liberror-perl.
      Preparing to unpack .../liberror-perl_0.17-1.1_all.deb ...
      Unpacking liberror-perl (0.17-1.1) ...
      Selecting previously unselected package git-man.
      Preparing to unpack .../git-man_1%3a2.1.4-2.1+deb8u2_all.deb ...
      Unpacking git-man (1:2.1.4-2.1+deb8u2) ...
      Selecting previously unselected package git.
      Preparing to unpack .../git_1%3a2.1.4-2.1+deb8u2_amd64.deb ...
      Unpacking git (1:2.1.4-2.1+deb8u2) ...
      Selecting previously unselected package git-core.
      Preparing to unpack .../git-core_1%3a2.1.4-2.1+deb8u2_all.deb ...
      Unpacking git-core (1:2.1.4-2.1+deb8u2) ...
      Selecting previously unselected package plexmediaserver.
      Preparing to unpack .../plexmediaserver_1.4.4.3495-edef59192_amd64.deb ...
      Unpacking plexmediaserver (1.4.4.3495-edef59192) ...
      Selecting previously unselected package openmediavault-plexmediaserver.
      Preparing to unpack .../openmediavault-plexmediaserver_3.8.1_all.deb ...
      Unpacking openmediavault-plexmediaserver (3.8.1) ...
      Processing triggers for man-db (2.7.0.2-5) ...
      Processing triggers for systemd (215-17+deb8u6) ...
      Processing triggers for mime-support (3.58) ...
      Processing triggers for openmediavault (3.0.67) ...
      Restarting engine daemon ...
      Setting up avahi-utils (0.6.31-5) ...
      Setting up liberror-perl (0.17-1.1) ...
      Setting up git-man (1:2.1.4-2.1+deb8u2) ...
      Setting up git (1:2.1.4-2.1+deb8u2) ...
      Setting up git-core (1:2.1.4-2.1+deb8u2) ...
      Setting up plexmediaserver (1.4.4.3495-edef59192) ...
      OK
      Created symlink from /etc/systemd/system/multi-user.target.wants/plexmediaserver.service to /lib/systemd/system/plexmediaserver.service.
      Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      dpkg: error processing package plexmediaserver (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of openmediavault-plexmediaserver:
      openmediavault-plexmediaserver depends on plexmediaserver | plexmediaserver-installer; however:
      Package plexmediaserver is not configured yet.
      Package plexmediaserver-installer is not installed.

      dpkg: error processing package openmediavault-plexmediaserver (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      plexmediaserver
      openmediavault-plexmediaserver


      Any idea?
    • Not able to connect to Plex server

      I got plex works. I don't know if this solution is correct, but it works for me.

      Activate the Plex repo in the OMV GUI.

      To be sure there is the latest paket list loaded: in omv-extras tab make "Apt Clean" and after that "Update".

      According this thread (last post on first page) I did:

      Source Code

      1. apt-get purge openmediavault-plexmediaserver
      2. apt-get purge plexmediaserver
      3. userdel plex
      4. rmdir /media/<my-UUID>/plexmediaserver

      After this install plex plugin through OMV GUI (not CLI). When plexmediaserver is installed, I got this error message in OMV GUI: 'Failed to execute XPath query '//services/plexmediaserver'. Just ignore it.

      Then according this post (third post on first page):

      Source Code

      1. chgrp -R plex /var/lib/plexmediaserver
      2. chmod 777 /var/lib/plexmediaserver
      3. dpkg --configure plexmediaserver openmediavault-plexmediaserver

      Again, I don't know if this is a proper way, but my plex works now.

      The post was edited 1 time, last by Magellan ().

    • Magellan - thanks for posting how you successfully re-installed plex.

      But...It didn't work for me.

      Completed the first section. Reinstalled Plex in the OMV Gui. Saw the same error message.

      First two steps of second section worked, no problem.
      Unfortunately, the 3rd step "dpkg --configure plexmediaserver openmediavault-plexmediaserver" didn't.


      Source Code

      1. stat: cannot stat '/media/<my-UUID>/plexmedia/Library': No such file or directory
      plex/omv is determined to use the old directory even though its deleted