Plex: How do I get the unsupported App Store?

    • OMV 3.x
    • gderf wrote:

      Plex WebTools works for me on OMV 2.x and 3.x. I just followed the installation directions in the above posted link.
      Sorry I am a super noob on this. Pretty much everything I have done on OMV is because I copy exactly what to type.

      Could you give me a hint or where to start?

      I found the location on the settings>server>backup directory as:
      Display Spoiler
      /srv/dev-disk-by-label-Vault103/plexmediaserver/Library/Application Support/Plex Media Server/Plug-in Support/Databases


      I am not sure what I should type then :(

      I can keep reading but it has been a while of keep trying lol
    • Ok, so after doing a lot of reading and asking on the Plex forum, this is what I can get done:

      My server is called NAS, so I have this:
      root@NAS:/#
      then do the following:

      Source Code

      1. cd /srv/dev-disk-by-label-Vault103/plexmediaserver/Library/Application\ Support/Plex\ Media\ Server/Plug-ins/
      2. sudo wget https://github.com/ukdtom/WebTools.bundle/releases/download/2.4.1/WebTools.bundle.zip
      3. sudo apt-get install unzip -y
      4. sudo unzip WebTools*
      5. sudo rm -rf WebTools.bundle.zip
      6. sudo chown plex:plex -R ./WebTools.bundle
      7. sudo reboot

      it doesnt work .

      then I double check with

      Source Code

      1. ls -la
      and I can see the permission look fine (or should be):
      Display Spoiler
      drwxr-xr-x 9 plex nogroup 4096 Nov 8 18:32 .
      drwxr-xr-x 10 plex nogroup 4096 Nov 8 19:30 ..
      drwxr-xr-x 3 plex plex 4096 Nov 7 18:38 CNN.bundle
      drwxr-xr-x 3 plex plex 4096 Nov 7 18:32 FOX.bundle
      drwxr-xr-x 3 plex plex 4096 Nov 7 18:38 History Channel.bundle
      drwxr-xr-x 3 plex plex 4096 Nov 7 18:37 RT America.bundle
      drwxr-xr-x 3 plex plex 4096 Nov 8 10:22 Services.bundle
      drwxr-xr-x 3 plex plex 4096 Nov 7 18:36 Sub-Zero.bundle
      drwxr-xr-x 4 plex plex 4096 Nov 8 18:32 WebTools.bundle


      I am not sure what I am missing :(

      any help would be appreciated

      The post was edited 1 time, last by bad_boo ().

    • bad_boo wrote:

      Well, I managed to install it but I cant get into the tool. I get the error:
      This site can’t be reached

      I followed this tutorial for a raspberry pi< not sure if it was right:
      Installing WebTools utility on Raspberry Pi Plex Media Server
      Very new at all this but I followed your steps... Everything works over here lol.

      Huge typo in your dir path. Also not sure if it helps but mine was in "/var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-ins".

      Can you see the channel in the channel section of PMS?

      Also its yourserverip:33400

      Hope you can get yours working
    • After 7 months of had thrown the towel on this. I managed to make it work.

      I had the wrong location the whole time.... oh God... The right location was here

      Source Code

      1. cd /var/lib/plexmediaserver/Library/Application\ Support/Plex\ Media\ Server/
      Now I have access to rthe new webtools 3.0.0


      well, it is better to get something to work later than never lol
    • Ok, just coming back to this.

      Just thinking on leaving my solution cleared.

      This is what I did to get the unsupported app working in my NAS server for Plex.


      Source Code

      1. cd /var/lib/plexmediaserver/Library/Application\ Support/Plex\ Media\ Server/Plug-ins/
      2. sudo wget https://github.com/ukdtom/WebTools.bundle/releases/download/3.0.0/WebTools.bundle.zip
      3. sudo apt-get install unzip -y
      4. sudo unzip WebTools*
      5. sudo rm -rf WebTools.bundle.zip
      6. sudo chown plex:plex -R ./WebTools.bundle
      7. sudo reboot
      on line 1, I am using the right location. Before I was setting everything up on the svr\ folder.

      on line 2, the latest webtool 3.0 will be downloaded.
    • I think it is important to mention that the path

      /var/lib/plexmediaserver/

      is the path to the library of plexmedia as specified in the plugin of docker. So it can vary on different installations depending on the configuration.
      Odroid HC2 - armbian - Seagate ST4000DM004 - OMV4.x
      Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 - Intenso SSD 120GB - OMV4.x
      :!: Backup - Solutions to common problems - OMV setup videos - OMV4 Documentation - user guide :!:
    • macom wrote:

      I think it is important to mention that the path

      /var/lib/plexmediaserver/

      is the path to the library of plexmedia as specified in the plugin of docker. So it can vary on different installations depending on the configuration.
      Yes, you are right, but for some strange reason, when I used to check the location on the plex plugin settings, it was saying the location was on svr/ folder, until I finally googled it and read someone saying it was on var/ folder.

      I am at the office but I will double check when I get home to see if I am not seeing stuff lol

      I couldn't make plex working on docker (I haven't had time to figure it out) so that is why I am using the plugin.