SnapRAID Sync Killed after short time while attempting to sync

    • OMV 2.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • SnapRAID Sync Killed after short time while attempting to sync

      I have 5 data disks and 1 parity disk. I've been copying some data around on my SnapRAID disks and haven't setup a scheduled sync job yet, so I've been doing it manually. I did one 5 days ago and it completed after 2 days, no issue. Today I went to do a sync after I finished copying data and it keeps saying 'Killed' after "Scanning disk data4..."

      SnapRAID status seems to be working fine, I don't see anything that is raising a red flag.

      I tried rebooting the computer, didn't work. I tried switching from the backports kernel to the standard, and the killed message came up after "scanning disk data5..." instead of "scanning disk data4..." While syncing, CPU goes between 50 and 74% and Memory Usage goes to around 93%. It seems to peak at 95% CPU right before it stops syncing.

      All drives are identical. Nothing else has changed between in the 3 days since my last successful sync other than copying some data from data5 to data4 and data3.

      Could it be a RAM issue since it goes up to 93% while trying to sync? OMV shows 5% of 3.69GB while not trying to sync. Looking at the SnapRAID manual, section 7.9, I did the math for RAM and got 2.42GB.

      I'll attach some screenshots with more info about my setup.

      SnapRAID Settings

      Snapraid Drives

      SnapRAID Status

      Results when Using 3.2.0-4 Kernel

      Results when using 3.16.0 Kernel

      Drives in File Systems Tab:

      The post was edited 3 times, last by hotsauce ().

    • Looks like it was a lack of RAM. I decided to order 16 more GB to add in the two empty slots and snapRAID has made it past the scanning disk part. SnapRAID sync says it is using 3671 MiB of memory and OMV's system information page currently shows 38% of 19.47 GiB being used.

      I just started the sync, but initial results seem promising.
    • The sync finished this time, so it was a lack of RAM issue. Hopefully this helps anyone who runs into the same problem in the future. Either buy more ram, or change your hashsize so that SnapRAID uses less RAM. From what I see, changing Hashsize would require recalculating all the parity data. I didn't want to re calculate parity data, so I bought more RAM.

      Updated SnapRAID status for reference: