Erreur #7001

    • OMV 2.x
    • Erreur #7001

      Hello,

      When I try to log with the web interface, I have this error :


      Failed to connect to socket: No such file or directory
      Erreur #7001:exception 'OMVException' with message 'Failed to connect to socket: No such file or directory' in /usr/share/php/openmediavault/rpc.inc:135Stack trace:#0 /var/www/openmediavault/rpc/session.inc(72): OMVRpc::exec('UserMgmt', 'authUser', Array, Array, 2, true)#1 [internal function]: OMVRpcServiceSession->login(Array, Array)#2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('login', Array, Array)#4 /usr/share/php/openmediavault/rpcproxy.inc(125): OMVRpc::exec('Session', 'login', Array, Array, 3)#5 /var/www/openmediavault/rpc.php(32): OMVJsonRpcProxy->handle()#6 {main}

      To resolve, I try : apt-get update
      apt-get install openmediavault-omvextrasorg
      No results, same error.

      Also try omv-engined -df gives segmentation fault.

      Any ideas ?

      Thanks in advance.
    • Also, i want to say it's openmediavault version 2.2.13

      I try : dpkg -l | grep openm

      The results : ii openmediavault 2.2.13 all Open network attached storage solution
      ii openmediavault-backup 1.0.11 all backup plugin for OpenMediaVault.
      ii openmediavault-keyring 0.4 all GnuPG archive keys of the OpenMediaVault archive
      ii openmediavault-mysql 2.1 all MySQL plugin for OpenMediaVault.
      ii openmediavault-nginx 2.4 all Nginx plugin for OpenMediaVault.
      ii openmediavault-omvextrasorg 2.13.7 all OMV-Extras.org Package Repositories for OpenMediaVault
      ii openmediavault-openvpnas 1.0.10 all OpenVPN Acess Server plugin for OpenMediaVault.
    • Here are the results :

      df -h
      Sys. fich. Taille Util. Dispo Uti% Monté sur
      rootfs 73G 1,8G 67G 3% /
      udev 10M 0 10M 0% /dev
      tmpfs 202M 1,3M 200M 1% /run
      /dev/disk/by-uuid/faa31a8a-4207-4586-9b3f-d49d72537192 73G 1,8G 67G 3% /
      tmpfs 5,0M 0 5,0M 0% /run/lock
      tmpfs 1,1G 0 1,1G 0% /run/shm
      /dev/md0 3,6T 67G 3,6T 2% /media/e00a7b25-36e4-4d05-a347-00a0cac0cfb1
    • Not full... Try as root:

      monit stop omv-engined
      omv-engined -df

      Then try to login and see if there are errors in the output. Also, are you sure you have the nginx plugin configured correctly?
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • When i try omv-engined -df , i get segmentation fault

      When i try to login, same results :
      Erreur #7001:exception 'OMVException' with message 'Failed to connect to socket: No such file or directory' in /usr/share/php/openmediavault/rpc.inc:135Stack trace:#0 /var/www/openmediavault/rpc/session.inc(72): OMVRpc::exec('UserMgmt', 'authUser', Array, Array, 2, true)#1 [internal function]: OMVRpcServiceSession->login(Array, Array)#2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)#3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('login', Array, Array)#4 /usr/share/php/openmediavault/rpcproxy.inc(125): OMVRpc::exec('Session', 'login', Array, Array, 3)#5 /var/www/openmediavault/rpc.php(32): OMVJsonRpcProxy->handle()#6 {main}

      How can i verify the nginx plugin configured correctly ?

      Thanks for all.
    • kidordine wrote:

      How can i verify the nginx plugin configured correctly ?
      Hard to say without knowing what setup you have. If you remove the plugin (apt-get remove openmediavault-nginx) and the web interface works, that will definitely tell you.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • See in any messages in the output of dmesg? Maybe you have a bad memory stick?
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • kidordine wrote:

      Do you think memtest bugged or do you think i must replace motherboard ?
      I doubt memtest is the problem. It might be the motherboard and/or your memory settings on that motherboard.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!