German:virtualbox und ZFS laufen nicht

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • German:virtualbox und ZFS laufen nicht

      Hallo,

      ich habe die Aktuellste OMV 3 auf einer VM als Test laufen. jdownloader, ssh Drucker Service upnp scheinen gut zu funktionieren.
      Nun wollte ich ZFS & Virtualbox testen, diese sollen irgend wann auch vollständig benutzt werden ...

      ZFS lies sich nicht installieren,warum nicht hab da nicht ganz verstanden habt ihr evtl. im Moment Probleme mit den Paketen ?

      Virtualbox hab ich installieren können, jedoch gibt es Probleme beim aktivieren:

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start virtualbox-web 2>&1' with exit code '1': A dependency job for virtualbox-web.service failed. See 'journalctl -xn' for details


      edit:beide plugins habe ich über die omv webgui installiert bzw. bei zfs es versucht.

      Source Code

      1. Reading package lists...
      2. Building dependency tree...
      3. Reading state information...
      4. The following extra packages will be installed:
      5. libnvpair1linux libuutil1linux libzfs2linux libzpool2linux spl-dkms zfs-dkms
      6. zfs-zed zfsutils-linux
      7. Suggested packages:
      8. zfs-initramfs zfs-dracut
      9. Recommended packages:
      10. spl
      11. The following NEW packages will be installed:
      12. libnvpair1linux libuutil1linux libzfs2linux libzpool2linux
      13. openmediavault-zfs spl-dkms zfs-dkms zfs-zed zfsutils-linux
      14. Preconfiguring packages ...
      15. 0 upgraded, 9 newly installed, 0 to remove and 3 not upgraded.
      16. Need to get 0 B/2504 kB of archives.
      17. After this operation, 16.1 MB of additional disk space will be used.
      18. Selecting previously unselected package spl-dkms.
      19. (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 68694 files and directories currently installed.)
      20. Preparing to unpack .../spl-dkms_0.6.5.8-3~bpo8+1_all.deb ...
      21. Unpacking spl-dkms (0.6.5.8-3~bpo8+1) ...
      22. Setting up spl-dkms (0.6.5.8-3~bpo8+1) ...
      23. Loading new spl-0.6.5.8 DKMS files...
      24. Building for 4.9.0-0.bpo.1-amd64
      25. Building initial module for 4.9.0-0.bpo.1-amd64
      26. Done.
      27. spl:
      28. Running module version sanity check.
      29. - Original module
      30. - No original module exists within this kernel
      31. - Installation
      32. - Installing to /lib/modules/4.9.0-0.bpo.1-amd64/updates/dkms/
      33. splat.ko:
      34. Running module version sanity check.
      35. - Original module
      36. - No original module exists within this kernel
      37. - Installation
      38. - Installing to /lib/modules/4.9.0-0.bpo.1-amd64/updates/dkms/
      39. depmod.....
      40. DKMS: install completed.
      41. Selecting previously unselected package zfs-dkms.
      42. (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 68981 files and directories currently installed.)
      43. Preparing to unpack .../zfs-dkms_0.6.5.8-2~bpo8+1_all.deb ...
      44. Unpacking zfs-dkms (0.6.5.8-2~bpo8+1) ...
      45. Selecting previously unselected package libuutil1linux.
      46. Preparing to unpack .../libuutil1linux_0.6.5.8-2~bpo8+1_amd64.deb ...
      47. Unpacking libuutil1linux (0.6.5.8-2~bpo8+1) ...
      48. Selecting previously unselected package libnvpair1linux.
      49. Preparing to unpack .../libnvpair1linux_0.6.5.8-2~bpo8+1_amd64.deb ...
      50. Unpacking libnvpair1linux (0.6.5.8-2~bpo8+1) ...
      51. Selecting previously unselected package libzpool2linux.
      52. Preparing to unpack .../libzpool2linux_0.6.5.8-2~bpo8+1_amd64.deb ...
      53. Unpacking libzpool2linux (0.6.5.8-2~bpo8+1) ...
      54. Selecting previously unselected package libzfs2linux.
      55. Preparing to unpack .../libzfs2linux_0.6.5.8-2~bpo8+1_amd64.deb ...
      56. Unpacking libzfs2linux (0.6.5.8-2~bpo8+1) ...
      57. Selecting previously unselected package zfsutils-linux.
      58. Preparing to unpack .../zfsutils-linux_0.6.5.8-2~bpo8+1_amd64.deb ...
      59. Unpacking zfsutils-linux (0.6.5.8-2~bpo8+1) ...
      60. Selecting previously unselected package zfs-zed.
      61. Preparing to unpack .../zfs-zed_0.6.5.8-2~bpo8+1_amd64.deb ...
      62. Unpacking zfs-zed (0.6.5.8-2~bpo8+1) ...
      63. Selecting previously unselected package openmediavault-zfs.
      64. Preparing to unpack .../openmediavault-zfs_3.0.7_amd64.deb ...
      65. Unpacking openmediavault-zfs (3.0.7) ...
      66. Processing triggers for man-db (2.7.0.2-5) ...
      67. Processing triggers for openmediavault (3.0.60) ...
      68. Restarting engine daemon ...
      69. Setting up zfs-dkms (0.6.5.8-2~bpo8+1) ...
      70. Loading new zfs-0.6.5.8 DKMS files...
      71. Building for 4.9.0-0.bpo.1-amd64
      72. Building initial module for 4.9.0-0.bpo.1-amd64
      73. Error! Bad return status for module build on kernel: 4.9.0-0.bpo.1-amd64 (x86_64)
      74. Consult /var/lib/dkms/zfs/0.6.5.8/build/make.log for more information.
      75. Setting up libuutil1linux (0.6.5.8-2~bpo8+1) ...
      76. Setting up libnvpair1linux (0.6.5.8-2~bpo8+1) ...
      77. Setting up libzpool2linux (0.6.5.8-2~bpo8+1) ...
      78. Setting up libzfs2linux (0.6.5.8-2~bpo8+1) ...
      79. Setting up zfsutils-linux (0.6.5.8-2~bpo8+1) ...
      80. Job for zfs-import-scan.service failed. See 'systemctl status zfs-import-scan.service' and 'journalctl -xn' for details.
      81. Job for zfs-share.service failed. See 'systemctl status zfs-share.service' and 'journalctl -xn' for details.
      82. Job for zfs-mount.service failed. See 'systemctl status zfs-mount.service' and 'journalctl -xn' for details.
      83. Setting up zfs-zed (0.6.5.8-2~bpo8+1) ...
      84. Setting up openmediavault-zfs (3.0.7) ...
      85. modprobe: FATAL: Module zfs not found.
      86. dpkg: error processing package openmediavault-zfs (--configure):
      87. subprocess installed post-installation script returned error exit status 1
      88. Processing triggers for libc-bin (2.19-18+deb8u7) ...
      89. Processing triggers for openmediavault (3.0.60) ...
      90. Restarting engine daemon ...
      91. Errors were encountered while processing:
      92. openmediavault-zfs
      93. >>> *************** Error ***************
      94. <<< *************************************
      95. >>> *************** Error ***************
      96. <<< *************************************
      97. >>> *************** Error ***************
      98. <<< *************************************
      99. >>> *************** Error ***************
      100. <<< *************************************
      101. >>> *************** Error ***************
      102. <<< *************************************
      Display All



      Hat jemand diesbezüglich erfahrung ? Oder eine Lösung ? brauche da dringend Hilfe.

      mfg
      omvNAS

      The post was edited 1 time, last by omvNAS ().

    • As written in other threads, zfs and virtualbox modules do not compile with the 4.9 kernel. You need to revert back to the 4.8 kernel until Debian releases updates for those packages. I did compile a newer version of virtualbox (5.1.14) that works with the 4.9 kernel - search for that thread.
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      As written in other threads, zfs and virtualbox modules do not compile with the 4.9 kernel. You need to revert back to the 4.8 kernel until Debian releases updates for those packages. I did compile a newer version of virtualbox (5.1.14) that works with the 4.9 kernel - search for that thread.
      I have installed the 4.8 kernel. I blocked the 4.9 kernel by "apt-mark hold" command. Yesterday I tried to install the latest ZFS-package by WebUI "OMV-Extras" on the 4.8 kernel. During the installation of the ZFS package I saw, that the 4.9er kernel was tried to be installed in the background. But it failed because of the former "apt-mark hold".

      Then I enabled the 4.9 package again and tried to install the 4.9 also by WebUI. It failed also and some dependencies to the ZFS package was reported. So it seems that the 4.9 kernel must be installed to be able to install the zfs package.

      So my question is, how can I install the latest ZFS package with kernel 4.8?
      OMV 3.0.78 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • so ihr lieben

      i have install kernel 4.8, and zfs and virtualbox is working. thx


      But i have other question, too.

      is ZFS plugin for OMV stable ans performance as for FreeBSD ?


      edit: first start on virtualbox come this:

      Source Code

      1. This version of phpVirtualBox (5.0-5) is incompatible with VirtualBox 5.1.8_Debian. You probably need to download the latest phpVirtualBox 5.1-x.
      2. See the Versioning section below the file list in the link for more information
    • Also ich möchte ZFS produktiv verwenden, da ich mir extra dafür die passende Hardware mit ECC-Support angeschafft habe. Zur Stabilität im Vergleich zu FreeBSD kann ich nichts sagen. Allerdings wird ZFS unter Debian 8 nun wohl offiziell unterstützt, so dass hoffentlich keine Probleme damit zu erwarten sind. Die Erfahrungen hier im Forum sind hier eher positiv, was ich so quer gelesen habe.
      OMV 3.0.78 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • Fixed in zfs plugin 3.0.8

      apt-get -t jessie-backports install linux-image-4.8.0-0.bpo.2-amd64 linux-headers-4.8.0-0.bpo.2-all

      Set 4.8 to default boot kernel in omv-extras Kernel tab

      reboot

      apt-get purge linux-image-4.9.0-0.bpo.1-amd64 linux-image-amd64

      apt-get install openmediavault-zfs


      omvNAS wrote:

      This version of phpVirtualBox (5.0-5) is incompatible with VirtualBox 5.1.8_Debian.
      This is just a warning. It still works. There is no phpVirtualbox 5.1.
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Hi omvNAS,

      es kommt auf die Richtung an. Siehe folgende Beitrag im FreeBSD-Forum: Importing a ZFS-on-Linux pool to FreeBSD

      Zitat:
      "You "should" be able to import the ZFS pool from the linux machine onto the FreeBSD with no problems. BUT, going the other way FreeBSD -> Linux may not work at all, since the dataset on FreeBSD is more "mature" than the linux implemtation"
      OMV 3.0.78 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • cabrio_leo wrote:

      "You "should" be able to import the ZFS pool from the linux machine onto the FreeBSD with no problems. BUT, going the other way FreeBSD -> Linux may not work at all, since the dataset on FreeBSD is more "mature" than the linux implemtation"
      Good to reason to stay on Linux :)
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Ich möchte und werde wahrscheinlich auch bei debian bleiben, debian habe ich schon seit ca. 10 Jahren.

      ryecoaaron wrote:

      Good to reason to stay on Linux


      --------------------------
      jedoch habe ich jetzt etwas anderes getestet, ich hatte OMV 3 auf einer VM am laufen wie oben beschrieben, virtualbox lief nicht wegen dem Kernel 4.9, mit dem Kernel 4.8 lief es danach. Alles ok.

      Jetzt habe ich mal OMV 3 auf eine kleine SSD installiert und omv extra auch, dist upgrade gemacht und Kernel 4.8 gestartet jetzt läuft aber virtualbox trotzdem nicht , das ist sehr merkwürdig:


      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start virtualbox-web 2>&1' with exit code '1': A dependency job for virtualbox-web.service failed. See 'journalctl -xn' for
      2. Feb 18 16:44:50 DELL systemd[1]: Starting LSB: VirtualBox Linux kernel module...
      3. Feb 18 16:44:50 DELL virtualbox[3688]: Loading VirtualBox kernel modules...No suitable module for running kernel found ... failed!
      4. Feb 18 16:44:50 DELL virtualbox[3688]: failed!
      5. Feb 18 16:44:50 DELL systemd[1]: virtualbox.service: control process exited, code=exited status=1
      6. Feb 18 16:44:50 DELL systemd[1]: Failed to start LSB: VirtualBox Linux kernel module.
      7. Feb 18 16:44:50 DELL systemd[1]: Dependency failed for VirtualBox Web Service.
      8. Feb 18 16:44:50 DELL systemd[1]: Unit virtualbox.service entered failed state.
      9. Feb 18 16:45:01 DELL CRON[3709]: (root) CMD (/usr/sbin/omv-mkgraph >/dev/null 2>&1)
      10. Feb 18 16:45:01 DELL rrdcached[1063]: Received FLUSHALL
      11. Feb 18 16:46:20 DELL systemd[1]: Job dev-disk-by\x2duuid-FED9\x2d1210.device/start timed out.
      12. Feb 18 16:46:20 DELL systemd[1]: Timed out waiting for device dev-disk-by\x2duuid-FED9\x2d1210.device.
      13. Feb 18 16:46:20 DELL systemd[1]: Dependency failed for /media/FED9-1210.
      14. Feb 18 16:46:20 DELL systemd[1]: Job dev-disk-by\x2duuid-748CC5418CC4FE9C.device/start timed out.
      15. Feb 18 16:46:20 DELL systemd[1]: Timed out waiting for device dev-disk-by\x2duuid-748CC5418CC4FE9C.device.
      16. Feb 18 16:46:20 DELL systemd[1]: Dependency failed for /media/748CC5418CC4FE9C.
      Display All
    • also mit modinfo vboxguest oder virtualbox.service bekomme ich auch nichts rein da schein es wieder das selbe kernelproblem zu geben, habe spasshalber deshalb zfs versucht zu installieren, geht wieder NICHT.
      als auf der vm nach umstellung auf kernel 4.8 ging es, und jetzt fahre ich wieder mit kernel 4.8 und hab die selben probleme wie am anfang.


      @ryecoaaron


      u have remove some modul on kernel 4.8, yesterday ? since yesterday i have install omv again on ssd , but i have problems with kernel 4.8 again same problems as kernel 4.9


      sorry for my bad english
    • omvNAS wrote:

      u have remove some modul on kernel 4.8, yesterday ? since yesterday i have install omv again on ssd , but i have problems with kernel 4.8 again same problems as kernel 4.9
      I haven't removed anything. Kernel modules are included in debian packages or compiled by the package itself.
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • omvNAS wrote:

      can u say me , why kernel modul is not load again from kernel 4.8 ?
      No idea. The zfs packages have an update (0.6.5.9) that will compile with the 4.9 kernel though. No need to update the plugin for this.
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      apt-get -t jessie-backports install linux-image-4.8.0-0.bpo.2-amd64 linux-headers-4.8.0-0.bpo.2-all

      Set 4.8 to default boot kernel in omv-extras Kernel tab

      reboot

      apt-get purge linux-image-4.9.0-0.bpo.1-amd64 linux-image-amd64

      apt-get install openmediavault-zfs
      Hi Aaron,

      I had problems with your suggested sequence - I got errors - But nevertheless thank you for your help. So I decided to go back to an older Clonezilla image without any zfs installation.
      These were my steps to get zfs installed finally:

      1. Purge 4.9 kernel
      apt-get purge linux-image-4.9.0-0.bpo.1-amd64 linux-image-amd64

      2. Install 4.8 kernel again
      apt-get -t jessie-backports install linux-image-4.8.0-0.bpo.2-amd64 linux-headers-4.8.0-0.bpo.2-all

      3. Set 4.8 to default boot kernel in omv-extras Kernel tab

      4. reboot

      5. Tried to install the zfs-plugin 3.0.9 from WebUI => Failed - message "some broken packages zfs.zed...."

      6. "Apt-Clean" from WebUi and a second try to install zfs-plugin from WebUI -> Same error message

      7. apt-get dist-upgrade
      8. omv-initsystem
      9. apt-get install openmediavault-zfs
      This time the ZFS-package was correctly installed - no error message at all.


      P.S. Could you please take a look at the following thread ShellInABox - Create Link for SSH-access without Links-plugin? Thank you.
      OMV 3.0.78 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304
    • so hallo erstmal

      ich weiss jetzt was los war, hatte immer 4.8 ausgewählt war auch komplett installiert aber beim löschen vom kernel 4.9 hat apt-get die header kernel datei von 4.8 auch mit gelöscht warum auch immer, vor 2 tagen durch zufall gesehen installiert , lief gleich.

      heue habe ich virtualbox mit pci passtrough in gang bekommen, läuft auch ohne probleme. werde jetzt dem nächst ein paar benchmark machen ....


      DANKE euch beiden

      @ryecoaaron thanks for u help