Setting Vpn to access from outside

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • jata1 wrote:

      my take on the poster's question is that they are looking for a commercial VPN service and not a local VPN server on their OMV.

      Sorry that I can't be more helpful but my answer is that I don't know which is the best value/performance VPN service. I would try googling 'best VPN service' and have a look at the prices and performance/restrictions. You will probably find some that have a free trial and this will be a good way to find a good one.

      Good luck!
      I have been to various sites like these talking and reviewing about the best vpn services available, but somehow i don't believe them i feel these are not actual user reviews.
    • I understand. too much choice / marketing!

      Not sure if you read 9to5mac but they just posted an article talking about VPN services

      9to5mac.com/2017/04/04/how-to-choose-best-vpn-iphone-ipad/

      the article is looking at the question from a mobile (iPhone/iPad) perspective but does list 3-4 VPN providers that they recommend.

      You can post a question to the community on the article and see if you get other ideas/suggestions.
    • jata1 wrote:

      I understand. too much choice / marketing!

      Not sure if you read 9to5mac but they just posted an article talking about VPN services

      9to5mac.com/2017/04/04/how-to-choose-best-vpn-iphone-ipad/

      the article is looking at the question from a mobile (iPhone/iPad) perspective but does list 3-4 VPN providers that they recommend.

      You can post a question to the community on the article and see if you get other ideas/suggestions.
      Will try posting a question to the community. Thanks for the share.
    • dcbasso wrote:

      I make a post using a google chrome extesion and change the payload to the server including the "gateway_interface" on the JSON and the OMV accepted that.
      But I still thinking it's a bug!
      The field is there in the javascript - github.com/OpenMediaVault-Plug…/openvpn/Settings.js#L139. You probably just need to setup a network interface in the interfaces tab so that it has something to populate the combo with.

      Fresh install of OMV 3 and I can see the gateway interface combo. See screenshot.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!

      The post was edited 1 time, last by ryecoaaron ().

    • so im getting a lot of issues settings this up. i just checked the debug logs and got this

      Sun Dec 31 14:35:27 2017 us=534742 NOTE: your local LAN uses the extremely common subnet address 192.168.0.x or 192.168.1.x. Be aware that this might create routing conflicts if you connect to the VPN server from public locations such as internet cafes that use the same subnet

      from what i can tell, im able to connect with an openVPN client. but when i try to access anything, on the internet or anything on the VPN network i get no response.

      the error is spot on, both my local and remote (VPN servers) networks are the exact same. 192.168.1.0 255.255.255.0 192.168.1.254

      so i guess my question is, what is the best way to fix this? just change the network setup on one of them?

      or can i just use the 10.8.0.0 as the VPN network address. i didnt think this would work if the OMV server is at 192.168.1.xxx. if my VPN connection puts me on 10.8 how can i talk to OMV, which is the whole point(for me) of the vpn, to manage the OMV server from anywhere without exposing the port (which i am to understand isn't very secure)


      found this... so i guess i will need to change the network settings of the OMV server. from reading the link, im not sure if i need to change the entire network settings (gateway, subnet etc) or just change the OMV servers ip address into the range of the openVPN netowork (192.168.143.0 as recommended by the link)

      The post was edited 1 time, last by thejacer87: added more info ().

    • ionut007 wrote:

      Hello,
      I installed OpenVPN plug-in and when I want to change settings every time I click save i get this message:

      : Missing 'required' attribute 'gateway_interface'.

      What is going vrong and how can I fix it?

      Thanks
      Hi , same problem, someone solve this?
      I update plugin to 4.0 version but I cannot finish setup because this field is required and i dont know how ...
      Thanks
    • Users Online 2

      2 Guests