PlexPy doesn't run automatically

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • PlexPy doesn't run automatically


      I tried to install PlexPy on OMV 3.0, but it never starts automaticallly.

      I checked the /lib/systemd/system path and there is no plexpy.service as suggested in this explaination:…ripts/init.ubuntu.systemd

      Edit: I got rid of the error somehow. To use Plexpy I have to run "python" everytime in /opt/plexpy otherwise it doesn't work. The Service listens on port 8181 (as far as I know the standard port).

      It seems the launch routine of it is broken (same everytime I reinstall the whole thing).

      Any suggestions on what I could try to do?

      Kind regards

      The post was edited 1 time, last by ChacalCH ().

    • Hello,

      There are 2 options here

      Create init.d startup script for PlexPY
      Look in Ubuntu section, should be the same for debian

      Regarding this one:

      ChacalCH wrote:

      I checked the /lib/systemd/system path and there is no plexpy.service as suggested in this explaination:…ripts/init.ubuntu.systemd
      Clone GIT, you will get all content

      How to install PlexPy on Debian 7.x (Wheezy)

      Create cron job (via OMV WebUI) with those parameters and run after reboot

      cd /opt/plexpy

      I recommend #1., you just need to google a bit :)

      I don't use PY by myslef, but if you found it useful go with it!
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))


      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!

      The post was edited 1 time, last by kawu2 ().

    • I used the OMV Plex Plugin to enable PlexPy.

      This created a SystemV style init script at /etc/init.d/plexpy and it starts automatically at boot.

      I did the above on my OMV 2.x installation prior to upgrading it to OMV 3.x which might explain why a systemd script was not made.

      Mine listens on port 8182.
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380
    • systemctl enable plexpy

      don`t work for me, so I looked into the


      and there was

      ExecStart=/opt/Tautulli/ --quiet --daemon --nolaunch --config /opt/Tautulli/config.ini --datadir /opt/Tautulli

      wich ist obviously wrong. Because in /opt/ is only plexpy and no Tautulli. I guess OMV missed the new Tautulli path.

      After Changing all path and user in pleypy.service I could start with:

      systemctl daemon-reload
      systemctl start plexpy.service

      But I had no webinterface. And no clue why it doesn`t work.

      root@OMV:/lib/systemd/system# systemctl status plexpy.service ● plexpy.service - Tautulli - Stats for Plex Media Server usage Loaded: loaded (/lib/systemd/system/plexpy.service; enabled; vendor preset: enabled) Active: inactive (dead) since Sun 2018-04-29 17:48:02 CEST; 5min ago Apr 29 17:48:00 OMV systemd[1]: Starting Tautulli - Stats for Plex Media Server usage... Apr 29 17:48:02 OMV systemd[1]: Started Tautulli - Stats for Plex Media Server usage.

      So I am using also a cron job in OMV.
      python /opt/plexpy/

      It is a bit disappointing to use workarounds. Then I dont need Plugins.
      But maybe someone with more knowledge could help out.

      Thank you.
    • With the openmediavault-plexmediaserver 3.8.2 plugin on OpenMediaVault 4.1.14-1 I encountered this same issue. I enabled Plex, ticked the 'install' and 'run' PlexPy toggles, and saved the configuration. Some time later, Plex was running, PlexPy appeared to have installed, but hadn't started.

      I checked the /opt directory, and it was indeed /opt/plexpy instead of /opt/Tautulli as the service control file at /lib/systemd/system/plexpy.service was expecting. I changed the paths to /opt/plexpy, changed the user and group to plex and did

      systemctl daemon-reload
      systemctl enable plexpy
      systemctl start plexpy

      but still couldn't see it on port 8182. So I checked the config file /opt/plexpy/config.ini and http_port is set to 8181, so I instead tried that port and it works. So it looks like a few things are being missed ;) Hopefully it should now work without any further manual intervention.

      Edit: I was also getting an "ImportError: No module named pkg_resources" error when the plexpy service started working, so I did an apt-get install python-pip && pip install setuptools to fix that one (maybe I could have done apt-get install python-setuptools instead?)

      The post was edited 1 time, last by pfeerick ().