NextCloud Installation Q & A

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can you ls -la /etc/php5/fpm/pool.d and post the directory listing? I suspect you have no conf for that fpm pool.

      It's not difficult to create one but I'd be concerned as to why it's not there in the first place, is there other things with the install which is broken.

      I'm not so sure the permissions script will ameliorate the issue with no unix socket/fpm pool configuration for nextcloud, HOWEVER, I don't use that software and am just troubleshooting based on some experience with web development.

      To be sure, your install won't work until that .sock file appears, along with the correlating conf in fpm/pools.d . I'm just not sure if that was supposed to happen automagically or if you missed a step in the install (I haven't had more than a cursory glance at this guide)
      :cursing: Intel NUC Kit DE3815TYKHE My NAS build / ARK
      Atom E3815 1.46GHz4GB RAM • 1TB SSHD • 4GB eMMC
      OMV 3.x | OMV-Extras | Flash Memory | Pi-hole

      RPi/3 №1: LibreElec 8.xRPi/3 №2: SickRage, PiVPN, noip2
    • @drinks2go

      Source Code

      1. ls -la /etc/php5/fpm/pool.d
      2. total 36
      3. drwxr-xr-x 2 root root 4096 Aug 25 12:39 .
      4. drwxr-xr-x 4 root root 4096 Aug 26 13:21 ..
      5. -rw-r--r-- 1 root root 351 Aug 25 12:39 openmediavault-mysql-management-site.conf
      6. -rw-r--r-- 1 root root 1384 Jul 17 08:55 openmediavault-webgui.conf
      7. -rw-r--r-- 1 root root 18324 Feb 8 2017 www.conf
      @tinh_x7 I went through step 1e and noticed I am missing: description field. Also my fields for max post and max upload were different. After changing those I was able to access nextcloud installationi process. However when I entered mysql root password and create admin and clciked finish installation after a minute or so I got:
      This site can’t provide a secure connection
      ERR_SSL_PROTOCOL_ERROR

      Please note, I didn't enable ssl since in the tutorial it said: "Note: It would easier to begin the setup with HTTP than HTTPS. After the installation is done, you can change it to HTTPS, and use Let's Encrypt for your encryption if you want."
    • That's a progress.
      Max post and max upload aren't matter in this case.
      These parameters let you define your upload max size files.

      Turn off the HTTPS option in the vhost config, and reload the nginx service.
      After you have NC running like it suppose to, then you can re-enable HTTPS if you have the SSL certficate.

      Change this
      fastcgi_param HTTPS on;

      to
      fastcgi_param HTTPS off;

      Then run:
      sudo service nginx restart


      Note:
      For Clarification: the NextCloud vhost codes are set with HTTPS ON by default in my installation guide.
      Ensure to set HTTPS off in the vhost codes like above example if you not use SSL.
      OMV v3.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10

      The post was edited 5 times, last by tinh_x7 ().

    • Hi, first of all thanks for the nextcloud tutorial - it worked perfectly, at least until yesterday :)

      I had it running for a month now and yesterday I ran into timeouts while uploading data into the cloud. After a restart I got a "bad gateway" error, when checking the error log I got this, see below. (sock failed no such file or directory)

      I tried to fix it myself but unfortunately I am not used to work with linux. I didnt change permissions updated nextloud.

      Any help is highly appreciated!


      Source Code

      1. 2017/09/20 23:47:55 [crit] 6366#0: *14 connect() to unix:/var/run/fpm-34c7e7c6-933e-424b-97ee-8b5c99892767.sock failed (2: No such file or directory) while connecting to upstream, client: 217.225.220.92, server: , request: "GET /status.php HTTP/1.1", upstream: "fastcgi://unix:/var/run/fpm-34c7e7c6-933e-424b-97ee-8b5c99892767.sock:", host: "nas.XXdeletedXX.net:443"
      I might add that i dont find a "fpm-34c7e7c6-933e-424b-97ee-8b5c99892767.sock" file in var/run/
    • Hello,

      After upgrading to omv 4.0.5-1, i have a 502 bad gateway error on the http and https nextcloud web access.

      My OMV webaccess is working fine.

      I've the same error as dazzil

      I already restarted nginx and MySQL
      OMV 4.0.14-1
      omvextrasorg + Deluge + MiniDLNA + MySQL + Nginx + Nextcloud 12
      Pentium G4600 | Asrock H170M-ITX/AC | 4Go DDR4 | 120Go SSD + 6To RAID5 | Kolink Satellite | 400W Lepa

      The post was edited 3 times, last by Duff ().

    • My problem was very strange but I solved it: Reason for timeouts and php errors was caused by one mobile nextcloud app, which created so many logins that somehow the server went down. After reinstalling the app and clearing the bruteforce table of nextcloud, nextcloud is running fine again.
    • hi i tried to install the plugin according to the manual
      but it stopped at the first step :(

      Source Code

      1. root@openmediavault:~# apt-get install php5-curl
      2. Paketlisten werden gelesen... Fertig
      3. Abhängigkeitsbaum wird aufgebaut.
      4. Statusinformationen werden eingelesen.... Fertig
      5. Package php5-curl is not available, but is referred to by another package.
      6. This may mean that the package is missing, has been obsoleted, or
      7. is only available from another source
      8. E: Package 'php5-curl' has no installation candidate
      can somebody help me with this issue?

      i tried also to update and upgrade but this was also not working
    • Your repos must be wrong. What is the output
      of:

      cat /etc/apt/sources.list
      apt-get update
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!

      The post was edited 1 time, last by ryecoaaron ().

    • Source Code

      1. root@openmediavault:~# cat /etc/apt/sources.list
      2. #
      3. # deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20170731-21:43]/ jessie contrib main non-free
      4. #deb cdrom:[Debian GNU/Linux 8 _Jessie_ - Official Snapshot amd64 LIVE/INSTALL Binary 20170731-21:43]/ jessie contrib main non-free
      5. deb http://ftp2.de.debian.org/debian/ jessie main
      6. deb-src http://ftp2.de.debian.org/debian/ jessie main
      7. deb http://ftp.de.debian.org/debian-security/ jessie/updates main contrib non-free
      8. deb-src http://ftp.de.debian.org/debian-security/ jessie/updates main contrib non-free
      9. # jessie-updates, previously known as 'volatile'
      10. deb http://ftp.de.debian.org/debian/ jessie-updates main contrib non-free
      11. deb-src http://ftp.de.debian.org/debian/ jessie-updates main contrib non-free
      Display All
      apt-update

      Source Code

      1. -bash: apt-update: Kommando nicht gefunden. (command not found)
    • Users Online 2

      1 Member and 1 Guest