NextCloud Installation Q & A

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Hi guys,
      I have problem with installing NC 11. I'm sure i've done everything like in tutorial but when i'd like do install NC it's show 502 Bad gateway nginx 1.6.2
      . I notice that when i'm installing mysql it's show smoe errors like this:

      Shell-Script

      1. ">>> *************** Error ***************
      2. Bad Gateway
      3. <<< *************************************
      4. Processing triggers for php5-fpm (5.6.30+dfsg-0+deb8u1) ...
      5. Processing triggers for openmediavault (3.0.67) ...
      6. Restarting engine daemon ...
      7. Setting up dbconfig-common (1.8.47+nmu3+deb8u1) ...
      8. Creating config file /etc/dbconfig-common/config with new version
      9. Setting up php5 (5.6.30+dfsg-0+deb8u1) ...
      10. Setting up php5-mysqlnd (5.6.30+dfsg-0+deb8u1) ...
      11. Creating config file /etc/php5/mods-available/mysqlnd.ini with new version
      12. php5_invoke: Enable module mysqlnd for cgi SAPI
      13. php5_invoke: Enable module mysqlnd for cli SAPI
      14. php5_invoke: Enable module mysqlnd for fpm SAPI
      15. Creating config file /etc/php5/mods-available/mysql.ini with new version
      16. php5_invoke: Enable module mysql for cgi SAPI
      17. php5_invoke: Enable module mysql for cli SAPI
      18. php5_invoke: Enable module mysql for fpm SAPI
      19. Creating config file /etc/php5/mods-available/mysqli.ini with new version
      20. php5_invoke: Enable module mysqli for cgi SAPI
      21. php5_invoke: Enable module mysqli for cli SAPI
      22. php5_invoke: Enable module mysqli for fpm SAPI
      23. Creating config file /etc/php5/mods-available/pdo_mysql.ini with new version
      24. php5_invoke: Enable module pdo_mysql for cgi SAPI
      25. php5_invoke: Enable module pdo_mysql for cli SAPI
      26. php5_invoke: Enable module pdo_mysql for fpm SAPI
      27. Setting up php5-pgsql (5.6.30+dfsg-0+deb8u1) ...
      28. Creating config file /etc/php5/mods-available/pgsql.ini with new version
      29. php5_invoke: Enable module pgsql for cgi SAPI
      30. php5_invoke: Enable module pgsql for cli SAPI
      31. php5_invoke: Enable module pgsql for fpm SAPI
      32. Creating config file /etc/php5/mods-available/pdo_pgsql.ini with new version
      33. php5_invoke: Enable module pdo_pgsql for cgi SAPI
      34. php5_invoke: Enable module pdo_pgsql for cli SAPI
      35. php5_invoke: Enable module pdo_pgsql for fpm SAPI
      36. Setting up php5-sqlite (5.6.30+dfsg-0+deb8u1) ...
      37. Creating config file /etc/php5/mods-available/sqlite3.ini with new version
      38. php5_invoke: Enable module sqlite3 for cgi SAPI
      39. php5_invoke: Enable module sqlite3 for cli SAPI
      40. php5_invoke: Enable module sqlite3 for fpm SAPI
      41. Creating config file /etc/php5/mods-available/pdo_sqlite.ini with new version
      42. php5_invoke: Enable module pdo_sqlite for cgi SAPI
      43. php5_invoke: Enable module pdo_sqlite for cli SAPI
      44. php5_invoke: Enable module pdo_sqlite for fpm SAPI
      45. Setting up mywebsql (3.7-omv1) ...
      46. Setting up openmediavault-mysql (3.0.4) ...
      47. >>> *************** Error ***************
      48. Bad Gateway
      49. <<< *************************************
      Display All

      This is a bug or i'm too weak for installing it on omv?:(

      Best regards
      Jakotaki

      The post was edited 1 time, last by WastlJ ().

    • jakotaki007 wrote:

      Hi guys,
      I have problem with installing NC 11. I'm sure i've done everything like in tutorial but when i'd like do install NC it's show 502 Bad gateway nginx 1.6.2
      . I notice that when i'm installing mysql it's show smoe errors like this:

      Shell-Script

      1. ">>> *************** Error ***************
      2. Bad Gateway
      3. <<< *************************************
      4. Processing triggers for php5-fpm (5.6.30+dfsg-0+deb8u1) ...
      5. Processing triggers for openmediavault (3.0.67) ...
      6. Restarting engine daemon ...
      7. Setting up dbconfig-common (1.8.47+nmu3+deb8u1) ...
      8. Creating config file /etc/dbconfig-common/config with new version
      9. Setting up php5 (5.6.30+dfsg-0+deb8u1) ...
      10. Setting up php5-mysqlnd (5.6.30+dfsg-0+deb8u1) ...
      11. Creating config file /etc/php5/mods-available/mysqlnd.ini with new version
      12. php5_invoke: Enable module mysqlnd for cgi SAPI
      13. php5_invoke: Enable module mysqlnd for cli SAPI
      14. php5_invoke: Enable module mysqlnd for fpm SAPI
      15. Creating config file /etc/php5/mods-available/mysql.ini with new version
      16. php5_invoke: Enable module mysql for cgi SAPI
      17. php5_invoke: Enable module mysql for cli SAPI
      18. php5_invoke: Enable module mysql for fpm SAPI
      19. Creating config file /etc/php5/mods-available/mysqli.ini with new version
      20. php5_invoke: Enable module mysqli for cgi SAPI
      21. php5_invoke: Enable module mysqli for cli SAPI
      22. php5_invoke: Enable module mysqli for fpm SAPI
      23. Creating config file /etc/php5/mods-available/pdo_mysql.ini with new version
      24. php5_invoke: Enable module pdo_mysql for cgi SAPI
      25. php5_invoke: Enable module pdo_mysql for cli SAPI
      26. php5_invoke: Enable module pdo_mysql for fpm SAPI
      27. Setting up php5-pgsql (5.6.30+dfsg-0+deb8u1) ...
      28. Creating config file /etc/php5/mods-available/pgsql.ini with new version
      29. php5_invoke: Enable module pgsql for cgi SAPI
      30. php5_invoke: Enable module pgsql for cli SAPI
      31. php5_invoke: Enable module pgsql for fpm SAPI
      32. Creating config file /etc/php5/mods-available/pdo_pgsql.ini with new version
      33. php5_invoke: Enable module pdo_pgsql for cgi SAPI
      34. php5_invoke: Enable module pdo_pgsql for cli SAPI
      35. php5_invoke: Enable module pdo_pgsql for fpm SAPI
      36. Setting up php5-sqlite (5.6.30+dfsg-0+deb8u1) ...
      37. Creating config file /etc/php5/mods-available/sqlite3.ini with new version
      38. php5_invoke: Enable module sqlite3 for cgi SAPI
      39. php5_invoke: Enable module sqlite3 for cli SAPI
      40. php5_invoke: Enable module sqlite3 for fpm SAPI
      41. Creating config file /etc/php5/mods-available/pdo_sqlite.ini with new version
      42. php5_invoke: Enable module pdo_sqlite for cgi SAPI
      43. php5_invoke: Enable module pdo_sqlite for cli SAPI
      44. php5_invoke: Enable module pdo_sqlite for fpm SAPI
      45. Setting up mywebsql (3.7-omv1) ...
      46. Setting up openmediavault-mysql (3.0.4) ...
      47. >>> *************** Error ***************
      48. Bad Gateway
      49. <<< *************************************
      Display All
      This is a bug or i'm too weak for installing it on omv?:(

      Best regards
      Jakotaki

      tinh_x7 wrote:

      @jakotaki007,

      Ensure you installed mySQL, and Nginx before begin the NC installation.
      Make sure you mySQL is running and accessible.
      I have the same problem and get a similiar error message when installing nginx. I really don't know what we are doing wrong. Did multiple fresh installations of OMV on my Raspberry Pi 3 and get this errors every time. I didn't even come to the point of trying to install NC...
      Would be great if you could help us @tinh_x7

      ps: the images in your guide aren't visible anymore. Would be great if you could fix that :)
    • EDIT: SOLVED. I just had to look through my nginx configuration screens and make sure they were exactly set up as in the images.

      tinh_x7 wrote:

      I don't use RPI, can't help you much.
      Your error seem to be PHP-FPM related.

      Clear out your histories/cookies, and start a fresh NC installation.

      Check this out: scalescale.com/tips/nginx/502-bad-gateway-error-using-nginx/
      Hey, thank you for this guide!

      I started a fresh installation of NC and ran into this same issue. Maybe there is a problem with the php settings?

      I followed the link, and found this

      > Nginx with PHP-FPM: same as Apache example, let’s imagine your php daemon stop working, or get’s overloaded by requests, it will not work properly and the all the php requests from nginx would not be served, so, a 502 Bad Gateway error will appear. How to fix it? Restart php-fpm daemon and check the logs.

      I was wondering what is the best way to restart php-fpm, check the logs, and troubleshoot this?

      EDIT: SOLVED. I just had to look through my nginx configuration screens and make sure they were exactly set up as in the images

      The post was edited 2 times, last by semitones ().

    • Hi, I have a Raspberry Pi3 model B and a DietPi OS. I'm trying to run Nextcloud, I followed the guide(and not installed Nextcloud via diet-launcher because is not working when you also have OMV installed) and I receive "502 Bad Gateway" when I create Nextcloud pool in Nginx plugin.
      I connected to the Nextcloud page via my browser and I get this error: "No database drivers(sqlite, mysql, or postgresql) installed."

      What can I do? Thank you in advance and sorry for my bad English, is not my mother tongue.
    • tinh_x7 wrote:

      I found an alternative lightweight of NextCloud & Owncloud, and it calls: FileRun.
      It looks similar to Google Drive.

      You can check it out and report your feedback here.

      filerun.com/

      Demo:
      demo.filerun.com/#/HOME

      Installation Guide:
      docs.filerun.com/filerun_install_guide


      [IMG:https://www.filerun.com/images/screenshot.jpg?v=2017_01]
      It would be nice to have a very clear and derailed guide on how to install Filerun on OMV, as the wonderful one of Nextcloud.

      I have not been able to install filerun so far :(
    • Users Online 2

      2 Guests