NextCloud Installation Q & A

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Okay i updated to omv4 today. Now i have the problem that i can´t start nextcloud.

      I have no answer why i can´t start Nextcloud.

      At first. I installed nextcloud unter OMV3. I make no changes if i updated to omv4. Maybe during the update the MYSQL database changed to MariaDB.

      I saw in omv4 dashboard a green point at Mysql. In NGINX I dont´t see any problems. Maybe there are some other changes.

      If i started nextcloud in my browser nothing happens. I saw only the ip adress and a white tap.

      Maybe someone from you may have a solution.

      Thanks a lot


      The post was edited 1 time, last by Django43 ().

    • On OMV v4 you only have php7.
      If you have your old mysql DB you can try to import it in OMV on the plugin page.

      Or else, redo everything.
      Instead of the php5 packages you have to look for their php7 versions, there are some differences in package naming.
      Install these:


      1. apt-get install php7.0-curl php7.0-gd php-apcu
      if you use redis then:


      1. apt-get install php-redis
      the rest should be the same as told in the tutorial
    • @'br41n

      Thanks a lot for your response. I do the steps in your post before. Now I get another error:

      [Blocked Image:]

      I don´t understand waht it means. Why my modules are "PHP-Module wurden installiert, werden aber als noch fehlend gelistet?". Where i have to list the modules. Maybe I make some mistakes.

      Maybe someone of you could help me.

      Thanks a lot

    • Django43 wrote:

      Why my modules are "PHP-Module wurden installiert, werden aber als noch fehlend gelistet?". Where i have to list the modules. Maybe I make some mistakes.
      apt-get install php7.0-zip
      omv 4.1.17 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13 plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Hi,

      stupid question for all linux Gurus but not for me:

      Which config.php you are talking about at this step:

      Source Code

      1. 8. Memory caching:
      2. Redis is recommended or you can use APCu for low-power CPU such as dual-core or RPI.
      3. APCu: apt-get install php5-apcu
      4. Config.php: 'memcache.local' => '\OC\Memcache\APCu',
      5. Redis: apt-get install redis-server php5-redis
      6. Config.php: 'memcache.locking' => '\OC\Memcache\Redis',
      7. Whatever method you choose, it should look like this in the config.php:
      Display All

      is it the one located here:

      Source Code

      1. /srv/dev-disk-by-label-data/www/nextcloud/config/config.php
      Thanks for help
    • @tinh_x7 -- >Thanks for answer.

      Yesterday i managed to synchronize contacts and calendar between IOS/Outlook and Nextcloud but i can't download or upload any files.

      While trying to download one of the example pictures i got this error:

      Source Code

      1. file_get_contents(/srv/dev-disk-by-label-data/www/nextcloud/data/Mirko/files/Photos/Coast.jpg): failed to open stream: No such file or directory at /srv/dev-disk-by-label-data/www/nextcloud/lib/private/Files/Storage/Local.php#209

      Than i checked if directory exists and found out that this is missing :

      Source Code

      1. files/Photos/Coast.jpg
      This is how it looks at my Server:

      Source Code

      1. root@openmediavault /srv/dev-disk-by-label-data/www/nextcloud/data/Mirko > ls -la
      2. insgesamt 24
      3. drwxrwxr-x+ 3 www-data www-data 4096 Okt 18 21:47 .
      4. drwxrwx---+ 9 www-data www-data 4096 Okt 19 10:47 ..
      5. drwxrwxr-x+ 2 www-data www-data 4096 Okt 19 19:06 cache
      6. root@openmediavault /srv/dev-disk-by-label-data/www/nextcloud/data/Mirko >
      If i try to upload a file i only get a small hint which tells

      Source Code

      1. forbidden
      Can somebody please help?


      EDIT: Solved by changing path to data directory at config.php.

      The post was edited 3 times, last by Epo_Deluxe: Problem solved ().

    • Hi all,

      after i manage to fix my problem with file/data upload and download i switched on "HTTPS" at NGINX Server config.

      But now i have the problem that if i try to connect via Browser (Chrome/Firefox) it allways ends with:

      Source Code

      1. 400 Bad Request
      2. The plain HTTP request was sent to HTTPS port
      3. nginx/1.6.2
      if i try it a second time within the same window it's working and Nextcloud website is opened.

      NGINX config:

      Do i need to configure something else?

      Best regards
      • NGINX_SSL.jpg

        39.96 kB, 764×477, viewed 266 times
    • I suggest use HTTP on your initial setup, then turn on HTTPS after that.
      However, you need to turn off HTTP in the vhost config in your initial setup like I described from previous post above.
      Whatever port that you setup in Nginx, use that port number.
      i.e: http://local.ip.address:port#
      OMV v4.0
      Asus Z97-A/3.1; i3-4370
      32GB RAM Corsair Vengeance Pro
      4x3TB RAID10
    • Users Online 2

      2 Guests