VirtualBox ERROR

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • VirtualBox ERROR

      Hi Guys,

      Have installt the VirtualBox plugin but i cant enable it.. get this error: Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start virtualbox-web 2>&1' with exit code '1': A dependency job for virtualbox-web.service failed. See 'journalctl -xn' for details.

      Display Spoiler
      Fehler #0:exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start virtualbox-web 2>&1' with exit code '1': A dependency job for virtualbox-web.service failed. See 'journalctl -xn' for details.' in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/php/openmediavault/system/systemctl.inc(83): OMV\System\Process->execute(Array, 1)#1 /usr/share/php/openmediavault/system/systemctl.inc(101): OMV\System\SystemCtl->exec('start', NULL, false)#2 /usr/share/openmediavault/engined/module/virtualbox.inc(107): OMV\System\SystemCtl->enable(true)#3 /usr/share/openmediavault/engined/rpc/config.inc(189): OMV\Engined\Module\VirtualBox->startService()#4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(150): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatus0Y...', '/tmp/bgoutputvk...')#8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(151): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#9 /usr/share/openmediavault/engined/rpc/config.inc(208): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#12 /usr/share/php/openmediavault/rpc/rpc.inc(84): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#13 /usr/sbin/omv-engined(516): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#14 {main}


      Hope you can help me..
      best regards
      MrYoshii


      Nas Build:

      OS: OMV 3.x
      CPU: Intel Core I5-4570
      MB: Gigabyte GA-H97N-WIFI
      RAM: Crucial Ballistix Sport Arbeitsspeicher 8GB
      Power Supply: Be quiet! BN140 System Power 7 300Watt
      HDDs: 2x 2TB Seagate Barracuda ST2000DM001, 120GB Samsung 850 EVO SSD System Drive, 2x 2TB Western Digital Green HDD
      CASE: Fractal Design Node 804
    • If you are using the 4.9 kernel, the virtualbox module will fail when trying to compile. You either have to revert to the 4.8 kernel or use my virtualbox packages. Both are covered in other threads.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • ryecoaaron wrote:

      If you are using the 4.9 kernel, the virtualbox module will fail when trying to compile. You either have to revert to the 4.8 kernel or use my virtualbox packages. Both are covered in other threads.
      Hello ryecoaaron,

      I've checked several sources and read a lot about OMV3 & VirtualBox but I'm a bit stuck right now.
      I've planed to replace one of my Syno (412+) by an OMV instance. So far, OMV 3.0.64 is installed and configured, NFS/CIFS and iSCSI have been tested properly by now I need to have VBox up and running as my 3rd Proxmox cluster node is a VM hosted on my NAS (only used for quorum purpose).

      I've so far tried to install openmediavault-virtualbox plugin running 4.8.0-2-grsec, 4.8.0.0-bpo & 4.9.0-0.bpo with no luck. Each time I try to enable it it fails with:

      Display Spoiler

      Error #0:exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start virtualbox-web 2>&1' with exit code '1': A dependency job for virtualbox-web.service failed. See 'journalctl -xn' for details.' in /usr/share/php/openmediavault/system/process.inc:175Stack trace:#0 /usr/share/php/openmediavault/system/systemctl.inc(83): OMV\System\Process->execute(Array, 1)#1 /usr/share/php/openmediavault/system/systemctl.inc(101): OMV\System\SystemCtl->exec('start', NULL, false)#2 /usr/share/openmediavault/engined/module/virtualbox.inc(107): OMV\System\SystemCtl->enable(true)#3 /usr/share/openmediavault/engined/rpc/config.inc(189): OMV\Engined\Module\VirtualBox->startService()#4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)#5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(150): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)#7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusNW...', '/tmp/bgoutputZs...')#8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(151): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))#9 /usr/share/openmediavault/engined/rpc/config.inc(208): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)#10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)#11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)#12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)#13 /usr/sbin/omv-engined(522): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)#14 {main}


      Kind of error message (and complaining about missing headers during installation too).

      As 4.8 (bpo and not) and 4.9 bpo are not solving the problem, could you point me to the specific thread(s) where you explain how to install (and where to get) your VB packages ?

      Thanks a lot in advance !

      OIivier
    • peterka wrote:

      but the next issue appears – anyway phpVirtualBox seems to run well
      This is just a warning. There is no version 5.1 of phpvirtualbox.
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.9
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!