Plex server not working after plug-in update

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Plex server not working after plug-in update

      Hello,

      I just performed an update of my plexemediaserver plugin and it's now not connecting. When I try to activate/deactive it in the OMV UI, I get the following error :


      Source Code

      1. Failed to execute command 'export LANG=C; update-rc.d 'plexmediaserver' disable 2>&1': update-rc.d: error: no runlevel symlinks to modify, aborting! update-rc.d: using dependency based boot sequencing



      Source Code

      1. Erreur #4000:
      2. exception 'OMVException' with message 'Failed to execute command 'export LANG=C; update-rc.d 'plexmediaserver' disable 2>&1': update-rc.d: error: no runlevel symlinks to modify, aborting!
      3. update-rc.d: using dependency based boot sequencing' in /usr/share/php/openmediavault/initscript.inc:90
      4. Stack trace:
      5. #0 /usr/share/php/openmediavault/initscript.inc(56): OMVSysVInitScript->update(true)
      6. #1 /usr/share/openmediavault/engined/module/plexmediaserver.inc(52): OMVSysVInitScript->exec()
      7. #2 /usr/share/openmediavault/engined/rpc/config.inc(164): OMVModulePlexMediaServer->stopService()
      8. #3 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      9. #4 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      10. #5 /usr/share/php/openmediavault/rpcservice.inc(158): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      11. #6 /usr/share/openmediavault/engined/rpc/config.inc(224): OMVRpcServiceAbstract->callMethodBg('applyChanges', Array, Array)
      12. #7 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      13. #8 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      14. #9 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChangesBg', Array, Array)
      15. #10 /usr/sbin/omv-engined(500): OMVRpc::exec('Config', 'applyChangesBg', Array, Array, 1)
      16. #11 {main}
      Display All

      I tried rebooting OMV but no luck, the server is still missing.

      What can I do ?

      Just when my wife was about to start watching the last episode of her show... :(


      Thank you.
    • Hello,

      There are 2 things you can do.

      1. Uninstall and purge plexmediaserver and openmediavault-plexmediaserver, then install it again.
      2. Look in startup script, runlevels, permissions etc. (I believe here is your problem)

      But as plex setup is quick and easy I would just reinstall it completely.
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!
    • Hello,

      Thanks for the answer ! Sorry I didn't answer before but I have a more details about it to try to fix it for good.

      So the issue is connected to the fact that I recently installed the docker plugin to test it out. I ended up not having the time to do so, so I forgot about it until an update of the docker plug-in (docker-engine (17.03.0~ce-0~debian-wheezy) wheezy) started failing. I'm getting this error, repeated literally hundreds of times in the log :

      Source Code

      1. >>> *************** Error ***************
      2. Failed to execute command 'export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::="--force-confold" install docker-engine 2>&1': Reading package lists...
      3. Building dependency tree...
      4. Reading state information...
      5. Recommended packages:
      6. aufs-tools cgroupfs-mount cgroup-lite
      7. The following packages will be upgraded:
      8. docker-engine
      9. 1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      10. 2 not fully installed or removed.
      11. Need to get 0 B/27.3 MB of archives.
      12. After this operation, 150 kB of additional disk space will be used.
      13. WARNING: The following packages cannot be authenticated!
      14. docker-engine
      15. Authentication warning overridden.
      16. (Reading database ...
      17. 33895 files and directories currently installed.)
      18. Preparing to replace docker-engine 1.13.0-0~debian-wheezy (using .../docker-engine_17.03.0~ce-0~debian-wheezy_amd64.deb) ...
      19. Stopping Docker: docker
      20. start-stop-daemon: warning:
      21. failed to kill 2341: No such process
      22. No process in pidfile '/var/run/docker-ssd.pid' found running; none killed.
      23. invoke-rc.d: initscript docker, action "stop" failed.
      24. dpkg: warning: subprocess old pre-removal script returned error exit status 1
      25. dpkg: trying script from the new package instead ...
      26. Stopping Docker: docker
      27. start-stop-daemon: warning:
      28. failed to kill 2341: No such process
      29. No process in pidfile '/var/run/docker-ssd.pid' found running; none killed.
      30. invoke-rc.d: initscript docker, action "stop" failed.
      31. dpkg: error processing /var/cache/apt/archives/docker-engine_17.03.0~ce-0~debian-wheezy_amd64.deb (--unpack):
      32. subprocess new pre-removal script returned error exit status 1
      33. dpkg: error while cleaning up:
      34. subprocess installed post-installation script returned error exit status 1
      35. Errors were encountered while processing:
      36. /var/cache/apt/archives/docker-engine_17.03.0~ce-0~debian-wheezy_amd64.deb
      37. Creating index of upgradeable packages ...
      38. Creating index of openmediavault plugins ...
      39. E
      40. :
      41. Sub-process /usr/bin/dpkg returned an error code (1)
      42. <<< *************************************
      Display All
      Since that docker update started to fail, the plex server plugin would fail to load properly anytime it was updated itself. The only "solution" for now that I found is to either install or uninstall the docker plugin. When I do that, the plex server is back and running....until it needs to be updated again.
      Note that even when the docker plugin is uninstalled, I still get the notification for the "docker-engine (17.03.0~ce-0~debian-wheezy) wheezy" update and it still fails with the same error.

      I know it's a bit all over the place but any suggestion to fix this for good ? The ideal solution for me would be to get both plex and docker running as I would like to test the plex container for docker instead of using the omv plug-in but being able to uninstall docker for good would work too.

      Thanks.
    • DannyBiker wrote:

      Hello,

      Thanks for the answer ! Sorry I didn't answer before but I have a more details about it to try to fix it for good.

      So the issue is connected to the fact that I recently installed the docker plugin to test it out. I ended up not having the time to do so, so I forgot about it until an update of the docker plug-in (docker-engine (17.03.0~ce-0~debian-wheezy) wheezy) started failing. I'm getting this error, repeated literally hundreds of times in the log :

      Source Code

      1. >>> *************** Error ***************
      2. Failed to execute command 'export LANG=C; export DEBIAN_FRONTEND=noninteractive; apt-get --yes --force-yes --fix-missing --auto-remove --allow-unauthenticated --show-upgraded --option DPkg::Options::="--force-confold" install docker-engine 2>&1': Reading package lists...
      3. Building dependency tree...
      4. Reading state information...
      5. Recommended packages:
      6. aufs-tools cgroupfs-mount cgroup-lite
      7. The following packages will be upgraded:
      8. docker-engine
      9. 1 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
      10. 2 not fully installed or removed.
      11. Need to get 0 B/27.3 MB of archives.
      12. After this operation, 150 kB of additional disk space will be used.
      13. WARNING: The following packages cannot be authenticated!
      14. docker-engine
      15. Authentication warning overridden.
      16. (Reading database ...
      17. 33895 files and directories currently installed.)
      18. Preparing to replace docker-engine 1.13.0-0~debian-wheezy (using .../docker-engine_17.03.0~ce-0~debian-wheezy_amd64.deb) ...
      19. Stopping Docker: docker
      20. start-stop-daemon: warning:
      21. failed to kill 2341: No such process
      22. No process in pidfile '/var/run/docker-ssd.pid' found running; none killed.
      23. invoke-rc.d: initscript docker, action "stop" failed.
      24. dpkg: warning: subprocess old pre-removal script returned error exit status 1
      25. dpkg: trying script from the new package instead ...
      26. Stopping Docker: docker
      27. start-stop-daemon: warning:
      28. failed to kill 2341: No such process
      29. No process in pidfile '/var/run/docker-ssd.pid' found running; none killed.
      30. invoke-rc.d: initscript docker, action "stop" failed.
      31. dpkg: error processing /var/cache/apt/archives/docker-engine_17.03.0~ce-0~debian-wheezy_amd64.deb (--unpack):
      32. subprocess new pre-removal script returned error exit status 1
      33. dpkg: error while cleaning up:
      34. subprocess installed post-installation script returned error exit status 1
      35. Errors were encountered while processing:
      36. /var/cache/apt/archives/docker-engine_17.03.0~ce-0~debian-wheezy_amd64.deb
      37. Creating index of upgradeable packages ...
      38. Creating index of openmediavault plugins ...
      39. E
      40. :
      41. Sub-process /usr/bin/dpkg returned an error code (1)
      42. <<< *************************************
      Display All
      Since that docker update started to fail, the plex server plugin would fail to load properly anytime it was updated itself. The only "solution" for now that I found is to either install or uninstall the docker plugin. When I do that, the plex server is back and running....until it needs to be updated again.
      Note that even when the docker plugin is uninstalled, I still get the notification for the "docker-engine (17.03.0~ce-0~debian-wheezy) wheezy" update and it still fails with the same error.

      I know it's a bit all over the place but any suggestion to fix this for good ? The ideal solution for me would be to get both plex and docker running as I would like to test the plex container for docker instead of using the omv plug-in but being able to uninstall docker for good would work too.

      Thanks.
      any solution to this yet? I really can't get anything to update with this docker problem.