Can't connect to OMV & Upgrade help

    • OMV 1.0

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't connect to OMV & Upgrade help

      Hi everyone, I set up OMV on a RPI2 around 2 years ago to use as network drive for a CCTV cam.

      It is running v1.13. Had a few problems lately so I thought I would try upgrade OMV.

      When I went on the web gui and tried upgrade I got an error Error-updating-Secondary-OMV-extras-Failed-to-execute-command-export-LANG-C-apt

      I had a search and someone's said it could be DNS. I logged in and added a primary dns as my router and secondary 8.8.8.8. Since I have done that I can't log on it via the IP or through SSH.

      Can anyone help? The problem I have is I can't lose the config, I had loads of problems originally setting the share up for the CCTV and can't remember all the details.

      Is there any way to fix this and upgrade?

      Thanks :)
    • Either login via ssh or locally and try omv-firstaid. I would update from the command line. Use omv-update (if it is exists, otherwise you apt-get update && apt-get dist-upgrade)
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • marbar2k wrote:

      Since adding the dns I can't ssh onto it for some reason?
      No idea but that is why I suggested omv-firstaid first. I need to see the output of the update commands to help.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • I have managed to log back into the web gui. For some reason when I add dns it deletes the network config?

      When I try and upgrade as you suggested above, I get the following error ....



      Error #4000:exception 'OMVException' with message 'Failed to execute command 'export LANG=C; apt-get update 2>&1': Ign file: Release.gpgIgn file: ReleaseErr mirrordirector.raspbian.org wheezy Release.gpg Something wicked happened resolving 'mirrordirector.raspbian.org:http' (-5 - No address associated with hostname)Ign mirrordirector.raspbian.org wheezy ReleaseErr packages.openmediavault.org kralizec Release.gpg Something wicked happened resolving 'packages.openmediavault.org:http' (-5 - No address associated with hostname)Err packages.openmediavault.org kralizec-proposed Release.gpg Something wicked happened resolving 'packages.openmed