<SOLVED> SSL certificate - unable to delete old SSL certificate

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • <SOLVED> SSL certificate - unable to delete old SSL certificate

      Hello mates!

      I'm playing around with my OMV and wanted to change my ssl certificate:

      I added it 2 month ago with the ADD / Import function of OMV.

      Problem: i'm unable to remove it. "see screenshot"

      If i add a newer one: still cant delete and OMV still use the old one as SSL certificate: shows as an outdated one now.

      If i try to rename it i get error:
      Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; nginx -t 2>&1' with exit code '1': nginx: [emerg] SSL_CTX_use_PrivateKey_file("/etc/ssl/private/openmediavault-4e3dff1e-d7ad-4824-a168-e79ea01ea786.key") failed (SSL: error:0906D06C:PEM routines:PEM_read_bio:no start line:Expecting: ANY PRIVATE KEY error:140B0009:SSL routines:SSL_CTX_use_PrivateKey_file:PEM lib)nginx:

      when looking directly to the folder:into etc/ssl/private: The files is 0ko. "see screenshot"
      If i put some SSL lines in it: it get overwritten automatically.

      Any hint? :)

      OMV 3.0.64 up-to-date as far as i know.
      • nodelete.PNG

        11.77 kB, 429×168, viewed 329 times
      • ssl.PNG

        3.27 kB, 637×30, viewed 337 times