Can't install OVM over clean debian-stretch

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Can't install OVM over clean debian-stretch

      Hi,
      I'm still struggiling in setting up my machine so that it has OVM, runs kodi and logs to openvpn automatically.
      Due to hardware issues, my PC is a G4560 kabylake CPU with integrated graphics I can't rely on a stable debian distro and it's drivers.

      Today I've tried installing a fresh debian with gnome desktop base on stretch (/testing) netinstall iso.

      After logging in to gnome, following these steps:

      Shell-Script

      1. Shell-Script
      2. echo "deb http://packages.openmediavault.org/public erasmus main" > /etc/apt/sources.list.d/openmediavault.list
      3. apt-get update
      4. apt-get install openmediavault-keyring postfix
      5. apt-get update
      6. apt-get install openmediavault
      7. omv-initsystem

      I get an error while running apt-get install openmediavault

      Source Code

      1. Some packages could not be installed. This may mean that you have
      2. requested an impossible situation or if you are using the unstable
      3. distribution that some required packages have not yet been created
      4. or been moved out of Incoming.
      5. The following information may help to resolve the situation:
      6. The following packages have unmet dependencies:
      7. openmediavault : Depends: php5-fpm but it is not installable
      8. Depends: php5-cgi but it is not installable
      9. Depends: php5-cli (>= 5.6) but it is not installable
      10. Depends: php5-pam but it is not going to be installed
      11. E: Unable to correct problems, you have held broken packages.
      Display All

      Anyone could help me out? I'm still a linux newbie and I'm not really sure if its OK, to install those packages from a backport repo or what other steps I could do to make OMV run.

      For example stretch repository has a php-cli package in version 7.0. Will OMV understand that as it;s named simply php-cli and not php5-cli.

      Otherwise all other parts worked as they should (kodi, openvpn, tixati) before I wiped the HDD and tried one more install from scratch.

      I'd appreciate any help!
      Regards

      The post was edited 1 time, last by b1azk0 ().

    • b1azk0 wrote:

      Anyone could help me out? I'm still a linux newbie and I'm not really sure if its OK, to install those packages from a backport repo or what other steps I could do to make OMV run.

      For example stretch repository has a php-cli package in version 7.0. Will OMV understand that as it;s named simply php-cli and not php5-cli.

      Otherwise all other parts worked as they should (kodi, openvpn, tixati) before I wiped the HDD and tried one more install from scratch.
      OMV 2.x ONLY works on Debian Wheezy
      OMV 3.x ONLY works on Debian Jessie
      OMV 2.x and 3.x only work with php5.
      omv 4.0.11 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.0
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Thanks.

      I have added stable and backports repo and set them as default.
      After apt update omv found dependencies and it's installing itself.

      Also, as i'm not sure about it - when you say:

      ryecoaaron wrote:

      OMV 3.x ONLY works on Debian Jessie
      OMV 2.x and 3.x only work with php5.
      Does it mean that Debian Jessie with backports / testing repo won't work by definition?

      Edit:
      Install complete,
      omv-initsystem gives:

      Source Code

      1. omv-initsystem
      2. W: mdadm: /etc/mdadm/mdadm.conf defines no arrays.
      3. 2017/03/13 18:35:56 socat[10163] E connect(5, AF=1 "/var/run/rrdcached.sock", 25): No such file or directory
      4. run-parts: /usr/share/openmediavault/initsystem/99rrd exited with return code 1