RPCMOUNTDOPTS configure port

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • RPCMOUNTDOPTS configure port

      I have always had the variable set RPCMOUNTDOPTS="-p 32767" in /etc/default/nfs-kernel-server to allow me to define the NFS port and allow it though a firewall.

      I updated OMV today and it seems every time I make a change to an NFS share now, the /etc/default/nfs-kernel-server file is overwritten back to default and I loose my static port.

      I tried to stop root over writing the file #chattr +i /etc/default/nfs-kernel-server but the GUI throws an error with this set.

      If I administer my shares from CLI, I presume that OMV wont overwrite the file? Or is there another way to fix this?
    • Check out github.com/openmediavault/open…t/mkconf/nfsd.d/10default to find out the env variable you must enter to /etc/default/openmediavault to customize the settings.

      OMV is the master of the config files, it will always override you changes. You need to find other ways as suggested above to customize the default values.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit