RPi3 and WiFi only

    • Resolved
    • OMV 3.x
    • RPi3 and WiFi only

      Good evening,

      This evening I started to deploy OMV on a RPi3 using the latest image available.
      Once deployed I have added testing & community repo's and update the system.

      I am facing a very strange behaviour with the on-board networks though.
      I have enabled both eth0 and wlan0. If I leave the ethernet cable plugged in (and connected) then I can browse to both the RPi IP's (the LAN and the WLAN ones).
      As soon as I unplug the ethernet cable, OMV becomes unreachable and I cannot browse to its webpage or connect via SSH.
      If I re-plug the ethernet cable all return functional and I can connect via HTTPS or SSH on both the IP's.

      I thought it might have been losing the connection however checking the router administration page I can see the RPI connected and transmitting/receiving data.
      Even after a reboot (that would disconnect and re-connect from the Wireless LAN), I can see it connects successfully to the router however for some reason it is unreachable via SSH or HTTPS.

      Just to tule out the obvious I have tried with different clients as well, some wired, other wireless.

      I have tried with both static and dynamic IP's, that made no difference.

      I might plug in another Wireless dongle (I have a spare D-Link DWA-121) just to see if it works using that one.
      Nevertheless I thought to post on the board, just to see if anyone else has seen this odd behaviour?