WD Red 3 TB Harddisk acting unstable

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • WD Red 3 TB Harddisk acting unstable

      Hi Everyone,

      First of all I'm quite a noob in all this, and I probably overlooked a few details, but I recently stumbled upon a problem that I don't know how to fix.

      MSI P7N SLI motherboard (MS-7380)
      Intel Q9450 CPU
      Fujitsu Mobile MHY2200BS HDD 200 GB (for system)
      7 year old Seagate Desktop HDD 3TB (ST3000DM001-9YN1)
      Brand new WD Red HDD 3 TB (WDC WD30EFRX-68E)

      So, I'm running the latest 3.x OMV (since a few weeks) with the two 3TB drives in software mirror RAID. I never had any problems with the 7 y/o seagate drive, but I've read many bad things about it so for the second drive I decided to buy a WD RED iso a similar Seagate. After installation everything went quite smooth until suddenly the WD drive wasn't in the physical disk list anymore, and I started getting emails like SparesMissing, SMART error (ErrorCount) and DegradedArray. I rebooted, wiped the drive and recovered the the RAID setup. It worked OK for some time but after a few days I noticed high CPU loads when I tried to get SMART info, so I thought, OK something's definitely wrong with this drive. So I took the drive out of my OMV system into a Windows system and downloaded the official WD tools. After a long SMART self test results came back positive, nothing seemed to be wrong with the drive.

      Next thing I did was replace the SATA cable, used a different SATA port, replaced the power cable, and recovered the RAID again. But unfortunately the drive is still acting unstable. For example sometimes the green status symbol doesn't show up only after a few minutes and the drive once again disappeared on the physical disk list. So again I wiped the drive and recovered the RAID, but I'm afraid it will degrade sooner or later. The drives have normal temperatures ranging from 33/36 degrees Celsius and 60% of the 3TB is used.

      I seriously don't know whether this is a HDD, motherboard or software issue.

      Any help would be appreciated:)


      The post was edited 1 time, last by Marty ().

    • tinh_x7 wrote:

      A side note: I had bad luck with two WD 3TB hdds in the past.
      I have four of them (from two different suppliers) and no issue at all. Fortunately :)

      The 700W PSU is oversized for a this configuration. Could you change the PSU by a different type with less electrical power for a test? The max power of a PSU should be roughly fit to all active components in a NAS with a sufficient spare power for power peaks e.g. during hard disk startup-phase.
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304