Some docker containers don't like it when fstab is noexec

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Some docker containers don't like it when fstab is noexec

      ## Scenario ##
      Some docker applications require the file system to have exec for a mount option. OMV by default sets the mountpoints to nonexec. I have had problems with plex + transcoding and also openvpn-as for docker when my 'APPhdd' is mounted as nonexec.

      ## Question ##
      1.)Is there a way to change the filesystem mount to exec and have it stay permanente? (after updates and reboots its back to nonexec)
      2.)right now i check every 7 days, or when plex doesn't transcode if fstab changed back to nonexec for my APPhdd. Are there any better options or alternatives or recommendation?


      Thanks!
    • Find the fstab entries you don't want with noexec in /etc/openmediavault/config.xml look at the mnent entries. Remove the noexec directive and run

      omv-mkconf fstab

      Reboot. If you want future attached disks the same you need to edit Omv environmental variables
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server
    • Thank you for this info!! Was working on getting some post process scripts working in some apps inside Docker, and ran into this exact issue. This info helped save my night. Wanted to respond for anyone else getting permission denied for script processing from inside Docker containers, to check the mount options on your system. This helped me illuminate the common issue others had with remote locations being mounted with the no exec option. I wasn't realizing that OMV actually mounted the drives this way. Learn something new everyday!