MySQL Plugin - Backup/Restore Databse

    • OMV 2.x
    • Resolved
    • MySQL Plugin - Backup/Restore Databse

      Good DAY!!

      Tried to research the issue I am having before hand, but did not see anyone with the same problem.


      Can recreate the issue on both my production OMV 2 and testing OMV 3 systems

      I have the MySQL plugin running on OMV2 system which contains a couple of databases.
      There is a backup job that runs and works great, so no issues with creating the .sql backup files.

      However I have tried to restore the database on both my current OMV2 box and OMV3 test box, but get the same errors

      1) I was getting an error the the file was to big to upload for Nginx
    • vshaulsk wrote:

      I was getting an error the the file was to big to upload for Nginx
      That is an OMV setting. You will just have to restore from the command line. mysql -u root -p DATABASE_NAME < backup.sql
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!
    • Thank you for the information.

      I was able to get it working with the command line.


      However it is unfortunate that it does not work with the GUI ....... since the option is there.

      Maybe it would be nice to add a feature which would let you adjust the php.ini settings and vshost settings for the web-gui (max upload size, max post size, etc....)
    • vshaulsk wrote:

      However it is unfortunate that it does not work with the GUI ....... since the option is there.
      It does work. Just not for large databases. Most OMV users don't have 20+ MB databases.

      vshaulsk wrote:


      Maybe it would be nice to add a feature which would let you adjust the php.ini settings and vshost settings for the web-gui (max upload size, max post size, etc....)
      The plugin can't do this. OMV has to do this. I thought there was a setting in /etc/default/openmediavault to change it but I can't find it right now.
      omv 4.0.5 arrakis | 64 bit | 4.12 backports kernel | omvextrasorg 4.0.2
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!