Plexmediaserver - Database Path ignored

    • OMV 3.x
    • Plexmediaserver - Database Path ignored

      Hi @all,
      i have recognized a strange behaviour with my Plax install.


      I have the newest Plugin installed with the OMV-Extras Plugin.
      In the WebUI i have set the Database path to a location on my Snapraid Pool.


      But this is ignored. ?(


      The File- and Folderstructure is there but the Plexmediaserver still uses the original path at

      /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Is there a way to correct that?Regards,
      René
      My System:Erasmus 3.0.72Plex 1.5.5.3634
    • I'm not 100% sure but path defined in plugin is created symlink to original path.
      Debian 8.6 Jessie + OMV 3.0.latest Kernel: Linux 4.8.0-0.bpo.2-amd64
      Processor: Intel Core 2 Duo E8400@3GHz
      Memory: 4GB RAM
      OS-HDD: Samsung SSD 120 GB +LVM

      Full media and download center configured.

      BIG and special thanks for OMV-Extras team for great plug-ins (especially: TeamSpeak, VirtualBox, Sonarr, Radarr, and rest I use :))

      ------------------------------

      Wise guy don't know everything, he can search or ask!
      Don't ask me via PM!
    • Hi,
      i don't think the Plugin creates symlinks.

      Here the path Info for the current used standard path..
      /var/lib/plexmediaserver/Library/Application Support/Plex Media Server/Plug-in Support/Databases

      Source Code

      1. drwxr-xr-x 2 plex nogroup 4096 Apr 28 08:12 .
      2. drwxr-xr-x 7 plex nogroup 4096 Apr 25 17:41 ..
      3. -rw-r--r-- 1 plex nogroup 69632 Apr 27 08:44 com.plexapp.dlna.db
      4. -rw-r--r-- 1 plex plex 32768 Apr 27 08:44 com.plexapp.dlna.db-shm
      5. -rw-r--r-- 1 plex plex 292552 Apr 27 08:44 com.plexapp.dlna.db-wal
      6. -rw-r--r-- 1 plex nogroup 6034432 Apr 28 18:28 com.plexapp.plugins.library.db
      7. -rw-r--r-- 1 plex plex 65536 Apr 28 18:31 com.plexapp.plugins.library.db-shm
      8. -rw-r--r-- 1 plex plex 5967344 Apr 28 18:31 com.plexapp.plugins.library.db-wal

      and here the one from the path configured in the Plugin
      /srv/36df31d7-ae34-42fb-ae30-97aa9cdaf455/plexmediaserver/Library/Application Support/Plex Media Server/Plug-in Support/Databases


      Source Code

      1. drwxrwxr-x+ 2 plex users 4096 Apr 27 15:13 .
      2. drwxrwxr-x+ 7 plex users 4096 Apr 25 12:18 ..
      3. -rwxrwxr-x 1 plex users 69632 Apr 25 12:18 com.plexapp.dlna.db
      4. -rwxrwxr-x 1 plex users 32768 Apr 25 12:18 com.plexapp.dlna.db-shm
      5. -rwxrwxr-x 1 plex users 292552 Apr 25 12:18 com.plexapp.dlna.db-wal
      6. -rwxrwxr-x 1 plex users 285696 Apr 25 12:23 com.plexapp.plugins.library.db
      7. -rwxrwxr-x 1 plex users 32768 Apr 25 12:27 com.plexapp.plugins.library.db-shm
      8. -rwxrwxr-x 1 plex users 0 Apr 25 12:23 com.plexapp.plugins.library.db-wal

      as you can see the Library File com.plexapp.plugins.library.db only changes in the standard path


      Anyone any ideas ?

      Bye,
      René
    • Same thing here. Waiting for an answer, so far none have been found how to fix this and my system drive is swelling up.
      OMV 3.0.76

      Asus Z97, Intel i7-4770
      16gb Ram
      Corsair 550w PSU
      Fractal Design Mini Black MATX Case (5 Fans)
      4x WD 6TB Red (Raid 6) Main Storage
      2x WL 3TB (Raid 1) Secondary Storage / Future Cloud
      30gb SSD (OS)
      Plex Media Server Lifetime Pass member
      Linux n00b
    • This has been discussed in many other threads. The plex package keeps changing and is hard to keep up with. Especially when I don't want to maintain this plugin anymore. Using docker seems like a better idea. Or suggest plex that they include a way to move the library in their web interface.
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • gderf wrote:

      Has everyone seen this?
      The current plugin creates an override file as described. It just has changed since first coded. It would be great if someone other than me that uses plex could submit the changes needed to fix the plugin.
      omv 4.1.15 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!