my config.xml is messed up

    • OMV 2.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • my config.xml is messed up

      Hi.

      I am running OMV 2.x for quite some time. I have a HP N40L running 4 disks. One of them (sdc) was broken.

      I replaces the broken disk with a new one, so these are my physical disks

      [IMG:https://abload.de/img/physdiskmwsh1.jpg]
      When I try to mount the filesystem residing on this drive, I alway get errors. Here you can see the filesystem list [IMG:https://abload.de/img/filesysl1smw.jpg]
      As you can see, there are a lot of n/a entries. When trying to delete them I get the same errors.



      Source Code

      1. The configuration has been changed. You must apply the changes in order for them to take effect.
      2. Page
      3. of 1
      4. Displaying items 1 - 9 of 9
      5. Failed to mount '/media/14ad5785-b9ac-46a9-a87f-04e78a0bb00a/Daten2/': mount: special device /media/14ad5785-b9ac-46a9-a87f-04e78a0bb00a/Daten2/ does not exist
      6. Error #6000:
      7. exception 'OMVException' with message 'Failed to mount '/media/14ad5785-b9ac-46a9-a87f-04e78a0bb00a/Daten2/': mount: special device /media/14ad5785-b9ac-46a9-a87f-04e78a0bb00a/Daten2/ does not exist' in /usr/share/openmediavault/engined/module/fstab.inc:90
      8. Stack trace:
      9. #0 /usr/share/openmediavault/engined/rpc/config.inc(206): OMVModuleFsTab->startService()
      10. #1 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      11. #2 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      12. #3 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('applyChanges', Array, Array)
      13. #4 /usr/share/openmediavault/engined/rpc/filesystemmgmt.inc(903): OMVRpc::exec('Config', 'applyChanges', Array, Array)
      14. #5 [internal function]: OMVRpcServiceFileSystemMgmt->mount(Array, Array)
      15. #6 /usr/share/php/openmediavault/rpcservice.inc(125): call_user_func_array(Array, Array)
      16. #7 /usr/share/php/openmediavault/rpc.inc(79): OMVRpcServiceAbstract->callMethod('mount', Array, Array)
      17. #8 /usr/sbin/omv-engined(500): OMVRpc::exec('FileSystemMgmt', 'mount', Array, Array, 1)
      18. #9 {main}
      Display All

      What can I do?

      Thanks in advance
    • You will have to edit /etc/openmediavault/config.xml from the command line and remove the unwanted entries from the mntent section. Make sure to backup config.xml before editing though.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • You shouldn't have to restart OMV for that change but monit restart omv-engined will do it
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!