The Class E Network

    • New

      geaves wrote:

      Pi-Hole>>>Settings>>>DNS>>>>Custom 192.168.1.40#53
      You don't need to specify port 53. That is the default DNS port.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • New

      ryecoaaron wrote:

      You don't need to specify port 53. That is the default DNS port.
      Then I have another problem, because even if I change that, save, it still returns and I get the dns_probe_bad_config.

      I'm sure my pi-hole set up is upset, just had a docker timed out when checking in the gui, because pi-hole was not responding...almost as if it had restarted.
      Raid is not a backup! Would you go skydiving without a parachute?
    • New

      geaves wrote:

      EDIT:
      The other thing I noticed was that the interface in pi-hole is set at eth0, even though I reinstalled pi-hole once I got the N54L running and it's network interface....further investigation of 01-pihole.conf in /dockerparms/pihole/dnsmasq.d has the setting as interface=eth0, eth0 was from the last server.
      My setup, on the latest pi-hole in Docker (ver 4.0), is eth0 as well. Remember, pi-hole (in a Docker) is running in a type of vm where the Ethernet interface might still be eth0. You'd have to get in on the CLI, inside the Docker, with ip add to see the result.


      geaves wrote:


      W10 ipconfig /flushdns, test web access, error DNS_PROBE_BAD_CONFIG :(

      So either I'm setting up something incorrectly, or there is something array with my setup, but I don't know what.
      Is it just W10? Did another client work? (Since I'm over at the new place, all I have on-line is W7. I haven't tested W10 yet.)
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)
    • New

      You're using OMV's DNS plugin (as I remember) where I am not. Perhaps the plugin is conflicting with unbound.

      Did you ever figure out a workaround for the DHCP issue? (Caused by your ISP's router as I recall.)
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)
    • New

      flmaxey wrote:

      You're using OMV's DNS plugin (as I remember) where I am not. Perhaps the plugin is conflicting with unbound.

      Did you ever figure out a workaround for the DHCP issue? (Caused by your ISP's router as I recall.)
      Yes I am, and the only reason is because my isp's router does not allow a dns entry only ddns....this is looking more toward using the Pi for Pi-Hole and maintaining OMV's DNS plugin on the my main OMV box.
      Raid is not a backup! Would you go skydiving without a parachute?
    • New

      geaves wrote:

      Yes I am, and the only reason is because my isp's router does not allow a dns entry only ddns....this is looking more toward using the Pi for Pi-Hole and maintaining OMV's DNS plugin on the my main OMV box.
      Why not enable dhcp on your pi-hole box? I am. Then you don't need the dns plugin.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • New

      geaves wrote:

      So run the plugin on my Pi and not on the main OMV box.
      No. I am saying don't use the dnsmasq plugin at all. Enable DHCP in pi-hole. Settings -> DHCP lets you enable it.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • New

      ryecoaaron wrote:

      Enable DHCP in pi-hole. Settings -> DHCP lets you enable it.
      I tried that a couple of times and for some reason the settings would fail....like changing the custom dns entry first I tried 192.168.1.40#5353, then 192.168.1.40#53, saving after each change, then after your comment to not add the port reference 192.168.1.40>>>Save only for it to reappear as 192.168.1.40#53.
      The same happened when I tried to alter the dhcp scope, made the changes>>>Save but it displayed the previous settings, it was as if it was ghosting. Even cleared the browser and tried on Edge, which I never use, the same outcome.
      Raid is not a backup! Would you go skydiving without a parachute?
    • New

      geaves wrote:

      I tried that a couple of times and for some reason the settings would fail....like changing the custom dns entry first I tried 192.168.1.40#5353, then 192.168.1.40#53, saving after each change, then after your comment to not add the port reference 192.168.1.40>>>Save only for it to reappear as 192.168.1.40#53.
      The same happened when I tried to alter the dhcp scope, made the changes>>>Save but it displayed the previous settings, it was as if it was ghosting. Even cleared the browser and tried on Edge, which I never use, the same outcome.
      Sounds like something is seriously wrong with your pi-hole install. I would get it working (re-install?) with cloudflare or something before trying to switch to unbound.
      omv 4.1.13 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • New

      ryecoaaron wrote:

      Sounds like something is seriously wrong with your pi-hole install. I would get it working (re-install?) with cloudflare or something before trying to switch to unbound.
      I don't mind doing a reinstall and switching everything to Pi-Hole, whilst it does work the fact that it will stop as if it's getting an update is disconcerting. I have also added a small drive specifically for Docker installs, but Pi-Hole is still on my OMV's flashdrive.

      Job for tomorrow when everyone's out, the working class of the family need their internet for work :) as do I, but I can stand the downtime.
      Raid is not a backup! Would you go skydiving without a parachute?
    • New

      Geaves:
      As you seem to be trying different settings - you probably already know this....

      If you change unbound's config, it should to be followed by service unbound restart (or a reboot).
      Since it seems there may be some sort of problem, what does service unbound status show?
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)
    • New

      flmaxey wrote:

      Geaves:
      As you seem to be trying different settings - you probably already know this....

      If you change unbound's config, it should to be followed by service unbound restart (or a reboot).
      Since it seems there may be some sort of problem, what does service unbound status show?
      Gosh, sorry teacher, I can assure you it won't happen again.

      1) Yes, I'm not totally fik
      2) Can't do that have gone back to the first option.
      3) I fink it's gon pear shaped

      I'll try harder tomorrow :D :D :thumbup:
      Raid is not a backup! Would you go skydiving without a parachute?
    • New

      Come on... :)
      Good backup takes the "drama" out of computing
      ____________________________________
      Primary: OMV 3.0.99, ThinkServer TS140, 12GB ECC, 32GB USB boot, 4TB+4TB zmirror, 3TB client backup.
      Backup: OMV 4.1.9, Acer RC-111, 4GB, 32GB USB boot, 3TB+3TB zmirror, 4TB Rsync'ed disk
      2nd Data Backup: OMV 3.0.99, R-PI 2B, 16GB boot, 4TB WD USB MyPassport - direct connect (no hub)
    • Users Online 1

      1 Guest