NAS Not Detected

    • NAS Not Detected

      I recently made a raspberry pi 2 openmediavault, using the OMV 3 img. I started by transferring some files to my NAS, which worked. However, now Windows 10 is not detecting it in the network tab. From the same computer, I can still ping the NAS and logon to the web GUI, but I can't see it in network. Additionally, the web GUI says that all of the services are working, such as the FTP service and the SMB/CIFS service.

      Thanks in advance,
      Brian
    • redder558 wrote:

      What should I put in the DNS section, because I don't know my network dns. For now, I put in the opendns ip address.
      Usually the dns of the your router, or whatever is running dns for your local network. One way to find it open cmd on W10 and type ipconfig /all that will give the dns.
      Either that or select network from file explorer in the address bar click on network and type \\ip address of nas but that will not be permanent unless you map the share.
    • geaves wrote:

      redder558 wrote:

      What should I put in the DNS section, because I don't know my network dns. For now, I put in the opendns ip address.
      Usually the dns of the your router, or whatever is running dns for your local network. One way to find it open cmd on W10 and type ipconfig /all that will give the dns.Either that or select network from file explorer in the address bar click on network and type \\ip address of nas but that will not be permanent unless you map the share.
      I just set the DNS server to 192.168.0.1. The NAS is still not being detected.
    • Ok this could a number of things....it took me days and a lot of searching and trying various suggestions, 2 things you need to ensure,

      1. Network Discovery is turned in Network and Sharing Center>>Advanced sharing settings
      2. Control Panel>>>Programs and Features, left hand side Turn Windows Features on or off scroll down and ensure that SMB 1.0/CIFS File Sharing Support is checked.

      As for OMV....under network you have the hostname of your OMV and in Domain I have added the same name I entered in the SMB/CIFS Workgroup.

      The other option to try is open file explorer, click on network, so it displays in the address bar, highlight it so it turns blue, then type in \\<ip address of your omv the shares should be displayed....if not then either there are no shares or it's a configuration relating to those shares.

      W10 and SMB either plays nice or is a PIA....it took me the best part of a day until I got it resolved.
    • geaves wrote:

      Ok this could a number of things....it took me days and a lot of searching and trying various suggestions, 2 things you need to ensure,

      1. Network Discovery is turned in Network and Sharing Center>>Advanced sharing settings
      2. Control Panel>>>Programs and Features, left hand side Turn Windows Features on or off scroll down and ensure that SMB 1.0/CIFS File Sharing Support is checked.

      As for OMV....under network you have the hostname of your OMV and in Domain I have added the same name I entered in the SMB/CIFS Workgroup.

      The other option to try is open file explorer, click on network, so it displays in the address bar, highlight it so it turns blue, then type in \\<ip address of your omv the shares should be displayed....if not then either there are no shares or it's a configuration relating to those shares.

      W10 and SMB either plays nice or is a PIA....it took me the best part of a day until I got it resolved.
      I did what you said, but the NAS is still not detected. However, as I said, the NAS worked for one file transfer, so I doubt that the problem is in the settings. Also, when I tried to use the network trick, Windows just opened a tab in Edge.
    • redder558 wrote:

      I did what you said, but the NAS is still not detected. However, as I said, the NAS worked for one file transfer, so I doubt that the problem is in the settings. Also, when I tried to use the network trick, Windows just opened a tab in Edge.
      It won't open Edge if you used \\ before the ip address. The other option is to add omv to your hosts file on that W10 machine, Windows>>>system32>>>drivers>>etc right click on hosts and open in notepad, enter the information regrading omv in the file, there are some examples already in there. Reboot.
    • geaves wrote:

      redder558 wrote:

      I did what you said, but the NAS is still not detected. However, as I said, the NAS worked for one file transfer, so I doubt that the problem is in the settings. Also, when I tried to use the network trick, Windows just opened a tab in Edge.
      It won't open Edge if you used \\ before the ip address. The other option is to add omv to your hosts file on that W10 machine, Windows>>>system32>>>drivers>>etc right click on hosts and open in notepad, enter the information regrading omv in the file, there are some examples already in there. Reboot.
      I redid the network trick, and it kind of worked. However, it says "A specified logon session does not exist. It may have already been terminated.", and when I do login, I can see the shared folder, but I can't open it, and I already tried to edit the hosts file.