openmediavault-sftp plugin

    • OMV 3.x
    • Resolved
    • openmediavault-sftp plugin

      I would like to set up a secure FTP (sftp) with users jailed in a common directory. To achieve this through the Web-Interface I need to install "openmediavault-sftp plugin" however I can't find an installable Module for this (only the source on Github).
      I'm running OMV3074 Beta.
      Can anybody help me on this?
      Thanks a lot :)
    • Sorry, was having trouble to grab output from installation window (scrollbar jumps immediately down, when Mousebutton is released). Here ist the output:
      Reading package lists...
      Building dependency tree...
      Reading state information...
      The following NEW packages will be installed:
      openmediavault-sftp
      0 upgraded, 1 newly installed, 0 to remove and 1 not upgraded.
      Need to get 10.6 kB of archives.
      After this operation, 38.9 kB of additional disk space will be used.
      Get:1 dl.bintray.com/openmediavault-…velopers/erasmus-testing/ jessie/main openmediavault-sftp all 3.0.4 [10.6 kB]
      Fetched 10.6 kB in 0s (28.7 kB/s)
      Selecting previously unselected package openmediavault-sftp.
      (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 35597 files and directories currently installed.)
      Preparing to unpack .../openmediavault-sftp_3.0.4_all.deb ...
      Unpacking openmediavault-sftp (3.0.4) ...
      Processing triggers for openmediavault (3.0.74) ...
      Restarting engine daemon ...
      Setting up openmediavault-sftp (3.0.4) ...
      enabled
      mount: /etc/fstab: parse error: ignore entry at line 13.
      mount: (null): mount failed: Invalid argument
      dpkg: error processing package openmediavault-sftp (--configure):
      subprocess installed post-installation script returned error exit status 32
      Processing triggers for openmediavault (3.0.74) ...
      Restarting engine daemon ...
      Errors were encountered while processing:
      openmediavault-sftp


      >>> *************** Error ***************


      <<< *************************************

      ....etc. Error line is repeated many times ......

      >>> *************** Error ***************

      <<< *************************************
    • Something is wrong with your fstab. What is the output of: cat /etc/fstab
      omv 4.1.19 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.15
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • # /etc/fstab: static file system information.
      #
      # Use 'blkid' to print the universally unique identifier for a
      # device; this may be used with UUID= as a more robust way to name devices
      # that works even if disks are added and removed. See fstab(5).
      #
      # <file system> <mount point> <type> <options> <dump> <pass>
      # / was on /dev/sda1 during installation
      UUID=242d9d98-e0c0-4584-afc0-dcf73c956203 / ext4 errors=remount-ro 0 1
      # swap was on /dev/sda5 during installation
      UUID=0e7f8095-1ee9-4987-9ba1-4b9612462d9e none swap sw 0 0
      tmpfs /tmp tmpfs defaults 0 0
      0e7f8095-1ee9-4987-9ba1-4b9612462d9e
      # >>> [openmediavault]
      # <<< [openmediavault]



      root@N54L-02:~# blkid
      /dev/sda2: LABEL="Pool" UUID="8150737851758098192" UUID_SUB="4513289313023532910" TYPE="zfs_member" PARTUUID="d2cb171c-2e86-11e7-9455-6805ca2fe415"
      /dev/sdb2: LABEL="Pool" UUID="8150737851758098192" UUID_SUB="7289729905518796248" TYPE="zfs_member" PARTUUID="d39de63e-2e86-11e7-9455-6805ca2fe415"
      /dev/sdc1: UUID="242d9d98-e0c0-4584-afc0-dcf73c956203" TYPE="ext4" PARTUUID="74e58277-01"
      /dev/sdc2: UUID="0e7f8095-1ee9-4987-9ba1-4b9612462d9e" TYPE="swap" PARTUUID="74e58277-02"
      /dev/sda1: PARTUUID="d2b5f017-2e86-11e7-9455-6805ca2fe415"
      /dev/sdb1: PARTUUID="d383a029-2e86-11e7-9455-6805ca2fe415"
    • I have formatted the disks successfully. Mount however failed with the same parse-error.
      I tried to mount from console, same error.
      As I have a productive server running without any mount problems (same release) and the problem exists only on my testing server, I decided to start over with the complete installation of omv.

      After the installation I was not able to update omv from the web interface (errors as usual) and so I ran update & upgrade & dist-upgrade from console with success.
      Good news is, that I now could install sftp-plugin successfully :=))

      As advised during upgrade I ran omv-initsystem as requested in the console message (I have never done that before) and then the font changed to a lager size and Gui-colors changed slightly. The Gui does not look nice anymore but is full functioning. I would like to switch back to the original smaller font & colors, however have no clue how - Please advise.

      Re sftp-funtionality:
      - Jailing works
      - ACL some users rw, some ro works
      Overall impression: Very good, exactly, what I was looking for

      Little issue:
      Besides the shared folder, a folder call "dev" is displayed. It is accessible, but ro. Can I hide that?

      Thanks a lot for your great support, I really appreciate that :=)))))))))