How to get Shellinabox work in https?

    • OMV 3.x (stable)
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • I think you need the openssl package installed.

      When you installed shellinabox, I believe it should have created a self-signed certificate to enable HTTPS.

      Perhaps you didn't have openssl installed when you installed shellinabox.

      Maybe if you remove and re-install shellinabox after you make sure openssl is installed that will solve your issue.

      Can't say for sure, but that's what I would try.

      Edit: FYI, the certificate that was created was placed in /var/lib/shellinabox and was named certificate.pem

      The post was edited 1 time, last by vim ().

    • vim wrote:

      I think you need the openssl package installed.

      When you installed shellinabox, I believe it should have created a self-signed certificate to enable HTTPS.

      Perhaps you didn't have openssl installed when you installed shellinabox.

      Maybe if you remove and re-install shellinabox after you make sure openssl is installed that will solve your issue.

      Can't say for sure, but that's what I would try.

      Edit: FYI, the certificate that was created was placed in /var/lib/shellinabox and was named certificate.pem
      Thanks and it is more than enough, I just paste the keys, restarts and it is working now!