Torrent Client besides deluge and transmissionbt

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • flvinny521 wrote:

      @Symbiot

      I have installed OMV 3.0.86 on a real system and the media is transferring from my backup onto the pool. I thought maybe removing the VM from the equation would solve my woes, but I'm still not having any luck. I am considering having all my applications run in Docker, and so far I've been successful, but rtorrent just does not want to cooperate.



      And my config:

      Source Code

      1. execute = {sh,-c,/usr/bin/php7 /usr/share/webapps/rutorrent/php/initplugins.php abc &}
      2. execute.nothrow = rm,/run/php/.rtorrent.sock
      3. network.scgi.open_local = /run/php/.rtorrent.sock
      4. schedule = socket_chmod,0,0,"execute=chmod,0660,/run/php/.rtorrent.sock"
      5. schedule = socket_chgrp,0,0,"execute=chgrp,abc,/run/php/.rtorrent.sock"
      6. log.open_file = "rtorrent", /config/log/rtorrent/rtorrent.log
      7. log.add_output = "info", "rtorrent"
      8. min_peers = 40
      9. max_peers = 125
      10. max_uploads = 15
      11. # download_rate = 10000
      12. # upload_rate = 5000
      13. schedule = watch_directory_1,5,5,"load.start=/downloads/watched/*.torrent"
      14. directory = /downloads/incoming
      15. session = /config/rtorrent/rtorrent_sess
      16. schedule = low_diskspace,5,60,close_low_diskspace=100M
      17. # ip = 178.32.28.51
      18. bind = 0.0.0.0
      19. port_range = 60548-60548
      20. check_hash = no
      21. use_udp_trackers = no
      22. encryption = allow_incoming,enable_retry,prefer_plaintext
      23. dht = disable
      24. dht_port = 6881
      25. peer_exchange = no
      26. # network.http.ssl_verify_peer.set=0
      27. # scgi_port = 0.0.0.0:5000
      28. encoding_list = UTF-8
      29. # system.umask.set = 022
      Display All


      So you've opened port 60548 in your router? and you've added it to the docker config?

      please try adding a range like 60548-60553 in both docker config (yes, 1 line pr. port.. take a while :) ) and in your router...

      Maybe printscreen the config of the docker so we can see your setup :)
    • Symbiot wrote:

      are you making progress?

      Thanks for following up. Had a busy week with in-laws visiting. Actually, yes, I was able to get rutorrent running and downloading. I'm honestly not sure what I did differently, but I suspect it probably had to do with permissions (only because every time I have a problem with anything, it ends up being permissions...)

      I do have some other issues with it. I can download a torrent, but if I stop and then recheck data, it stays queued at 0% like it can't detect the data that was just placed there. I tried to ask for assistant on #rutorrent, but it's not a very active channel.

      As a result, I can't add the thousands of completed torrents to seed, because it can't find any of the data.
    • Fair enough :)

      Are you telling rutorrent the correct place to look for the torrent data?

      Have you mapped the shares properly?

      I've been stuck in a situation where everything was 100% correct .. until I spotted that I mapped the parent folder of the one I mapped earlier and thus nothing worked as it should.

      that or...as you mentioned .. permissions.

      Post by flvinny521 ().

      This post was deleted by the author themselves: Confusing ().
    • Symbiot wrote:

      Fair enough :)

      OK, back to the original problem. I keep recreating the container so I can learn what works and doesn't work, and I'm only further confusing myself.

      If I run the container with the directories mapped as the documentation specifies, I can't download anything. I think I have ruled out networking being the culprit, and instead it has to do with mapped folders.

      The following container creates incoming, completed and watched directories under my specified /downloads directory, as I would expect, but I can't download anything. So this config does NOT work:

      Display Spoiler

      Source Code

      1. execute = {sh,-c,/usr/bin/php7 /usr/share/webapps/rutorrent/php/initplugins.php abc &}
      2. execute.nothrow = rm,/run/php/.rtorrent.sock
      3. network.scgi.open_local = /run/php/.rtorrent.sock
      4. schedule = socket_chmod,0,0,"execute=chmod,0660,/run/php/.rtorrent.sock"
      5. schedule = socket_chgrp,0,0,"execute=chgrp,abc,/run/php/.rtorrent.sock"
      6. log.open_file = "rtorrent", /config/log/rtorrent/rtorrent.log
      7. log.add_output = "info", "rtorrent"
      8. min_peers = 40
      9. max_peers = 1200
      10. max_uploads = 15
      11. # download_rate = 10000
      12. # upload_rate = 5000
      13. # schedule = watch_directory_1,5,5,"load.start=/downloads/watched/*.torrent"
      14. directory = /downloads/incoming
      15. session = /config/rtorrent/rtorrent_sess
      16. schedule = low_diskspace,5,60,close_low_diskspace=100M
      17. # ip = 178.32.28.51
      18. bind = 0.0.0.0
      19. port_range = 50555-50555
      20. check_hash = yes
      21. use_udp_trackers = yes
      22. encryption = allow_incoming,try_outgoing,enable_retry
      23. dht = auto
      24. dht_port = 6881
      25. peer_exchange = yes
      26. # network.http.ssl_verify_peer.set=0
      27. # scgi_port = 0.0.0.0:5000
      28. encoding_list = UTF-8
      29. # system.umask.set = 022
      Display All






      However, if I un-map the /downloads directory, then everything DOES work, but obviously I don't want my files downloading to the /var/lib/dockerwhatever folder. So, it seems it is indeed a permissions issue:
      Display Spoiler

      Source Code

      1. execute = {sh,-c,/usr/bin/php7 /usr/share/webapps/rutorrent/php/initplugins.php abc &}
      2. execute.nothrow = rm,/run/php/.rtorrent.sock
      3. network.scgi.open_local = /run/php/.rtorrent.sock
      4. schedule = socket_chmod,0,0,"execute=chmod,0660,/run/php/.rtorrent.sock"
      5. schedule = socket_chgrp,0,0,"execute=chgrp,abc,/run/php/.rtorrent.sock"
      6. log.open_file = "rtorrent", /config/log/rtorrent/rtorrent.log
      7. log.add_output = "info", "rtorrent"
      8. min_peers = 40
      9. max_peers = 1200
      10. max_uploads = 15
      11. # download_rate = 10000
      12. # upload_rate = 5000
      13. # schedule = watch_directory_1,5,5,"load.start=/downloads/watched/*.torrent"
      14. directory = /downloads/incoming
      15. session = /config/rtorrent/rtorrent_sess
      16. schedule = low_diskspace,5,60,close_low_diskspace=100M
      17. # ip = 178.32.28.51
      18. bind = 0.0.0.0
      19. port_range = 50550-50550
      20. check_hash = yes
      21. use_udp_trackers = yes
      22. encryption = allow_incoming,try_outgoing,enable_retry
      23. dht = auto
      24. dht_port = 6881
      25. peer_exchange = yes
      26. # network.http.ssl_verify_peer.set=0
      27. # scgi_port = 0.0.0.0:5000
      28. encoding_list = UTF-8
      29. # system.umask.set = 022
      Display All



      It seems that the container is resetting the permissions every time it is launched. Each time, I use the OMV UI to view the folders' ACL settings, and the owner has switched back to the user whose UID and GID was mapped. I don't know if that is related, because I have the folders set that everybody can read/write/execute (at least until I figure out what's going on).

      The post was edited 5 times, last by flvinny521 ().

    • So when you restart the container then the owner/group is what?

      and what would you like it to be?

      Are you certain that the user you are using (1001) is the correct one?

      nano /etc/passwd to check the userID.

      Can you check ACL & privs to see if the user has the proper rights..

      Alternatively create a new share and set the access rights for the Docker user and try using that..

      It's hard to troubleshoot without hands-on :)

      Post by flvinny521 ().

      This post was deleted by the author themselves: Duplicate ().
    • The owner/group for the /downloads directory is my docker user. I think this is the expected behavior, right? However, this doesn't happen with other containers that download data, like NZBGet. The download directories there remain owned by root/users. In fact, no other Docker containers' mapped volumes are owned by the docker user, they are ALL owned by root/users except the rutorrent container.

      New information: when mapping /downloads to the same directory as /config (on my system drive), the downloading works perfectly fine. What I have been trying to establish is mapping /downloads to my mergerfs pool. Could this be causing the issue? Can rtorrent/rutorrent not save to a mergerfs pool? Is there anything different I need to do with my rtorrent.rc file?

      Edit again: I've temporarily set up rutorrent saving to a non-pool directory and moving completed torrents into the pool. This is working fine, but once the torrent data is moved, the torrent shows the new, correct save path, but I can not verify local data and begin seeding. I've tried the resetperms plugin on my storage pool but this doesn't seem to fix the problem.

      Final edit (?): I think I've found that rtorrent can't write files to mergerfs while using the direct_io option. Removing that argument from my pool has allowed rtorrent to work as expected, finally! Thank you @Symbiot for all your time, and apologies to the original OP of this thread for completely taking it over.

      The post was edited 5 times, last by flvinny521 ().

    • The culprit finally reveals it self :)

      Perfect... funny how you end up looking any and everywhere :)

      I've never used direct_io for mergerFS so never had that problem..

      trapexit does write:

      • Do not use direct_io if you expect applications (such as rtorrent) to mmap files. It is not currently supported in FUSE w/ direct_io enabled.


      But not immediately obvious that the filesystem was the issue..

      Well done!



      btw - don't know if you've spotted that @trapexit has released some nice tools a while back for MergerFS.. : github.com/trapexit/mergerfs-tools
    • Symbiot wrote:

      Display Spoiler
      The culprit finally reveals it self :)

      Perfect... funny how you end up looking any and everywhere :)

      I've never used direct_io for mergerFS so never had that problem..

      trapexit does write:

      • Do not use direct_io if you expect applications (such as rtorrent) to mmap files. It is not currently supported in FUSE w/ direct_io enabled.


      But not immediately obvious that the filesystem was the issue..

      Well done!



      btw - don't know if you've spotted that @trapexit has released some nice tools a while back for MergerFS.. : github.com/trapexit/mergerfs-tools


      Thanks for all your help. I'm working tonight but later or tomorrow I'll try to fully get it working and integrated with Sonarr/Radarr, and then work on importing my few thousand torrents to seed again. Fingers crossed.

      I had read that info from trapexit, but supposedly Transmission uses nmap similarly to rtorrent, and I've never had a problem with the Transmission container. Regardless, I was able to copy over a large file from my Windows PC at around 85 MB/sec. without direct_io. While I'd much prefer 120, that's good enough for me at this time.
    • Hi all, this is a really stupid beginner question that I don't want to make a new thread for.

      I have downloaded Deluge onto my NAS and I don't know what kind of syntax or file structure I need to type into the Preferences of deluge to specify where I want my torrents to be downloaded to by default. I can see the default is /home/deluge-daemon/Downloads but I have a folder for Movies I want to use but I don't know what I should be typing in? Like I try /Movies but it doesn't work?
    • Vidaeus wrote:

      Hi all, this is a really stupid beginner question that I don't want to make a new thread for.

      I have downloaded Deluge onto my NAS and I don't know what kind of syntax or file structure I need to type into the Preferences of deluge to specify where I want my torrents to be downloaded to by default. I can see the default is /home/deluge-daemon/Downloads but I have a folder for Movies I want to use but I don't know what I should be typing in? Like I try /Movies but it doesn't work?

      Are you using Docker, or did you install Deluge via a plugin or something?
    • New

      I installed deluge into OMV using the plugin. I can see that there is an extra user that is created for the deluge-daemon. I gave it read/write permissions to the folders I want to use but the torrents stop downloading almost immediately and say error, permission denied for the directory.
    • New

      I had the same problem: to check the real path you need to go to shared folder. There you will see the relative path. To see the full path that you need to put in deluge you need to move the mouse to any of the column and click in the arrow pointing down, then choose columns and then full path.
      You will get one more column with the full path of each shared folder.
    • Users Online 1

      1 Guest