haugene/transmission-openvpn on Docker storage in local directory

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • haugene/transmission-openvpn on Docker storage in local directory

      Hello, I would first like to apologize for my bad English. :whistling:

      I encountered a problem when using docker, to make it simple I want to install a bitorrent client that must go through a VPN without all the traffic of the machine going through the VPN.

      So I had the idea to turn to docker and especially to the image haugene / transmission-openvpn.

      My problem is that the storage does this in the volume of the container and I would like him to do it directly in a local directory that does not change as soon as a change is made to the container and do not have a name like "002ef0c61d59f744f2416c3153cc3308ba6efd5ac991ca5fea0d1950fb887948"

      If ever you have advice when setting up transmission, to download torrents and seed them behind

      thank you in advance :)
    • Blastmun wrote:

      Hello, I would first like to apologize for my bad English. :whistling:

      I encountered a problem when using docker, to make it simple I want to install a bitorrent client that must go through a VPN without all the traffic of the machine going through the VPN.

      So I had the idea to turn to docker and especially to the image haugene / transmission-openvpn.

      My problem is that the storage does this in the volume of the container and I would like him to do it directly in a local directory that does not change as soon as a change is made to the container and do not have a name like "002ef0c61d59f744f2416c3153cc3308ba6efd5ac991ca5fea0d1950fb887948"

      If ever you have advice when setting up transmission, to download torrents and seed them behind

      thank you in advance :)
      The last part referring to storage I find it hard to understand. Can you try and explain again what's the issue ?


      I know exactly what your problem is and i know how to solve it. I was having the same issue myself and i didn't know what the problem was. I ended up just trial and erroring things and then eventually i was the options in the omv docker-container gui i needed to edit to make this work. I will try to explain the problem and then how i fixed it.

      the issue is that your docker download directory, and your 'omv/transmission/nas' doanload directory are not bound.

      I spent hours changing the ENV variable TRANSMISSION_FINISHED_DOWNLOAD to my nas directory but my nas drive wouldnt get the file. transmission would spend time downloading the file and then poof it was just no where to be found. Then i got to digging into the docker container file system and after a lot of digging 'usr/var/lib/docker/???' something like that, i found the transmission downloads. at the directory i specified in the EVN variable.

      so then after a few more hours, i realized below the ENV variables section in the container start dialogue, there is a bind directory field. Thats what you need to edit. your Nas download directory is the first field, and the docker container download directory is the second field. (if you changed this in the ENV variables, you have to put that directory here). but there is a GOTCHA. i put my NAS directory as /jack/sparrow/ and my docker downloads were /docker/downloads/. If you are using Sonarr, and you set up transmission to download into /jack/sparrow, your downloads will fail because your docker container does not have the folder /jack/sparrow and transmission will not know where to put the file. this is because docker is running transmission and not OMV so it does not have immediate access to your root file structure. it only have access to the internal folders (e.g /docker/downloads) and they get bound to external folders (e.g. /jack/sparrow). The solution to this problem is simple. you need to make your docker downloads directory the same ad your NAS downloads directory. so your docker ENV variable for transmission downloads should also be /jack/sparrow/.

      I know this is long, but i wanted to explain why it wasn't working vs just giving a solution.

      Tl:Dr;

      1. set your Docker downloads ENV variable path to be the same as your NAS download dir path
      2. in the docker container start dialogue, BIND the nas doanload path to your docker download path. (this means they should say the same thing on each line e.g. /my/download/folder).
      3. this also applies to incomplete downloads, and a watch folder.

      hope this helps.