Upgrade to 3.x and grub error as a result

    • OMV 3.x (stable)
    • Resolved
    • Upgrade 2.x -> 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Upgrade to 3.x and grub error as a result

      Hi guys,
      sorry to bother you...
      After over a year I tried to upgrade from the latest 2.x to 3.x (with the omv-release-upgrade command).
      The only plug-in I have installed is Snapraid.
      Unfortunately after many attempts I have the same "grub" error console.
      If there is a guide about it, please point me there... :)

      Here the system info

      Thanks in advance for your help!

      The post was edited 1 time, last by 0rtega ().

    • Any help to debug my issue ?
      I have executed these commands:

      Source Code

      1. apt-get update
      2. apt-get dist-upgrade
      3. omv-update
      4. omv-release-upgrade

      After the reboot i get the grub rescue console.

      There is a way to log what happen during the command "omv-release-upgrade" ?

      Every time I have to restore the clonezilla image of my system drive because it will not boot... :(

      Any advise is welcome... Tnx!
    • I have run into the same problem as you have in trying to upgrade 2.2 .x to 3.x. The only way I was able to solve it was to take the OMV drive to another Linux machine and reinstall grub to the OMV disk from there. There are numerous HOWTOs out there that describe the procedure - just google "boots to grub rescue"

      Once that was done and the OMV drive taken back to its own machine it did boot, but had so many other problems that I was convinced that, in my case, OMV could not be upgraded from 2.2.x to 3.x. I am still on 2.2.x.
      OMV 4.x - ASRock Rack C2550D4I - 16GB ECC - Silverstone DS380

      The post was edited 1 time, last by gderf ().

    • I wanted to upgrade my OMV as well so, what I did:
      1. apt-get update; apt-get upgrade; apt-get dist-upgrade
      2. omv-update (it's probably the same as that above, any way I've done that 2)
      3. omv-release-upgrade (it's took a while), after that
      4. dpkg -r openmediavault-omvextrasorg
      5. next I followed the instructions from omv-extras.org/joomla/index.php/guides:
      # wget omv-extras.org/openmediavault-omvextrasorg_latest_all3.deb
      # dpkg -i openmediavault-omvextrasorg_latest_all3.deb
      # apt-get update
      6. reboot the system and...
      That worked fine 4 me.
      "Given enough eyeballs, all bugs are shallow"

      The post was edited 2 times, last by Jap0 ().

    • Hi guys.

      I have solved by a combination of the two advices.

      To solve the grub error I have reinstalled grub with the "Parted Magic" distro.

      Firstly identify your boot drive with the "Parted Magic Mount" utlity.
      In my case was :"/dev/sdf1"

      then, from the main menu select:
      -Boot Utilities
      -Boot Loader Restore Utility

      Install the new grub on (in my case...) "/dev/sdf1".

      After that my OMV box booted fine... but the web interface was not accessible...

      To solve this issue:

      Source Code

      1. wget omv-extras.org/openmediavault-omvextrasorg_latest_all3.deb
      2. dpkg -i openmediavault-omvextrasorg_latest_all3.deb
      3. omv-update
      after that, reboot the machine.

      Now the web interface is accessible.

      There are still some minor quirks (that i will investigate later on), but after all the machine works-ish :)

      Thank you guys!

      Let me know if I could do it in a better way... specifically, someone with a real knowledge about the "grub" command
      has an alternative method (without using "Parted Magic") to solve the issue ???
    • My upgrade also resulted in error:

      Source Code

      1. .
      2. .
      3. Errors were encountered while processing:
      4. postfix
      5. bsd-mailx
      6. openmediavault
      7. Creating index of upgradeable packages ...
      8. Creating index of openmediavault plugins ...
      9. E: Sub-process /usr/bin/dpkg returned an error code (1)

      Boot in rescue mode:

      Source Code

      1. grub rescue >
      2. set prefix=(hd0,1)/boot/grub
      3. set root=(hd0,1)
      4. insmod linux
      5. insmod normal
      6. normal

      Reboot and finish upgrade:

      Source Code

      1. aptitude upgrade
      2. aptitude safe-upgrade

      Reinstall grub (in my case /dev/hdc is the root-Device):

      Source Code

      1. grub-mkdevicemap
      2. grub-install /dev/hdc
      3. update-grub

      Finish omv-release-upgrade:

      Source Code

      1. omv-update

      The following problems still exists after upgrade:

      1. Notifications

        E-Mail Sender not set (header "From: <sender>" missing) by OMV-Notifications

      2. Each time you login via webinterface, you get an (unwanted) email notification
        (this can not be configured)


      Michael ^^
      omv 3.0.80 (erasmus) | Debian Jessie | Kernel 4.9 | Intel Celeron J1800 | MX-ES 8GB USB 3.0 | RAID1 1TB