Unable to make NUT plugin work (errors codes inside)

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Unable to make NUT plugin work (errors codes inside)

      Hello all.

      I am on OMW 3.0.80 with NUT 3.12.2 plugin installed.

      I have connected my APC Smart-UPS SMT1500i to the NAS via the USB cable (also tried via the RJ-45 - Serial cable).

      I have tried the following driver configuration:

      Source Code

      1. driver = apcsmart
      2. port = auto


      And:

      Source Code

      1. driver = usbhid-ups
      2. port = auto



      But, whenever I try to enable the plugin i got the following error output:

      Source Code

      1. Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start nut-server 2>&1' with exit code '1': A dependency job for <a href="<a href=" http:="" nut-server.service"="">nut-server.service</a>"><a href="<a href=" http:="" nut-server.service"="">nut-server.service">http://nut-server.service">nut-server.service</a>"><a href="http://http://http://nut-server.service">nut-server.service">http://nut-server.service">nut-server.service">http://http://nut-server.service">nut-server.service">http://nut-server.service">nut-server.service</a> failed. See 'journalctl -xn' for details.

      The output of the command "journalctl -xn" is:

      Source Code

      1. -- Logs begin at jue 2017-06-15 18:38:14 CEST, end at jue 2017-06-15 20:51:19 CEST. --
      2. jun 15 20:51:08 olmos13nas-e upsdrvctl[16164]: Driver failed to start (exit status=1)
      3. jun 15 20:51:08 olmos13nas-e upsdrvctl[16164]: Network UPS Tools - UPS driver controller 2.7.2
      4. jun 15 20:51:08 olmos13nas-e systemd[1]: <a href="<a href=" http:="" nut-driver.service:"="">nut-driver.service:</a>"><a href="<a href=" http:="" nut-driver.service:"="">nut-driver.service:">http://nut-driver.service:">nut-driver.service:</a>"><a href="http://http://http://nut-driver.service:">nut-driver.service:">http://nut-driver.service:">nut-driver.service:">http://http://nut-driver.service:">nut-driver.service:">http://nut-driver.service:">nut-driver.service:</a> control process exited, code=exited status=1
      5. jun 15 20:51:08 olmos13nas-e systemd[1]: Failed to start Network UPS Tools - power device driver controller.
      6. -- Subject: Unit <a href="<a href=" http:="" nut-driver.service"="">nut-driver.service</a>"><a href="<a href=" http:="" nut-driver.service"="">nut-driver.service">http://nut-driver.service">nut-driver.service</a>"><a href="http://http://http://nut-driver.service">nut-driver.service">http://nut-driver.service">nut-driver.service">http://http://nut-driver.service">nut-driver.service">http://nut-driver.service">nut-driver.service</a> has failed
      7. -- Defined-By: systemd
      8. -- Support: <a href="<a href=" http:="" lists.freedesktop.org="" mailman="" listinfo="" systemd-devel"=""></a><a href="http://lists.freedesktop.org/mailman/listinfo/systemd-devel</a>"><a"></a"></a><a href="http://http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel</a>"><a< a=""> href="<a href="http://http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel</a>"><a href="http://http://http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel</a></a<>
      9. --
      10. -- Unit <a href="<a href=" http:="" nut-driver.service"="">nut-driver.service</a>"><a href="<a href=" http:="" nut-driver.service"="">nut-driver.service">http://nut-driver.service">nut-driver.service</a>"><a href="http://http://http://nut-driver.service">nut-driver.service">http://nut-driver.service">nut-driver.service">http://http://nut-driver.service">nut-driver.service">http://nut-driver.service">nut-driver.service</a> has failed.
      11. --
      12. -- The result is failed.
      13. jun 15 20:51:08 olmos13nas-e systemd[1]: Dependency failed for Network UPS Tools - power devices information server.
      14. -- Subject: Unit <a href="<a href=" http:="" nut-server.service"="">nut-server.service</a>"><a href="<a href=" http:="" nut-server.service"="">nut-server.service">http://nut-server.service">nut-server.service</a>"><a href="http://http://http://nut-server.service">nut-server.service">http://nut-server.service">nut-server.service">http://http://nut-server.service">nut-server.service">http://nut-server.service">nut-server.service</a> has failed
      15. -- Defined-By: systemd
      16. -- Support: <a href="<a href=" http:="" lists.freedesktop.org="" mailman="" listinfo="" systemd-devel"=""></a><a href="http://lists.freedesktop.org/mailman/listinfo/systemd-devel</a>"><a"></a"></a><a href="http://http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel</a>"><a< a=""> href="<a href="http://http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel</a>"><a href="http://http://http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel">http://lists.freedesktop.org/mailman/listinfo/systemd-devel</a></a<>
      17. --
      18. -- Unit <a href="<a href=" http:="" nut-server.service"="">nut-server.service</a>"><a href="<a href=" http:="" nut-server.service"="">nut-server.service">http://nut-server.service">nut-server.service</a>"><a href="http://http://http://nut-server.service">nut-server.service">http://nut-server.service">nut-server.service">http://http://nut-server.service">nut-server.service">http://nut-server.service">nut-server.service</a> has failed.
      19. --
      20. -- The result is dependency.
      21. jun 15 20:51:08 olmos13nas-e systemd[1]: Unit <a href="<a href=" http:="" nut-driver.service"="">nut-driver.service</a>"><a href="<a href=" http:="" nut-driver.service"="">nut-driver.service">http://nut-driver.service">nut-driver.service</a>"><a href="http://http://http://nut-driver.service">nut-driver.service">http://nut-driver.service">nut-driver.service">http://http://nut-driver.service">nut-driver.service">http://nut-driver.service">nut-driver.service</a> entered failed state.
      22. jun 15 20:51:16 olmos13nas-e snmpd[2649]: error on subcontainer 'ia_addr' insert (-1)
      Display All



      I have tried to uninstall and reinstall the NUT plugin, but at the uninstallation i got the following error (with the plugin disabled):

      Source Code

      1. moving openmediavault-nut (3.2.12) ...
      2. /usr/bin/deb-systemd-helper: error: unable to read <a href="<a href=" http:="" collectd.service"="">collectd.service</a>"><a href="<a href=" http:="" collectd.service"="">collectd.service">http://collectd.service">collectd.service</a>"><a href="http://http://http://collectd.service">collectd.service">http://collectd.service">collectd.service">http://http://collectd.service">collectd.service">http://collectd.service">collectd.service</a>
      3. Purging configuration files for openmediavault-nut (3.2.12) ...
      4. /usr/bin/deb-systemd-helper: error: unable to read <a href="<a href=" http:="" collectd.service"="">collectd.service</a>"><a href="<a href=" http:="" collectd.service"="">collectd.service">http://collectd.service">collectd.service</a>"><a href="http://http://http://collectd.service">collectd.service">http://collectd.service">collectd.service">http://http://collectd.service">collectd.service">http://collectd.service">collectd.service</a>
      5. Processing triggers for openmediavault (3.0.80) ...
      6. Failed to connect to socket: No such file or directory
      7. Error #0:
      8. exception 'OMV\Rpc\Exception' with message 'Failed to connect to socket: No such file or directory' in /usr/share/php/openmediavault/rpc/rpc.inc:140
      9. Stack trace:
      10. #0 /usr/share/php/openmediavault/rpc/proxy/json.inc(95): OMV\Rpc\Rpc::call('Exec', 'getOutput', Array, Array, 3)
      11. #1 /var/www/openmediavault/rpc.php(45): OMV\Rpc\Proxy\Json->handle()
      12. #2 {main}
      Display All


      I am pretty lost and I do not know what to do next. Could anyone help me?

      Thanks in advance!

      Regards.
      || omv 3.0.88 | kernel 4.9.0 | omvextrasorg 3.4.28 ||
      || shellinabox || backup | syncthing || deluge | jdownloader || flashmemory | remotemount | symlinks | webdav || plex || fail2ban || apttool | autoshutdown | letsencrypt | locate | nut | resetperms | wakealarm || docker ||
    • I manage to make it work by uninstalling/installing it manually via the cli.

      Now it is working and reading my UPS values.

      Thanks for the plugin!
      || omv 3.0.88 | kernel 4.9.0 | omvextrasorg 3.4.28 ||
      || shellinabox || backup | syncthing || deluge | jdownloader || flashmemory | remotemount | symlinks | webdav || plex || fail2ban || apttool | autoshutdown | letsencrypt | locate | nut | resetperms | wakealarm || docker ||
    • I am having the same problem. It doesn't seem to want my configuration settings.

      This is what I get when I run journalctl -xn

      Jul 09 23:17:00 Nilsson systemd[1]: Failed to start Network UPS Tools - power device driver controller.
      -- Subject: Unit nut-driver.service has failed
      -- Defined-By: systemd
      -- Support: lists.freedesktop.org/mailman/listinfo/systemd-devel
      --
      -- Unit nut-driver.service has failed.
      --
      -- The result is failed.
      Jul 09 23:17:00 Nilsson systemd[1]: Dependency failed for Network UPS Tools - power devices information server.
      -- Subject: Unit nut-server.service has failed
      -- Defined-By: systemd
      -- Support: lists.freedesktop.org/mailman/listinfo/systemd-devel
      --
      -- Unit nut-server.service has failed.
      --
      -- The result is dependency.
      Jul 09 23:17:00 Nilsson systemd[1]: Unit nut-driver.service entered failed state.
      Jul 09 23:17:00 Nilsson upsdrvctl[13038]: Driver failed to start (exit status=1)
      Jul 09 23:17:00 Nilsson upsdrvctl[13038]: Network UPS Tools - UPS driver controller 2.7.2
      Jul 09 23:17:01 Nilsson CRON[13042]: pam_unix(cron:session): session opened for user root by (uid=0)
      Jul 09 23:17:01 Nilsson CRON[13043]: (root) CMD ( cd / && run-parts --report /etc/cron.hourly)
      Jul 09 23:17:01 Nilsson postfix/postsuper[13046]: Deleted: 2 messages
      Jul 09 23:17:01 Nilsson CRON[13042]: pam_unix(cron:session): session closed for user root

      Any help would be appreciated

      John
      San Pedro, CA
    • Hello I am trying to configure this plugin or I do not know how to know the driver I need to use, I have an UPS Infosec 500XP inverter and the command lsusb tel me :


      Source Code

      1. lsusb
      2. Bus 002 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
      3. Bus 001 Device 003: ID 8087:0a2b Intel Corp.
      4. Bus 001 Device 004: ID 0665:5161 Cypress Semiconductor USB to Serial
      5. Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
      Its the cypress semiconductor, can you tell me how to find them please ?
    • I have an error


      Source Code

      1. Erreur #0:
      2. exception 'OMV\ExecException' with message 'Failed to execute command 'export PATH=/bin:/sbin:/usr/bin:/usr/sbin:/usr/local/bin:/usr/local/sbin; export LANG=C; systemctl start nut-server 2>&1' with exit code '1': A dependency job for nut-server.service failed. See 'journalctl -xn' for details.' in /usr/share/php/openmediavault/system/process.inc:175
      3. Stack trace:
      4. #0 /usr/share/php/openmediavault/system/systemctl.inc(86): OMV\System\Process->execute(Array, 1)
      5. #1 /usr/share/php/openmediavault/system/systemctl.inc(104): OMV\System\SystemCtl->exec('start', NULL, false)
      6. #2 /usr/share/openmediavault/engined/module/nut.inc(83): OMV\System\SystemCtl->enable(true)
      7. #3 /usr/share/openmediavault/engined/rpc/config.inc(194): OMVModuleNetworkUPSTools->startService()
      8. #4 [internal function]: OMVRpcServiceConfig->applyChanges(Array, Array)
      9. #5 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      10. #6 /usr/share/php/openmediavault/rpc/serviceabstract.inc(150): OMV\Rpc\ServiceAbstract->callMethod('applyChanges', Array, Array)
      11. #7 /usr/share/php/openmediavault/rpc/serviceabstract.inc(528): OMV\Rpc\ServiceAbstract->OMV\Rpc\{closure}('/tmp/bgstatusc2...', '/tmp/bgoutput9p...')
      12. #8 /usr/share/php/openmediavault/rpc/serviceabstract.inc(151): OMV\Rpc\ServiceAbstract->execBgProc(Object(Closure))
      13. #9 /usr/share/openmediavault/engined/rpc/config.inc(213): OMV\Rpc\ServiceAbstract->callMethodBg('applyChanges', Array, Array)
      14. #10 [internal function]: OMVRpcServiceConfig->applyChangesBg(Array, Array)
      15. #11 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      16. #12 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('applyChangesBg', Array, Array)
      17. #13 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Config', 'applyChangesBg', Array, Array, 1)
      18. #14 {main}
      Display All
    • freeman32 wrote:

      I have an error
      I get also an error after trying to enable the UPS service under OMV while no UPS is physically connected. It seems that the nut-server.service is trying to communicate with the UPS immediately, after trying to save the settings in the UPS plugin. This error in itself is explainable. But it seems to prevent to save the settings in the UPS plugin also.
      OMV 3.0.90 (Gray style)
      ASRock Rack C2550D4I - 16GB ECC - 6x WD RED 3TB (ZFS 2x3 Striped RaidZ1)- Fractal Design Node 304