OMV system drive is full

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV system drive is full

      Hi all, longtime user of OMV and have just upgraded from OMV2 to OMV3.
      My server has 4Gb of RAM and an 8Gb SSD as the system disc, 1Tb,and 2 x 3Tb drives for storage, and the system disc is nearly full. My other OMV setup is still running version2 X and the system drive is a 32Gb SSD (overkill) but only 2Gb is used on that one. On the 8Gb SSD only about 700mb is free! Both my servers are running nearly identical plugins (I like redundancy in Servers) with the 8Gb server having the added addon of Apple filing for a time machine back up!
      I have run apt-clean and apt-autoremove, rebooted with little change.

      This is the output of df -h:

      openmediavault2:~# df -h
      Filesystem Size Used Avail Use% Mounted on
      udev 10M 0 10M 0% /dev
      tmpfs 689M 8.9M 680M 2% /run
      /dev/sdc1 6.9G 5.8G 756M 89% /
      tmpfs 1.7G 8.0K 1.7G 1% /dev/shm
      tmpfs 5.0M 4.0K 5.0M 1% /run/lock
      tmpfs 1.7G 0 1.7G 0% /sys/fs/cgroup

      Any ideas of what is using so much space and what I can do to free any up?
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • Forgot to mention, did that too...
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • Source Code

      1. root@openmediavault2:~# du -sh /var/log
      2. 35M /var/log
      For some reason it still had the PLEX database pointing to the small SSD, resolved that and rebooted (one of the first thigs I did when I noticed the issue after the upgrade from OMV 2 to 3)...
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • Here is the thing now - I cannot access the WebGUI without being logged in in SSH as ROOT and running omv-engined -d -f. It then will continually run RPC response (service=System, method=dirty) etc.. etc with an updating PID. This is one of the more interesting lines:

      RPC response (service=System, method=noop): {"response":"I must not fear. Fear is the mind-killer. Fear is the little-death that brings total obliteration. I will face my fear. I will permit it to pass over me and through me. And when it has gone past I will turn the inner eye to see its path. Where the fear has gone there will be nothing. Only I will remain.","error":null}

      - Some one having a laugh...

      I am nearing the point of reinstalling OMV 2. OMV 3 seems a bit too buggy at the moment..

      Edit update - managed to do a clean reboot and it seems to be working, apart from the nearly full system drive...
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • Ok stil perservering with this have ran gparted live and reduced swap space down to 100mb and increased the system drive space (do we really need a swap space on openmedia vault with 4Gbs of RAM on using an SSD for storage?). The drive is still full, the system is running normally (most important theing is Plexmediaserver is running). Without taking the system drive out and looking at it with Ubuntu to see what filesare filling it up, what else can I do?
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • root@openmediavault2:~# du -d1 -h /
      4.0K /lib64
      142M /opt
      8.0K /dev
      9.1M /run
      4.9T /media
      16K /lost+found
      28K /tmp
      339M /boot
      332K /root
      1.1G /usr
      4.0G /var
      16M /sbin
      du: cannot access ‘/proc/32166/task/32166/fd/3’: No such file or directory
      du: cannot access ‘/proc/32166/task/32166/fdinfo/3’: No such file or directory
      du: cannot access ‘/proc/32166/fd/4’: No such file or directory
      du: cannot access ‘/proc/32166/fdinfo/4’: No such file or directory
      0 /proc
      7.7M /etc
      4.0K /home
      9.3M /bin
      12K /srv
      0 /sys
      4.0K /export
      488M /lib
      4.0K /mnt
      5.0T /
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • 4.0K /var/opt
      35M /var/log
      143M /var/cache
      12K /var/tmp
      4.0K /var/local
      132K /var/spool
      4.0K /var/mail
      5.1M /var/www
      3.9G /var/lib
      1.8M /var/backups
      4.0G /var/ Looks like /var/lib is the culprit. What is filling that and how would I purge it?
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • We need to keep running the command on subdirectories to find what is causing it. du -d1 -h /var/lib/

      If you have plex installed, that is probably what is filling it.
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • 3.3G /var/lib/plexmediaserver

      Yes the very culprit - I had moved the database file to a 1Tb drive for that purpose, but for some reason it had been put back. When I upgraded I moved it back to the 1Tb drive and rebooted in the (vain) hope that the file would be moved/overwritten and not take up so much room. Is ther any way to get rid of it as it is now elsewhere?

      (Thanks for all your help).
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • MrT10001 wrote:

      Is ther any way to get rid of it as it is now elsewhere?
      I can't promise this won't break something with plex but rm -rfv /var/lib/plexmediaserver/*
      omv 4.1.9 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.10
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • Thats good, it removed the database and saved 3.3Gb.. Just lost all my media thumbnails (Grr), but the films and music seems to work fine.. I am trying to remember the scraper I used to get all thumbs of internet...

      (Really graetful for your help here)..

      Edit - All thumbnails coming back after rebooting...

      Thanks so much...
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)

      The post was edited 1 time, last by MrT10001 ().

    • Unfortunately that broke the installation, started getting an error related to the plex service, so I uninstalled and reinstalled and it refused to connect, then for some reason stopped all other services.. I am reinstalling now, praies the lord its not M$ Windows, I would be here all night reinstalling...
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • SSD started filling again even though PLEX was pointing to a 1TB drive... Then installation broke again same as above. Reinstalling again...
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)
    • Looks like an issue with var/lib/plexmdiaserver. Have done 2 clean installs of OMV 3.x and twice it has filled to system drive even though plex was pointed to another drive. Have downgraded to OMV 2.X and the same issue applies. I have removed PLEX for the time being. On the other system the system drive is 30Gb and OMV 3.X stays under 3Gb on the system drive. Bit perplexed on this one. I am setting up two servers to test some of this out.
      HP N54L Microserver, 20Gb Intel SSD, 4Gb RAM runing OMV 3.X
      HP N54L Microserver 20Gb Intel SSD, 8Gb RAM running OMV 3.X
      and loads of other PC's and NAS... OMV by far the best....
      (P.S. I hate Windows 10, 8.1, 8, 7 Vista, XP, 2K, ME, 98se, 98 and 95 - I have lost hours of my life to this windows virus)