Clean install of 3.0.80 - CIFS shares not visible?

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Clean install of 3.0.80 - CIFS shares not visible?

      Hello to all of you,
      Yesterday I came across the info of OMV3 going officially out of beta so wanted to check if I could finally upgrade my box (Asrock Q1900ITX-DC, 4GB RAM, 2x2TB Barracuda Green and a 8GB Kingston DTSE for OS - FlashMemory plugin installed) currently running flawlessly on OMV 2.2.14 with a few services, mainly some CIFS shares, minidlna and BT (Transmission) plugin. I disconnected the hard drives, swapped the OS stick for a blank one and ran the install from another usb stick. With OMV installed, I put the box together again, updated the OS (with some issues: firmware adi and firmware ralink packages - a few forum posts helped me with these), set up CIFS (re-added shared folders and CIFS shares on them, permissions and so on) but then I hit the wall. The NAS box doesn't come up in Network section of Windows Explorer (Windows 10), I had no luck connecting to it using its name or ip in Explorer (\\name or \\ip) either. In the NAS webui CIFS seems to be working fine while I'm not able to connect to the shares at all (tried disabling the firewall/AV on my machine - no luck whatsoever). Anyone's got any ideas what I should check next?
      One more thing - if I now swap the OS sticks back again (that is, put in the one with 2.2.14), OMV starts fine and I can access the SMB shares from the same W10 machine, even in the same session (without reboot).
    • Have you run a simple ping test from a windows 10 machine?
      Have you added a DNS entry to your network settings on omv?

      If both of those are yes and return ok, try adding an entry in the hosts file on a windows 10 machine and rebooting.

      Or, Shared Folders>>>>ACL and check sambashre

      The post was edited 1 time, last by geaves ().

    • The NAS responds to ping and the DNS setting is there. Correct me if I'm wrong but if it was to be fixed by hosts file, the NAS should be still reachable via \\(IP) (e.g. \\192.168.2.x).
      Also, I tried with both username/password and anonymous (guest) access settings (on 2.2.14 I used all guest access - it's a small home LAN)

      Wysłane z mojego LG-K430 przy użyciu Tapatalka
    • g_betiuk wrote:

      The NAS responds to ping and the DNS setting is there. Correct me if I'm wrong but if it was to be fixed by hosts file, the NAS should be still reachable via \\(IP) (e.g. \\192.168.2.x)
      Yes it should, but my windows 10 laptop would not see any shares, whereas the other 3 could, mine was a clean install of 10.

      A couple of things I did on my own, added an entry to the hosts file, Control Panel>>>>Programs and Features>>>>Turn windows features on or off>>>>SMB 1.0/CIFS File Sharing Support and SMB Direct both of these were off on my laptop but on, on the others (Windows 7 Upgrade).
      I also ensured that in omv shared folders I enabled sambashare under ACL, for me this worked.....if you get this working, open explorer then start powershell as administrator and type Get-SmbConnection hit enter and it will tell what version of smb 10 is using.
      There is a lot of information around regarding this, but if it doesn't work first a lot seems to be trial and error, there's also a command line option you can run to ensure that smb 3 is enabled.
      I found it all very much hit and miss....but the consensus was that the problem was with 10 rather than what one was trying to connect too.
    • Exact same problem here.

      Upgrade from (a fine working) OMV 2.x to 3.0.79 via clean install.
      After the installation there were also some troubles updating to 3.0.80 via the web gui, but somehow managed it via ssh (at least i hope so).

      The OMV Server ist not visible in the windows network sektion, neither reachable over \\ip. Same for an android phone with total commander.
      Ping works.
      SSH works.
      DNS are set (tried the ip of my router an
      ACL are set to the user and smb service.

      Tried with an update .80 Version and with a fresh installed .079. At the last one, the only changes were creating an user and a smb share. Same results.
      Also FTP seems not to work, so maybe a more general problem with permissions/shares/whatever?
    • Domain names all ( network settings, smb and windows) on default settings "WORKGROUP".

      Windows error message is:
      "Auf \\192.... konnte nicht zugegriffen werden. Vergewissern Sie sich, dass der Name richtig geschrieben wurde. Möglicherweise besteht ein Netzwerkfehler."
      (Not able to access \\192.... Check the spelling of [the servers] name. Maybe there is a network error).

      Windows trouble shooting:
      "Die Verbindung wird von der Remotegerät bzw. der Ressource nicht akzeptiert."
      (Remote device or resource refused the connection)

      Edit: After following geaves link...still no luck. It's like there is no server at all (same windows error message, when entering a random ip).

      The post was edited 2 times, last by ThatGuy ().

    • ifconfig:

      Source Code

      1. eth0 Link encap:Ethernet Hardware Adresse xx:xx:xx:xx:xx:xx
      2. inet Adresse: Bcast: Maske:
      4. RX packets:99 errors:0 dropped:0 overruns:0 frame:0
      5. TX packets:78 errors:0 dropped:0 overruns:0 carrier:0
      6. Kollisionen:0 Sendewarteschlangenlänge:1000
      7. RX bytes:12854 (12.5 KiB) TX bytes:21794 (21.2 KiB)
      8. lo Link encap:Lokale Schleife
      9. inet Adresse: Maske:
      10. inet6-Adresse: ::1/128 Gültigkeitsbereich:Maschine
      11. UP LOOPBACK RUNNING MTU:65536 Metrik:1
      12. RX packets:0 errors:0 dropped:0 overruns:0 frame:0
      13. TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
      14. Kollisionen:0 Sendewarteschlangenlänge:1
      15. RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)
      Display All
    • Same issue here, with a clean install.

      Note that from any guest OS the smb server is unreachable.

      The problem seems with the daemon / configuration, since we can clearly see that the daemon is not listening at all :


      1. tcp 0 0* LISTEN 1194/nginx -g daemo
      2. tcp 0 0* LISTEN 1067/sshd
      3. tcp 0 188 ESTABLISHED 3644/0
      4. tcp 0 0 TIME_WAIT -
      5. tcp 0 0 TIME_WAIT -
      6. tcp 0 0 ESTABLISHED 1197/nginx: worker
      7. tcp6 0 0 :::22 :::* LISTEN 1067/sshd
      8. udp 0 0* 1092/avahi-daemon:
      9. udp 0 0* 1092/avahi-daemon:
      10. udp6 0 0 :::60397 :::* 1092/avahi-daemon:
      11. udp6 0 0 :::5353 :::* 1092/avahi-daemon:
      Display All

      And worst, the daemon is not started at all (no process running) despite what is stated in the webui.
    • Hi ThatGuy
      Hast du den Router neugestartet es kann vielleicht sein das er zwei gleiche IP vergeben hat oder er sonst irgendwie hängt, du hast ja ftp ja auch nicht.
      Oder ändere die Netzwerk Einstellung auf DHCP

      Gesendet von meinem SM-G935F mit Tapatalk Visit on and help us, The Germany Forum :thumbsup:
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)

      The post was edited 1 time, last by Wolf2000 ().

    • Wolf2000 wrote:

      Hast du den Router neugestartet es kann vielleicht sein das er zwei gleiche IP vergeben hat oder er sonst irgendwie hängt, du hast ja ftp ja auch nicht.
      Oder ändere die Netzwerk Einstellung auf DHCP
      I was going to suggest that....sorry I had to use google translate......I set my omv with dhcp, however my router has a setting to 'always this ip address' which is technically dynamic all you have to do is restart the device to enable it. Also most routers act as dns thereby storing hostname to ip address, if I use a static ip the router does not pick up the host and there is no way of adding that information to the router.

      Another issue regarding W10 is that it fails to find any network computers if you login with a microsoft id, but it does work if you login with a local id.