Docker installation and plugin purge error

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Docker installation and plugin purge error

      I failed to install docker or purge the docker-plugin(it's ok to just remove the plugin). I tried the steps in this ticket, it worked until i restart the machine. Any idea

      Source Code

      1. Setting up docker-engine (17.05.0~ce-0~debian-jessie) ...
      2. Job for docker.service failed. See 'systemctl status docker.service' and 'journalctl -xn' for details.
      3. invoke-rc.d: initscript docker, action "start" failed.
      4. dpkg: error processing package docker-engine (--configure):
      5. subprocess installed post-installation script returned error exit status 1

      Source Code

      1. Purging configuration files for openmediavault-docker-gui (3.1.8) ...
      2. Failed to stop docker.socket: Unit docker.socket not loaded.
      3. dpkg: error processing package openmediavault-docker-gui (--purge):
      4. subprocess installed post-removal script returned error exit status 5
      5. Errors were encountered while processing:
      6. openmediavault-docker-gui
      7. E: Sub-process /usr/bin/dpkg returned an error code (1)
      It seems to be resolved after i manaully cleaned up the docker configuration by executing

      Source Code

      1. rm -r /var/lib/docker
      omv 3.0.84(stable) | 64 bit | 4.9.0 backport kernel | omvextrasorg 3.4.26

      The post was edited 1 time, last by popdisk ().