Errors on trying Plugins Check and Update Management Check

    • OMV 3.x
    • Resolved
    • Update
    • Errors on trying Plugins Check and Update Management Check

      Been using OMV for about a week now on a new build. Installed 3.0.76 (latest at the time), subsequently used OMV's update management to install some updates and used Plug-ins to install openmediavault-minidlna 3.3.10. Problems occurred at 3.0.79, and now at 3.0.80 (manually updated via apt-get).

      Not sure what I did that broke the "Check" function in Plugins and in Update Management (both in the OMV interface). Both fail with the same error (detailed error report in the attached file).

      I've tried the indicated dpkg --configure -a command, which ran but didn't resolve the problem. Also tried apt-get update and apt-get dist-upgrade - again, ran but didn't solve the issue.

      I do see a HTTP404 error at the end of the error list, but that seems to be addressed by "ignoredm or old ones used"

      What do I need to do to get the Check function working again?

    • File /etc/apt/sources.list.d/omv-extras-org.list below. Note that it is "-org.list" not ".org.list" - not sure if that's a problem or was a typo. The ".org.list" filedoes not exist in my installation. Line numbers below were added by the "Code" format and are not in the actual file.

      Source Code

      1. # This is file is generated.
      2. # OMV-Extras repos
      3. #
      4. #
      5. deb jessie main
    • Wolf2000 wrote:


      OK, I did an su -, then ran
      apt-get clean

      Both ran, but no difference when I tried the Check functions in OMV's user interface.

      Then, I noticed that the OMV-Extras menu item in OMV has a button Apt Clean. Tried it, no error messages. Got a message to Reload the page, which I did. Then tried Check - still no joy - same error as before.

      Then, rebooted and tried Apt Clean, reloaded the page, tried Check, still got same error.

      Wondering if reinstalling OMV and setting it up again may be the best route...
    • Hi
      apt-get install --reinstall Openmediavault

      dpkg -i openmediavault-omvextrasorg_latest_all3.deb

      If it does not work:

      apt-get purge openmediavault-omvextrasorg Visit on and help us, The Germany Forum :thumbsup:
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)
    • Well, I gave up on trying to resolve the issues. Thanks for the suggestions, subzero79, wolf2000, and The Master. Unfortunately, I wasn't successful with them. I had most of my notes on customizations, or at least browser links, so getting back fully operational didn't take too long.

      I downloaded 3.0.79 and did a clean install. Then, upgraded via Update Management to 3.0.81. "Check" works in both Update Management and in Plug-ins.

      Just finished doing a Clonezilla backup of my /dev/sda disk, just in case.

      Next step is to install omv-extras. I'll do that using Wolf2000's suggestions for the fix:
      dpkg -i openmediavault-omvextrasorg_latest_all3.deb