Samba - activated but not reachable

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Samba - activated but not reachable

      Hi team,

      I have upgraded to OMV 3.x on a Dell T20 microserver and installed OMV on a USB thumbdrive.

      So far, I can reach the admin console via the webinterface and make all necessary setting but even after activating samba multiple times, setting up shares and passing them on to the Samba plugin in OMV, I still can't access the shares from the other computers within my home network.

      In the dashboard section I can see that the plugin is active and running.

      I have assigned DHCP to the NAS/OMV but the IP is constantly leased on 192.168.0.219 (as I had issued with DNS resolving and apt-get update while I assigned a fixed IP).

      Does anyone have an idea what the problem could be or what else i could try? Every time when I try to access the samba share via network folder in windows I get an error message that the source is not reachable.

      Thanks for help and guidance on this, very much appreciated. Feel like I am getting out of ideas what to do.
    • Forgive the user the password again?
      And is the USB drive not full?
      Through the google translator it was difficult to understand.
      forum-bpi.de Visit on and help us, The Germany Forum :thumbsup:
      github.com/Wolf2000Pi
      Banana Pi /Armbian 3.4.109 / Openmediavault 2.x
      Banana Pi /Armbian 4.11.5-sunxi / Openmediavault 3.0.xx (Test)
      Dell Inspiron One 2205 | Openmediavault 3.0.xx / Kernel 4.7 (Test)
    • nomax wrote:

      I have assigned DHCP to the NAS/OMV but the IP is constantly leased on 192.168.0.219 (as I had issued with DNS resolving and apt-get update while I assigned a fixed IP).
      Had the same issue; adding 8.8.8.8 to the DNS servers in "interfaces" solved it.

      Regarding your Samba issue, there could be a lot of issues. Search the forum and try what has already been proposed, If you do not find a solution, post here what you have tried and what the result was.

      This full-install video might also be helpfull.
      Odroid HC2 - armbian - OMV4.x | Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 (rsnapshot) - 1x Intenso SSD 120GB - OMV4.x 64bit
      :!: Backup - Solutions to common problems in OMV - Must see OMV setup videos - OMV4 Documentation :!:

      The post was edited 1 time, last by macom: added link to video ().

    • Did you have configured the shared folder privileges? With this information the service configurations are build. If you do not configure the access privileges for the users for each share you won't be able to access it via SMB for example.
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • So far, I have configured a user in order to access the share drives and have provided via ACLs the privs to that user.

      Furthermore what makes the cookie crumble for me is that I can not even see the OMV server/NAS within the network shares view. My rationale is, if it was a problem with access privileges I would at least be able to see the machine on the network but get error messages when it comes to connecting to the shares.

      Or am I far off the track?
    • Do you have the same workgroup name on server (general settings page for SMB/CIFS) and clients?

      Also look here: forum.openmediavault.org/index…res-not-visible/?pageNo=1
      Odroid HC2 - armbian - OMV4.x | Asrock Q1900DC-ITX - 16GB - 2x Seagate ST3000VN000 (rsnapshot) - 1x Intenso SSD 120GB - OMV4.x 64bit
      :!: Backup - Solutions to common problems in OMV - Must see OMV setup videos - OMV4 Documentation :!:

      The post was edited 1 time, last by macom ().

    • Hi guys,

      sorry for the delay in getting back to you. To answer your queries;

      geaves wrote:

      Are your other machines W10?
      Can you ping the ip of omv and get a reply from your windows machine?
      Have you tried from explorer/file manager, select network then in the location box type the ip address of omv?

      >> Yes, all machines are running W10. Yes, I can confirm that a ping from the other machines to the OMV box is successful. Furthermore I can see both machines in the DHCP clients sections of the main router. No issues with this one.
      I tried from explorer/file manager to access both IP and name of the box ('OPENMEIDAVAULT") but no luck - I always get the message that it's not possible to access \\192.168.0.219 with error code 0x80004005 (Unknown error). Within the OMV control panel I can see that Samba is activated and running (both dots are green).


      macom wrote:

      Do you have the same workgroup name on server (general settings page for SMB/CIFS) and clients?

      Also look here: forum.openmediavault.org/index…res-not-visible/?pageNo=1

      >> That did the trick!! Worked!!



      geaves wrote:

      macom wrote:

      Do you have the same workgroup name on server (general settings page for SMB/CIFS) and clients?

      Also look here: forum.openmediavault.org/index…res-not-visible/?pageNo=1
      That was going to be my next question :)
      [/quote]Yes, done already.
    • nomax wrote:

      tried from explorer/file manager to access both IP and name of the box ('OPENMEIDAVAULT") but no luck - I always get the message that it's not possible to access \\192.168.0.219 with error code 0x80004005 (Unknown error).
      Ok, initially I don't believe this is a samba issue, you should see OMV on your network without Samba even being activated, the problem is W10, I spent enough time trying to get my W10 to see OMV, the problem is there no fix to fix all, so I'll try and outline what I did to get this to work.

      OMV

      Network>>>>Domain name this should be same as your windows workgroup click save and then agree to apply changes
      Network>>>>Interfaces double click, scroll down and enter your network dns, this is probably your router, click save and then agree to apply changes


      W10

      This is the real problem as there is no simple fix and no one fix will solve it.

      Control Panel>>>>Network and Sharing Center

      Active Networks should be private
      Click change advanced sharing settings and check, Turn on network discovery and file and print sharing, click save changes if it's not grayed out.
      Click on Connections>>>Properties>>>TCP/IPv4>>>Properties>>>Advanced>>>Wins Tab>>>NetBIOS Setting change this to Enable NetBIOS over TCP/IP

      Control Panel>>>Programs and Features left hand side Turn Windows features on or off, ensure that SMB 1.0/CIFS File Sharing Support and SMB Direct are checked.

      This is where is it becomes very hit and miss, after doing the above reboot both and see if you are still getting the error, if you are then you will need to try some or all of the following;

      This has been doing the rounds as another solution;

      1/ run cmd as admin
      2/ sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
      3/ sc.exe config mrxsmb20 start= disabled
      Restart and you are done!

      There are also a couple of registry keys you should check;

      Regedit......HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Servies\LanmanServer\Parameters

      on the right you should see SMB1 and SMB2 with the type REG_DWORD these will either have a (1) = enabled or (0) = disabled if either are disabled enable them.

      I also recently found the following but I haven't used this option, again some have with success you'll have to excuse me because I shall copy and paste the info as the link does not take you to the post, you do not have to download the group policy installer, just type gpedit in cortana.

      I just found this method and it worked for me.
      The system in question was a brand new from th3e box Dell 3050 NUC.
      After adding a 64GB thumb drive I updated to the latest Windows 10 on 5/19/2016.
      The Nuc was added to an existing workgroup with 4 other Windows 10 systems already operating without issue.
      The NAS is a Thecus 4200 ECO and all systems on the network had mapped drives off of the NAS.
      If you're reading this you had the same issue as I, Windows 10 wouldn't recognize the NAS. In my case I could ping it but no more; I could not map drives with any method. I tried a dozen different ways including those in this thread unsuccessfully. Finally I stumbled on a fix for Windows 7 and a Buffalo Terastation and while nothing was the same their symptoms were. I tried the fix below and restarted.
      At first I got the message again but as I was wondering what to do next I saw the NAS appear in my network listings. I include that to say patience in needed in the first restart. I had a couple of fixes that worked before but weren't persistent so I restarted again and after allowing the system to catchup - initially it complained it couldn't reconnect the mapped drive - the drive appeared in explorer as it should.
      To carry out this process you'll need access to the group policy editor. Unfortunately if you type GPEDIT.MSC in the run box it may say there's no such program on the system. If you have a 64 bit system it may run; if so hurray. Otherwise you'll have to download the plugin from here.
      Download Group Policy Editor Installer
      Extract the setup file and run it.
      Now Go to ‘SysWOW64’ Folder located at C:\Windows
      From Here Copy the following

      • GroupPolicy Folder
      • GroupPolicyUsers Folder
      • Gpedit.msc
      Paste these items in C:\Windows\System and C:\Windows\System32

      Once the plugin is installed open the run box, type GpEdit.msc
      Browse to "Local Policies" -> "Security Options". Now look for the entry "Network Security: LAN Manager authentication level" and open it. Click on the dropdown menu and select "Send LM & NTLM - use NTLMv2 session security if negotiated". Apply the settings.


      With that done go to In the Network and sharing center -->Advanced sharing
      Make sure your network is set to private (Work/Home)
      • Enable network discovery
      • Turn on file and print sharing and insure the box for automatic setup is checked. It should be by default.
      • Change HomeGroup Connections from Allow Windows . . . to Use user accounts and passwords to connect to other computers
      • Under All Networks Turn off password protected sharing
      Restart and take a deep breath while the system processes the changes. Your NAS should appear in a minute or three :)
      The usual caveat here; this worked for me without any side effects. I'm not responsible if it doesn't work for you, you lose data - I don't see how you could - or your system crashes.

      This is as much as I have done, whilst it took the best part of day and a lot of google research as this is an on going problem with W10......and I'll throw you something else that I had to research.
      My printer is connected to my W10 and shared to the household, but my Linux Mint could not locate it!! Why? because the MS workaround is to ensure that SMB1 is set in the registry.

      Perhaps one day MS will ensure that their products work in a multi network environment (that's my soap box quote)

      Good luck...
    • Hi guys,

      sorry for the delay in getting back to you. To answer your queries;

      geaves wrote:

      Are your other machines W10?
      Can you ping the ip of omv and get a reply from your windows machine?
      Have you tried from explorer/file manager, select network then in the location box type the ip address of omv?

      >> Yes, all machines are running W10. Yes, I can confirm that a ping from the other machines to the OMV box is successful. Furthermore I can see both machines in the DHCP clients sections of the main router. No issues with this one.
      I tried from explorer/file manager to access both IP and name of the box ('OPENMEIDAVAULT") but no luck - I always get the message that it's not possible to access \\192.168.0.219 with error code 0x80004005 (Unknown error). Within the OMV control panel I can see that Samba is activated and running (both dots are green).


      macom wrote:

      Do you have the same workgroup name on server (general settings page for SMB/CIFS) and clients?

      Also look here: forum.openmediavault.org/index…res-not-visible/?pageNo=1

      >> That did the trick!! Worked!!



      geaves wrote:

      macom wrote:

      Do you have the same workgroup name on server (general settings page for SMB/CIFS) and clients?

      Also look here: forum.openmediavault.org/index…res-not-visible/?pageNo=1
      That was going to be my next question :)

      Yes, done already.



      Very big thanks for collecting here all the different methods to be act on!

      In my case, the change of the FAKE start-stop-daemon did the trick. Now I will perform a backup of the stick and then afterwards run an apt-get install dpkg --reinstall in order to fix any issues that may have happened during the installation.

      Anyone know a bit more about this problem in detail? seems still a bit weird that a fake daemon is run and set up instead of just highlighting broken packages.

      The post was edited 1 time, last by The Master ().