Plex plugin issue

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Plex plugin issue

      Hi everyone,

      I've made an update for plexmedia-plugin and the new version was unable read avi files ...

      Si I've decided to uninstall and reinstall it but I can't add it to omv anymore ... :(

      Could-you help me to wipe it please ?

      Here's the install log if it can help :

      Reading package lists...
      Building dependency tree...
      Reading state information...
      The following extra packages will be installed:
      avahi-utils git git-core git-man liberror-perl plexmediaserver
      Suggested packages:
      git-daemon-run git-daemon-sysvinit git-doc git-el git-email git-gui gitk
      gitweb git-arch git-cvs git-mediawiki git-svn
      Recommended packages:
      patch
      The following NEW packages will be installed:
      avahi-utils git git-core git-man liberror-perl
      openmediavault-plexmediaserver plexmediaserver
      0 upgraded, 7 newly installed, 0 to remove and 3 not upgraded.
      Need to get 107 MB/112 MB of archives.
      After this operation, 256 MB of additional disk space will be used.
      Get:1 downloads.plex.tv/repo/deb/ public/main plexmediaserver amd64 1.7.5.4035-313f93718 [107 MB]
      Get:2 dl.bintray.com/openmediavault-…-developers/erasmus-plex/ jessie/main openmediavault-plexmediaserver all 3.8.1 [21.5 kB]
      Fetched 107 MB in 5min 4s (350 kB/s)
      Selecting previously unselected package avahi-utils.
      (Reading database ... (Reading database ... 5%(Reading database ... 10%(Reading database ... 15%(Reading database ... 20%(Reading database ... 25%(Reading database ... 30%(Reading database ... 35%(Reading database ... 40%(Reading database ... 45%(Reading database ... 50%(Reading database ... 55%(Reading database ... 60%(Reading database ... 65%(Reading database ... 70%(Reading database ... 75%(Reading database ... 80%(Reading database ... 85%(Reading database ... 90%(Reading database ... 95%(Reading database ... 100%(Reading database ... 38504 files and directories currently installed.)
      Preparing to unpack .../avahi-utils_0.6.31-5_amd64.deb ...
      Unpacking avahi-utils (0.6.31-5) ...
      Selecting previously unselected package liberror-perl.
      Preparing to unpack .../liberror-perl_0.17-1.1_all.deb ...
      Unpacking liberror-perl (0.17-1.1) ...
      Selecting previously unselected package git-man.
      Preparing to unpack .../git-man_1%3a2.1.4-2.1+deb8u3_all.deb ...
      Unpacking git-man (1:2.1.4-2.1+deb8u3) ...
      Selecting previously unselected package git.
      Preparing to unpack .../git_1%3a2.1.4-2.1+deb8u3_amd64.deb ...
      Unpacking git (1:2.1.4-2.1+deb8u3) ...
      Selecting previously unselected package git-core.
      Preparing to unpack .../git-core_1%3a2.1.4-2.1+deb8u3_all.deb ...
      Unpacking git-core (1:2.1.4-2.1+deb8u3) ...
      Selecting previously unselected package plexmediaserver.
      Preparing to unpack .../plexmediaserver_1.7.5.4035-313f93718_amd64.deb ...
      Unpacking plexmediaserver (1.7.5.4035-313f93718) ...
      Selecting previously unselected package openmediavault-plexmediaserver.
      Preparing to unpack .../openmediavault-plexmediaserver_3.8.1_all.deb ...
      Unpacking openmediavault-plexmediaserver (3.8.1) ...
      Processing triggers for man-db (2.7.0.2-5) ...
      Processing triggers for systemd (215-17+deb8u7) ...
      Processing triggers for mime-support (3.58) ...
      Processing triggers for openmediavault (3.0.81) ...
      Restarting engine daemon ...
      Setting up avahi-utils (0.6.31-5) ...
      Setting up liberror-perl (0.17-1.1) ...
      Setting up git-man (1:2.1.4-2.1+deb8u3) ...
      Setting up git (1:2.1.4-2.1+deb8u3) ...
      Setting up git-core (1:2.1.4-2.1+deb8u3) ...
      Setting up plexmediaserver (1.7.5.4035-313f93718) ...
      Created symlink from /etc/systemd/system/multi-user.target.wants/plexmediaserver.service to /etc/systemd/system/plexmediaserver.service.
      Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      dpkg: error processing package plexmediaserver (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of openmediavault-plexmediaserver:
      openmediavault-plexmediaserver depends on plexmediaserver | plexmediaserver-installer; however:
      Package plexmediaserver is not configured yet.
      Package plexmediaserver-installer is not installed.

      dpkg: error processing package openmediavault-plexmediaserver (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      plexmediaserver
      openmediavault-plexmediaserver

      >>> *************** Error ***************

      <<< *************************************

      >>> *************** Error ***************

      <<< *************************************

      >>> *************** Error ***************
    • In the Plugin tab, there is an uninstall button right next to the install button you used to install it. -or- from the command line apt-get remove openmediavault-plexmediaserver plexmediaserver
      omv 4.1.8.2 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.8
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please read this before posting a question.
      Please don't PM for support... Too many PMs!
    • I was having the same issue. Turned out to be a permissions issue while creating the /var/lib/plexmediaserver/Library directory during installation. I was able recursively update the parent folder and manually install Plex. Currently streaming a movie in HD. Please post the contents of /var/log/daemon.log.
    • Hi Lekim36, here's the content of my daemon.log

      ty for the help !

      root@ANA:/var/log# vi daemon.log
      Jul 15 02:45:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 03:00:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 03:13:36 ANA rrdcached[1015]: flushing old values
      Jul 15 03:13:36 ANA rrdcached[1015]: rotating journals
      Jul 15 03:13:36 ANA rrdcached[1015]: started new journal /var/lib/rrdcached/journal/rrd.journal.1500081216.945200
      Jul 15 03:13:36 ANA rrdcached[1015]: removing old journal /var/lib/rrdcached/journal/rrd.journal.1500074016.945192
      Jul 15 03:15:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 03:30:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 03:45:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 04:00:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 04:13:36 ANA rrdcached[1015]: flushing old values
      Jul 15 04:13:36 ANA rrdcached[1015]: rotating journals
      Jul 15 04:13:36 ANA rrdcached[1015]: started new journal /var/lib/rrdcached/journal/rrd.journal.1500084816.945199
      Jul 15 04:13:36 ANA rrdcached[1015]: removing old journal /var/lib/rrdcached/journal/rrd.journal.1500077616.945193
      Jul 15 04:15:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 04:30:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 04:45:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 05:00:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 05:13:36 ANA rrdcached[1015]: flushing old values
      Jul 15 05:13:36 ANA rrdcached[1015]: rotating journals
      Jul 15 05:13:36 ANA rrdcached[1015]: started new journal /var/lib/rrdcached/journal/rrd.journal.1500088416.945227
      Jul 15 05:13:36 ANA rrdcached[1015]: removing old journal /var/lib/rrdcached/journal/rrd.journal.1500081216.945200
      Jul 15 05:15:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 05:30:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 05:45:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 06:00:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 06:13:36 ANA rrdcached[1015]: flushing old values
      Jul 15 06:13:36 ANA rrdcached[1015]: rotating journals
      Jul 15 06:13:36 ANA rrdcached[1015]: started new journal /var/lib/rrdcached/journal/rrd.journal.1500092016.945194
      Jul 15 06:13:36 ANA rrdcached[1015]: removing old journal /var/lib/rrdcached/journal/rrd.journal.1500084816.945199
      Jul 15 06:15:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 06:30:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 06:45:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 07:00:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 07:13:36 ANA rrdcached[1015]: flushing old values
      Jul 15 07:13:36 ANA rrdcached[1015]: rotating journals
      Jul 15 07:13:36 ANA rrdcached[1015]: started new journal /var/lib/rrdcached/journal/rrd.journal.1500095616.945198
      Jul 15 07:13:36 ANA rrdcached[1015]: removing old journal /var/lib/rrdcached/journal/rrd.journal.1500088416.945227
      Jul 15 07:15:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 07:30:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 07:30:01 ANA systemd[1]: Expecting device dev-disk-by\x2duuid-7AF4F122F4F0E175.device...
      Jul 15 07:30:01 ANA systemd[1]: Expecting device ST500LT012-1DG142 BOOT...
      Jul 15 07:30:01 ANA systemd[1]: Expecting device ST500LT012-1DG142 Stock...
      Jul 15 07:30:01 AN
      A systemd[1]: Starting Run anacron jobs...
      Jul 15 07:30:01 ANA systemd[1]: Started Run anacron jobs.
      Jul 15 07:31:31 ANA systemd[1]: Job dev-disk-by\x2duuid-D29E66409E661D6B.device/start timed out.
      Jul 15 07:31:31 ANA systemd[1]: Timed out waiting for device ST500LT012-1DG142 Stock.
      Jul 15 07:31:31 ANA systemd[1]: Dependency failed for /media/D29E66409E661D6B.
      Jul 15 07:31:31 ANA systemd[1]: Job dev-disk-by\x2duuid-9EBC\x2dBF8E.device/start timed out.
      Jul 15 07:31:31 ANA systemd[1]: Timed out waiting for device ST500LT012-1DG142 BOOT.
      Jul 15 07:31:31 ANA systemd[1]: Dependency failed for /media/9EBC-BF8E.
      Jul 15 07:31:31 ANA systemd[1]: Job dev-disk-by\x2duuid-7AF4F122F4F0E175.device/start timed out.
      Jul 15 07:31:31 ANA systemd[1]: Timed out waiting for device dev-disk-by\x2duuid-7AF4F122F4F0E175.device.
      Jul 15 07:31:31 ANA systemd[1]: Dependency failed for /media/7AF4F122F4F0E175.
      Jul 15 07:45:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 08:00:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 08:13:36 ANA rrdcached[1015]: flushing old values
      Jul 15 08:13:36 ANA rrdcached[1015]: rotating journals
      Jul 15 08:13:36 ANA rrdcached[1015]: started new journal /var/lib/rrdcached/journal/rrd.journal.1500099216.945194
      Jul 15 08:13:36 ANA rrdcached[1015]: removing old journal /var/lib/rrdcached/journal/rrd.journal.1500092016.945194
      Jul 15 08:15:01 ANA rrdcached[1015]: Received FLUSHALL
      Jul 15 08:30:01 ANA rrdcached[1015]: Received FLUSHALL
    • I'm having the same problem but have a few additional comments:
      1. I'm waiting for a Time Machine backup to complete. Then I'll try rebooting between steps. Hopefully this will help clean up some of the mess.
      2. Even though PMS is uninstalled, the sidebar still shows "Plex Media Server" in Sevices.
      3. Whenever I click this entry, the system throws an error message: "Failed to execute XPath query <cr><lf> //services/plexmediaserver."
      4. Ykzel is going to reinstall OMV. For me this is really unacceptable. On my system OMV sits on an internal USB flash drive, and it has to be removed to reinstall OMV because the system can't boot from a drive with an install iso while the system drive is present. Just reinstalling OMV is a 2-3 hour process since the ~50 lb. NAS system has to be removed from the media cabinet and moved elsewhere, a terminal & keyboard attached, the system drive removed, and OMV reinstalled. Then OMV has to be reconfigured and the NAS system returned to the media cabinet. And there's no guarantee the PMS plugin will behave any differently after OMV is reinstalled.
      5. When OMV is reinstalled, what happens to existing data on the system's hard drives? Are the data lost, or do they stay on the drives?
      6. Is reinstalling OMV a common solution for problems like this? If so, is there anyway to reinstall by changing the BIOS settings and not having to remove the internal system flash drive?
      7. Can one reinstall OMV on a headless system, or does one have to connect monitor & keyboard?
      8. Is the plugin really worth all this trouble versus just installing PMS under Debian through the CLI?
      9. I'm a Plex Pass member and want to use the Plex Pass version of PMS. Considering this, is the plugin really worth it?
      10. Lekim36: when you mention installing PMS "manually," do you mean a Debian install outside OMV?
      11. Lekim36: From CLI on my system, running "ls -l" while in /var/lib only returns an entry for "postfix." When you say you "recursively update the parent folder," exactly what parent folder do you mean: /var/lib, /var/lib/plexmediaserver, or another?
      12. There's no "/var/log/daemon.log" on my system.
      13. Suppose I went the route of installing PMS under Debian and without using the plugin. What's the recommended way to clean up things in OMV, like the Services > Plex Media Server entry?
    • Just an update.
      1. Rebooting got rid of the PMS item in the sidebar, but the XPath error message still sometimes crops up in unexpected places.
      2. {Uninstall plugin > reboot > reinstall plugin > reboot} does not fix the problem.
        • The first time I tried to install the plugin the installation seemed successful, but the PMS did not start. Following suggestions in the forums, I then tried uninstalling and reinstalling the plugin. But, except for the initial install, it does not install without errors.
      3. I think my next step will be to try installing a linux version of PMS in docker.
      4. But before doing so, I'd like to clean up all traces of the unsuccessful Plex plugin installation. Do you have any suggestions for the best way to do this?

    • What do I do now?

      Getting this:

      Restarting engine daemon ...
      Setting up avahi-utils (0.6.31-5) ...
      Setting up liberror-perl (0.17-1.1) ...
      Setting up git-man (1:2.1.4-2.1+deb8u4) ...
      Setting up git (1:2.1.4-2.1+deb8u4) ...
      Setting up git-core (1:2.1.4-2.1+deb8u4) ...
      Setting up plexmediaserver (1.8.1.4139-c789b3fbb) ...
      Created symlink from /etc/systemd/system/multi-user.target.wants/plexmediaserver.service to /lib/systemd/system/plexmediaserver.service.
      Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details.
      dpkg: error processing package plexmediaserver (--configure):
      subprocess installed post-installation script returned error exit status 1
      dpkg: dependency problems prevent configuration of openmediavault-plexmediaserver:
      openmediavault-plexmediaserver depends on plexmediaserver | plexmediaserver-installer; however:
      Package plexmediaserver is not configured yet.
      Package plexmediaserver-installer is not installed.

      dpkg: error processing package openmediavault-plexmediaserver (--configure):
      dependency problems - leaving unconfigured
      Errors were encountered while processing:
      plexmediaserver
      openmediavault-plexmediaserver

      >>> *************** Error ***************

      <<< *************************************
      OMV 4.x on intel
    • Now when I log in to the WebGUI I get this:

      ---

      Failed to execute XPath query '//services/plexmediaserver'.

      Error #0:
      exception 'OMV\Config\DatabaseException' with message 'Failed to execute XPath query '//services/plexmediaserver'.' in /usr/share/php/openmediavault/config/database.inc:78
      Stack trace:
      #0 /usr/share/openmediavault/engined/module/plexmediaserver.inc(58): OMV\Config\Database->get('conf.service.pl...')
      #1 /usr/share/openmediavault/engined/rpc/services.inc(56): OMVModulePlexMediaServer->getStatus()
      #2 [internal function]: OMVRpcServiceServices->getStatus(Array, Array)
      #3 /usr/share/php/openmediavault/rpc/serviceabstract.inc(124): call_user_func_array(Array, Array)
      #4 /usr/share/php/openmediavault/rpc/rpc.inc(86): OMV\Rpc\ServiceAbstract->callMethod('getStatus', Array, Array)
      #5 /usr/sbin/omv-engined(536): OMV\Rpc\Rpc::call('Services', 'getStatus', Array, Array, 1)
      #6 {main}

      ---
      OMV 4.x on intel
    • gderf wrote:

      Have you cleared your browser's cache?
      I still had the plug-in patly installed. Removed and disabled the service with the WebGUI. Oh and yes I did clear cache, thanks.

      BTW: I am on 3.0.88 on an intel i3.

      OMV:~# apt-get remove openmediavault-plexmediaserver plexmediaserver
      Reading package lists... Done
      Building dependency tree
      Reading state information... Done
      E: Unable to locate package openmediavault-plexmediaserver


      I do happen to have a local copy of plexmediaserver_1.7.6.4058-8fa494d15_amd64
      my attempt to dpkg -i plex plexmediaserver_1.7.6.4058-8fa494d15_amd64, while in /var/cache/apt/archives/, seemed to go well except plugin still needs to be installed and in doing so I get "Job for plexmediaserver.service failed. See 'systemctl status plexmediaserver.service' and 'journalctl -xn' for details."

      I sure would like to not reinstall/configure the OS. Looks like I am not the only one in this situation.

      Anyone figure out a fix?
      OMV 4.x on intel