Syncthing plugin - starting with STTRACE environment variable

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Maybe create a systemd override file to specify the strace stuff? Never had an issue with connections as long as settings were right and firewalls were not in the way.
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • That isn't an override file. An override file would be in /etc/systemd/system/syncthing.service.d. Did you try reading this wiki - docs.syncthing.net/dev/debugging.html
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • i did read the syncthing debugging FAQ,
      the only useful tidbit in there is :


      Source Code

      1. Under Unix (including Mac) the easiest way to run Syncthing with an environment variable set is to prepend the variable to the command line. I.e:
      2. $ STTRACE=model syncthing

      no mention of systemd override files.


      Source Code

      1. root@backup-nas:/etc/systemd/system# ls -lha /etc/systemd/system/syncthing.service.d
      2. ls: cannot access /etc/systemd/system/syncthing.service.d: No such file or directory
      3. root@backup-nas:/etc/systemd/system#

      There is no /etc/systemd/system/syncthing.service.d directory on the OMV installation ?
    • after some further reading :

      # systemctl edit syncthing@admin

      is supposed to create the directory "/etc/systemd/system/syncthing.service.d"

      which would contain an override file.

      Unfortunately :
      root@backup-nas:/etc/systemd/system# systemctl edit syncthing@admin
      Unknown operation 'edit'
      root@backup-nas:/etc/systemd/system# systemd --version
      systemd 215

      The systemctl edit functionality was only added in Systemd 218.

      Any further help would be much appreciated.
    • Tii wrote:

      no mention of systemd override files.
      This was my idea. I had no idea if it would work or not and I didn't read the wiki. I don't even use syncthing. I was just trying to throw ideas out there since no one else was responding.

      Tii wrote:

      There is no /etc/systemd/system/syncthing.service.d directory on the OMV installation ?
      No because the plugin doesn't create an override file. It doesn't need to exist unless there is an override file.

      Tii wrote:

      is supposed to create the directory "/etc/systemd/system/syncthing.service.d"
      Just create the directory yourself - mkdir -p /etc/systemd/system/syncthing.service.d
      omv 4.1.14 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.13
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • root@backup-nas:/etc/systemd/system/syncthing.service.d# cat override.conf
      [Service]
      Environment=STTRACE=connections

      followed by

      # systemctl daemon-reload
      and
      # systemctl restart syncthing@admin

      Still no extra info in the log.

      also :
      # systemd-delta
      0 overridden configuration files found.

      The post was edited 3 times, last by Tii ().

    • setting the environment variable in Windows enables debugging perfectly, as it does in other linux distributions
      C:\> set STTRACE=model

      I'm just not finding the correct way to set the variable in this distro

      Setting the environment variable in /lib/systemd/system/syncthing@.service works just fine, but that's a Bad Idea (tm).

      The post was edited 1 time, last by Tii ().

    • Place a file containing the following to /etc/systemd/system/syncthing@.service.d , run systemctl daemon-reload and restart the Syncthing service ( systemctl restart syncthing@admin ) :

      [Service]Environment=STTRACE=*your value*

      This is what solved it for me.

      The post was edited 1 time, last by Tii: revisiting this after extensive testing. ().

    • In the console terminal of Omv change into the user syncthing is supposed to be running.
      As root

      su username

      The run this

      SSTRACE=connections syncthing

      All output should be redirected to the current screen.

      systemctl edit doesn't work in default systemd of Debian.
      New wiki
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server