SAMBA not starting automatically, ok if started manually

    • OMV 3.x
    • Resolved

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • SAMBA not starting automatically, ok if started manually

      I'm trying to get my head around on why SAMBA is not starting automatically.
      The Enabled is of course set to on on the SMB config page.

      After a reboot I see no smb process:

      Source Code

      1. root@nas:~# ps aux |grep smbroot 1216 0.0 0.0 12732 2192 pts/0 S+ 13:46 0:00 grep smb


      but if I start it manually from the shell

      Source Code

      1. root@nas:~# /usr/sbin/smbd -D
      2. root@nas:~# ps aux |grep smb
      3. root 1271 1.0 0.1 283160 13908 ? Ss 13:49 0:00 /usr/sbin/smbd -D
      4. root 1275 0.0 0.0 12732 2240 pts/0 S+ 13:49 0:00 grep smb

      Everything works fine.

      Any tip?

      Thanks
    • Please post the output of

      Shell-Script

      1. # systemctl status smbd.service
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • Source Code

      1. root@nas:~# systemctl status smbd.service
      2. ● smbd.service - LSB: start Samba SMB/CIFS daemon (smbd)
      3. Loaded: loaded (/etc/init.d/smbd)
      4. Active: active (exited) since Thu 2017-07-06 13:40:08 BST; 1h 13min ago
      5. Jul 06 13:40:08 nas smbd[1133]: Starting SMB/CIFS daemon: smbd.
      6. Jul 06 13:40:08 nas systemd[1]: Started LSB: start Samba SMB/CIFS daemon (smbd).

      The post was edited 1 time, last by rs232 ().

    • donh wrote:

      Try enabling samba logs on the smb/cifs page. Set it back to none when done. Then look at the log for possible clues.

      Do you have this file? /sbin/start-stop-daemon.REAL

      Yes that file is available:

      Source Code

      1. root@nas:~# ls -la /sbin/start-stop-daemon.REAL
      2. -rwxr-xr-x 1 root root 32392 May 2 2016 /sbin/start-stop-daemon.REAL



      about the log this is the content:

      Source Code

      1. root@nas:~# tail -50 /var/log/samba/log.smbd
      2. [2017/07/06 10:26:13, 0] ../source3/smbd/server.c:1241(main)
      3. smbd version 4.2.14-Debian started.
      4. Copyright Andrew Tridgell and the Samba Team 1992-2014
      5. [2017/07/06 10:26:13, 1] ../lib/param/loadparm.c:1638(lpcfg_do_global_parameter)
      6. WARNING: The "null passwords" option is deprecated
      7. [2017/07/06 10:26:13, 2] ../source3/lib/tallocmsg.c:124(register_msg_pool_usage)
      8. Registered MSG_REQ_POOL_USAGE
      9. [2017/07/06 10:26:13, 2] ../source3/lib/dmallocmsg.c:78(register_dmalloc_msgs)
      10. Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
      11. [2017/07/06 13:07:14, 0] ../source3/smbd/server.c:1241(main)
      12. smbd version 4.2.14-Debian started.
      13. Copyright Andrew Tridgell and the Samba Team 1992-2014
      14. [2017/07/06 13:07:14, 1] ../lib/param/loadparm.c:1638(lpcfg_do_global_parameter)
      15. WARNING: The "null passwords" option is deprecated
      16. [2017/07/06 13:07:14, 2] ../source3/lib/tallocmsg.c:124(register_msg_pool_usage)
      17. Registered MSG_REQ_POOL_USAGE
      18. [2017/07/06 13:07:14, 2] ../source3/lib/dmallocmsg.c:78(register_dmalloc_msgs)
      19. Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
      20. [2017/07/06 13:09:54, 0] ../source3/smbd/server.c:1241(main)
      21. smbd version 4.2.14-Debian started.
      22. Copyright Andrew Tridgell and the Samba Team 1992-2014
      23. [2017/07/06 13:09:54, 1] ../lib/param/loadparm.c:1638(lpcfg_do_global_parameter)
      24. WARNING: The "null passwords" option is deprecated
      25. [2017/07/06 13:09:54, 2] ../source3/lib/tallocmsg.c:124(register_msg_pool_usage)
      26. Registered MSG_REQ_POOL_USAGE
      27. [2017/07/06 13:09:54, 2] ../source3/lib/dmallocmsg.c:78(register_dmalloc_msgs)
      28. Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
      29. [2017/07/06 13:49:35, 0] ../source3/smbd/server.c:1241(main)
      30. smbd version 4.2.14-Debian started.
      31. Copyright Andrew Tridgell and the Samba Team 1992-2014
      32. [2017/07/06 13:49:35, 1] ../lib/param/loadparm.c:1638(lpcfg_do_global_parameter)
      33. WARNING: The "null passwords" option is deprecated
      34. [2017/07/06 13:49:35, 2] ../source3/lib/tallocmsg.c:124(register_msg_pool_usage)
      35. Registered MSG_REQ_POOL_USAGE
      36. [2017/07/06 13:49:35, 2] ../source3/lib/dmallocmsg.c:78(register_dmalloc_msgs)
      37. Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
      38. [2017/07/06 14:56:58, 0] ../source3/smbd/server.c:1241(main)
      39. smbd version 4.2.14-Debian started.
      40. Copyright Andrew Tridgell and the Samba Team 1992-2014
      41. [2017/07/06 14:56:58, 1] ../lib/param/loadparm.c:1638(lpcfg_do_global_parameter)
      42. WARNING: The "null passwords" option is deprecated
      43. [2017/07/06 14:56:58, 2] ../source3/lib/tallocmsg.c:124(register_msg_pool_usage)
      44. Registered MSG_REQ_POOL_USAGE
      45. [2017/07/06 14:56:58, 2] ../source3/lib/dmallocmsg.c:78(register_dmalloc_msgs)
      46. Registered MSG_REQ_DMALLOC_MARK and LOG_CHANGED
      Display All
    • According to this link here is how to fix it. forum.openmediavault.org/index…?postID=147109#post147109
      mv /sbin/start-stop-daemon.REAL /sbin/start-stop-daemon

      My best guess is an installation issue caused it and it may be fairly common. If you can see anything in the install logs let us know. If you find it works I want to include it in this link forum.openmediavault.org/index…s-samba-Trouble-shooting/ . I am going into the back country for a few days. So if another moderator could add that to the first post that would be great.

      Thanks
      If you make it idiot proof, somebody will build a better idiot.

      The post was edited 1 time, last by donh ().

    • donh wrote:

      According to this link here is how to fix it. forum.openmediavault.org/index…?postID=147109#post147109
      mv /sbin/start-stop-daemon.REAL /sbin/start-stop-daemon

      My best guess is an installation issue caused it and it may be fairly common. If you can see anything in the install logs let us know. If you find it works I want to include it in this link forum.openmediavault.org/index…s-samba-Trouble-shooting/ . I am going into the back country for a few days. So if another moderator could add that to the first post that would be great.

      Thanks
      Unfortunately that didn't resolve.

      Just to clarify this is a fresh OMV 3.0 installation.

      2.x worked perfectly for years...
    • How do you have installed OMV? What hardware are you using?
      Absolutely no support through PM!

      I must not fear.
      Fear is the mind-killer.
      Fear is the little-death that brings total obliteration.
      I will face my fear.
      I will permit it to pass over me and through me.
      And when it has gone past I will turn the inner eye to see its path.
      Where the fear has gone there will be nothing.
      Only I will remain.

      Litany against fear by Bene Gesserit
    • It's a VM on VMWARE and it's a fresh installation from the ISO I have downloaded from the official openmediavault site.

      Having said that I have few users moaning about the lack of samba so had to quick re-build 2.x which worked out of the box at the first attempt.
    • I confirm this issue is still there in the latest v3.x ISO.
      I did a fresh install on a dedicated hardware, then installed omv-extras, then I was setting the shares.

      Dashboard indicators show green status, but I can't connect to shares until I start smbd manually via ssh console.
      Running smbd temporarily fixes samba, until next restart.

      [IMG:https://preview.ibb.co/itaKgv/omvsmbd.png]

      Any suggestions how where to look for the issue and to properly fix it?
      Thank you
    • babca wrote:

      I confirm this issue is still there in the latest v3.x ISO.
      I did a fresh install on a dedicated hardware, then installed omv-extras, then I was setting the shares.
      I have installed many times from that ISO and haven't had this issue.

      systemctl enable smbd.service should make it start at boot.
      omv 4.1.11 arrakis | 64 bit | 4.15 proxmox kernel | omvextrasorg 4.1.11
      omv-extras.org plugins source code and issue tracker - github

      Please read this before posting a question and this and this for docker questions.
      Please don't PM for support... Too many PMs!
    • #SOLVED

      $ systemctl enable smbd.service
      $ systemctl start smbd.service
      These commands did nothing for me.

      I checked an output of journalctl -r and noticed smbd[2122]: Warning: Fake start-stop-daemon called, doing nothing. message.

      This message is generated by current start-stop-daemon:

      Shell-Script

      1. $ cat /sbin/start-stop-daemon
      2. #!/bin/sh
      3. echo 1>&2
      4. echo 'Warning: Fake start-stop-daemon called, doing nothing.' 1>&2
      5. exit 0

      There is another start-stop-daemon available:

      Shell-Script

      1. $ ls -l /sbin/start-stop-daemon*
      2. -rwxr-xr-x 1 root root 94 Sep 8 17:42 /sbin/start-stop-daemon
      3. -rwxr-xr-x 1 root root 32392 May 2 2016 /sbin/start-stop-daemon.REAL

      So I replaced the REAL start-stop-daemon with the fake one:

      Shell-Script

      1. mv /sbin/start-stop-daemon /sbin/start-stop-daemon.FAKE
      2. mv /sbin/start-stop-daemon.REAL /sbin/start-stop-daemon


      It works now. Now I can see smbd successfully starting on boot: server smbd[2651]: STATUS=daemon 'smbd' finished starting up and ready to serve connections (output of journalctl -r).

      Thank you.

      The post was edited 1 time, last by babca ().