OMV + Docker + ZFS + SMB Oddities

    • OMV 3.x

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • OMV + Docker + ZFS + SMB Oddities

      I installed OMV latest 2-3 days ago, installed the ZFS plugin and imported my pool then set up the SMB share (as done in the past) and my wife and kids were back to watching TV/Movies from the share.

      I last night installed the docker plugin and was messing with various containers such as plex, couchpotato, transmission, etc etc and tonight I look and SMB shares are unavailable via network (they are showing as set up in SMB settings on OMV though), the ZFS pool has this stuff in it which was never there before AND the docker containers that were listed last night are ALL missing (i.e. they are not in the docker GUI anymore).

      My #1 concern is the 2+ TB of data gone? :cursing:

      Lance
      Images
      • omv.png

        208.21 kB, 1,249×923, viewed 84 times
    • That looks odd. Did you choose the root of the pool for docker ?
      I've would've created a special file system under the pool for docker.
      I have limited use of zfs, and certainly not in conjunction with docker and zfs as a storage driver.
      For now I would disable docker, keep your data safe.
      I'll test tomorrow see if I can replicate this in vm.
      chat support at #openmediavault@freenode IRC | Spanish & English | GMT+10
      telegram.me/openmediavault broadcast channel
      openmediavault discord server