Error Installing minidlna

    This site uses cookies. By continuing to browse this site, you are agreeing to our Cookie Policy.

    • Error Installing minidlna

      Hello!

      I'm using a version 3.0.59 OMV image on my raspberry pi 3, and I'm having problems installing the minidlna plugin. It appears to be a dependency error with ntp.service causing an issue in configuration after installation, but I don't have enough experience with this setup to tell what is causing the problem exactly. After the error, the gui login page no longer appears correctly, which is what has happened in the past for me after plugin installation errors, requiring me to reimage the sd card.

      Thank you for any insights you can offer!

      Here is the problem area of the installation log:

      Source Code

      1. Updating configuration database ...
      2. Running migration conf_3.0.68
      3. Updating configuration ...
      4. /usr/bin/deb-systemd-helper: error: unable to read ntp.service
      5. dpkg: error processing package openmediavault (--configure):
      6. subprocess installed post-installation script returned error exit status 1
      7. dpkg: dependency problems prevent configuration of openmediavault-minidlna:
      8. openmediavault-minidlna depends on openmediavault (>= 3.0.67); however:
      9. Package openmediavault is not configured yet.
      10. dpkg: error processing package openmediavault-minidlna (--configure):
      11. dependency problems - leaving unconfigured
      12. Processing triggers for libc-bin (2.19-18+deb8u6) ...
      13. Processing triggers for systemd (215-17+deb8u5) ...
      14. Errors were encountered while processing:
      15. openmediavault
      16. openmediavault-minidlna
      Display All
    • uninstall miniDLNA, then upgrade OMV to latest or at least > 3.067 that you can install miniDLNA.

      PD: You say that use OMV 3.0.59 that is < 3.0.67 requiered


      Source Code

      1. openmediavault-minidlna depends on openmediavault (>= 3.0.67); however:

      PD: No need to uninstall MiniDLNA if first you upgrade OMV to latest
      OMV 3.0.88 x64 on a HP T510, 8GB CF as Boot Disk & 32GB SSD 2,5" disk for Data, 4 GB RAM, CPU VIA EDEN X2 U4200 is x64 at 1GHz

      Post: HPT510 SlimNAS ; HOWTO Install Pi-Hole ; HOWTO install MLDonkey ; HOHTO Install ZFS-Plugin ; OMV_OldGUI ; ShellinaBOX ;
    • raulfg3 wrote:

      uninstall miniDLNA, then upgrade OMV to latest or at least > 3.067 that you can install miniDLNA.

      PD: You say that use OMV 3.0.59 that is < 3.0.67 requiered


      Source Code

      1. openmediavault-minidlna depends on openmediavault (>= 3.0.67); however:
      PD: No need to uninstall MiniDLNA if first you upgrade OMV to latest
      Thank you, where did you get that dependency information? When I was on 3.067 I had similar trouble with other plugins which ended up working when I switched to 3.0.59.
    • MrAngles wrote:

      plugin documents
      What exactly are you looking for? In my opinion, there is no reason to not fully update OMV before installing plugins.
      omv 4.0.14 arrakis | 64 bit | 4.13 backports kernel | omvextrasorg 4.1.1
      omv-extras.org plugins source code and issue tracker - github.com/OpenMediaVault-Plugin-Developers

      Please don't PM for support... Too many PMs!